Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Running ROMs from a Network Share



  • Pi Model or other hardware: Pi 4 4gig
    Power Supply used: Offical
    RetroPie Version Used 4.6
    Built From: Raspberry Pi Imager
    USB Devices connected: None
    Controller used: None (SSH)
    Error messages received: None
    Verbose log (if relevant):
    Guide used: https://retropie.org.uk/docs/Running-ROMs-from-a-Network-Share/

    I am trying to run my ROMs over my network. Since I have emulators on my PC as well, I want to have my directories changed. I followed the guide listed above, but I am not seeing any ROMs. I have tried making a directory with the normal name, and also putting a ROM on the SD card it self.

    es_systems.cfg looks like this:

    <system>
        <name>n64</name>
        <fullname>Nintendo 64</fullname>
        <path>//192.168.2.160/Games/LaunchBox/Games/Nintendo 64</path>
        <extension>.z64 .n64 .v64 .zip .Z64 .N64 .V64 .ZIP</extension>
        <command>/opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ n64 %ROM%</command>
        <platform>n64</platform>
        <theme>n64</theme>
    

    autostart.cfg looks like:

    emulationstation #auto
    
    max_usb_current=1
    hdmi_group=2
    hdmi_mode=1
    hdmi_mode=87
    hdmi_cvt 800 480 60 6 0 0 0
    
    sudo mount -t cifs -o guest,uid=pi,nounix,noserverino //192.168.2.160/Games/LaunchBox/Games /home/pi/RetroPie/roms
    

    My network path to ROMs is \192.168.2.160\Games\LaunchBox\Games

    I have also ran the command:

    cp /etc/emulationstation/es_systems.cfg /home/pi/.emulationstation/es_systems.cfg
    

    I have no idea what part I am doing wrong. I did once have it working via network on a pi 3 B+ a while ago but since got rid of that one.


  • Global Moderator

    es_systems.cfg looks like this:

      ...
        <path>//192.168.2.160/Games/LaunchBox/Games/Nintendo 64</path>
        ....
    

    EmulationStation doesn't support share (UNC) paths, you should leave those paths local (i.e. /home/pi/RetroPie/roms/Nintendo N64).

    autostart.cfg looks like:
    emulationstation #auto

    max_usb_current=1
    hdmi_group=2
    hdmi_mode=1
    hdmi_mode=87
    hdmi_cvt 800 480 60 6 0 0 0

    sudo mount -t cifs -o guest,uid=pi,nounix,noserverino //192.168.2.160/Games/LaunchBox/Games /home/pi/RetroPie/roms

    This is not correct:

    • the hdmi_ parameters have no place here, you should add those to /boot/config.txt, the configuration file for the RPI bootloader.
    • you're starting EmulationStation before mounting the network share, so the ROM folders will not exist - put the mount command before EmulationStation starts.

    cp /etc/emulationstation/es_systems.cfg /home/pi/.emulationstation/es_systems.cfg

    That will create your own customized es_systems.cfg, which allows you to edit the ROM paths or add/remove systems. Just be aware you'll have to maintain this file yourself and synchronize it with /etc/emulationstation/es_systems.cfg when adding new emulators/systems.



  • Tried what you said, and that still didn't have any ROMs show up. Then changed the Nintendo 64 to n64(I do believe that is the default folder name) and still nothing.


  • Global Moderator

    Check if the mount command worked - exit EmulationStation and run the mount command manually, see if you get any errors.



  • I think so... doesn't show an error. I was also just looking around using winscp, my /home/pi/RetroPie/roms/Nintendo 64 folder is populated in the pi it self, just emulation station is not showing any ROMs or emulators


  • Global Moderator

    @koygi Post your ES log - from $HOME/.emulationstation/es_log.txt - to pastebin.com.



  • @mitu said in Running ROMs from a Network Share:

    $HOME/.emulationstation/es_log.txt

    https://pastebin.com/tiR7TeN7 I think I did that right.


  • Global Moderator

    I don't think it's the whole log (and the lines are truncated) and don't seen any mentions to 'n64' in it. Try to get the whole log file as is with WinSCP and also post your es_systems.cfg file from the same folder.



  • Sorry I had to use PuTTY ... I cann't see the .emulationstation on winSCP.


  • Global Moderator

    @koygi said in Running ROMs from a Network Share:

    . I cann't see the .emulationstation on winSCP.

    It's a 'hidden' folder, you may want to enable showing hidden files/folders in WinSCP. The same folder is available via file shares at \\retropie\configs\all\emulationstation.




  • Global Moderator

    Can you spot the error ?



  • Looking the only difference I can see at the two is // vs. /. Which one should be correct?


  • Global Moderator

    Your path for the N64 roms folder is wrong:

    EmulationStation doesn't support share (UNC) paths, you should leave those paths local (i.e. /home/pi/RetroPie/roms/Nintendo N64).



  • I sware I had it changed to what you said earlier. Changed both files and it's now showing my N64 ones. Hopefully I can get the rest to work... thank you.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.