Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Border Issues, Black Bars, and Screen Stretch



  • @dankcushions

    Ok so I went and experimented with the settings using the Configuration Editor. Sure enough, setting it to 4:3 (it was actually set to Unset before I changed it) - this worked great for MKII and other games, virtually eliminating the borders. However, as you predicted upright games are stretched.

    But this is better than before, and presumably I can go into the RetroArch settings when playing using the HotKey+X command and edit settings for individual games? And somehow save settings for individual games?

    Thanks again, your help is certainly appreciated!



  • @BingoLittle What happens if you enable integer scaling?
    http://emulation-general.wikia.com/wiki/Scaling

    video_scale_integer = true

    If you wanted to set a custom retroarch.cfg for each game you can do that which is how I set specific resolutions for this sort of thing

    Given arcade games (as opposed to consoles) have a wide range of native resolutions its not that uncommon to tweak them.
    You can create these in the same dir as the game with a name of gamename.zip.cfg


  • Global Moderator

    @BingoLittle said in Border Issues, Black Bars, and Screen Stretch:

    @dankcushions

    Ok so I went and experimented with the settings using the Configuration Editor. Sure enough, setting it to 4:3 (it was actually set to Unset before I changed it) - this worked great for MKII and other games, virtually eliminating the borders. However, as you predicted upright games are stretched.

    But this is better than before, and presumably I can go into the RetroArch settings when playing using the HotKey+X command and edit settings for individual games? And somehow save settings for individual games?

    Thanks again, your help is certainly appreciated!

    great! yeah lr-imame4all is pretty limited. mame4all-pi will work with the same romset and probably not have these display issues, if you don't mind it not being retroarch (may have to manually configure controls).

    mame2003 does this stuff better but has the aforementioned problems with MK2/3.

    you can do per game .cfg settings by creating a mk2.zip.cfg in your /arcade/ folder, with just the aspect_ratio_index = "14" (or whatever it is) in there.



  • @Floob @dankcushions @GreenHawk84

    Hi folks,

    Ok so if I go and set video_scale_integer=true I get something like the following (e.g. Final Fight running on lr-imame4all):

    https://www.icloud.com/sharedalbum/#B0N5n8hH4KO0Fe;EE92B6C5-5765-49F9-9672-A9A999565446

    However, I noticed that by setting the aspect ratio to 5:4, I get a full screen for basically almost any game:

    https://www.icloud.com/sharedalbum/#B0N5n8hH4KO0Fe;1C299916-5E91-45BD-B85F-1150C3579A3B

    It doesn't seem to be sensitive to the resolution of the arcade game itself, unless the game is an upright, in that case I set the aspect ratio to 3:4 and they look perfect like that. So this setting works for MKII as well as it works for Final Fight or SFII.

    Even Mega Drive and SNES games stretch to fill the screen if I set the aspect ratio to 5:4.

    So I guess if you want to remove borders and you are using a CRT, then setting this one option seems to work most of time. Basically everything other option is set to default.

    Again, many thanks for all the help on this topic!

    PS @Floob your videos are excellent, I've watched quite a few of them at this point and they've helped a lot.



  • @BingoLittle I think a lot of this will depend on how much you want the precise aspect ratio to be maintained, or if your priority is to fill the borders.
    Does "Core Provided" (21) with integer scaling look any good?
    The true ratio for final fight looks like 12:7 based on https://en.wikipedia.org/wiki/Final_Fight
    I'd be tempted to manually max that to fill the screen keeping the aspect ratio.

    I guess this will only really be an issue with arcade games given their varied res as opposed to consoles.
    For consoles you could just set a custom retroarch.cfg and be precise with the layout as 99% of the games will be the same.



  • @Floob Basically my priority is to fill the screen at the expense of not having true aspect ratios for some games.

    I have uploaded two more screen shots. The first is using Core Provided and Integer Scale set to On:

    https://www.icloud.com/sharedalbum/#B0N5n8hH4KO0Fe;18A3E7B5-1983-4286-86FB-A462900F0945

    It just makes the image smaller as you can see and centres it on the screen.

    The second screenshot is still set to Core Provided but the Integer Scale is set to Off.

    https://www.icloud.com/sharedalbum/#B0N5n8hH4KO0Fe;F283CD92-44C9-46E4-B3E9-3E200B01D27D

    As you can see, it's almost a full screen. There are small borders to the top and bottom.


  • Global Moderator

    @BingoLittle said in Border Issues, Black Bars, and Screen Stretch:

    @Floob Basically my priority is to fill the screen at the expense of not having true aspect ratios for some games.

    I have uploaded two more screen shots. The first is using Core Provided and Integer Scale set to On:

    https://www.icloud.com/sharedalbum/#B0N5n8hH4KO0Fe;18A3E7B5-1983-4286-86FB-A462900F0945

    It just makes the image smaller as you can see and centres it on the screen.

    that sort of makes sense. final fight (which i think is playing here?) is a 224 lines high game. with integer scaling, the largest it can make it is 3 (2243 is 672, which is what it says on that image). i guess your tv is running at something like 1028768 resolution? that's a pretty strange resolution to be running at - i would have thought a pal tv should run at something576, or (even better for emulation), in NTSC mode at something*480.

    you might want to have a look into the different Tv modes available in https://github.com/retropie/retropie-setup/wiki/runcommand - if you're bothered about it being "authentic", but if it fills the screen you might not be too bothered :) i guess with a pal CRT the scanlines aren't going to line up with NTSC arcade games anyway, without big ol borders.



  • @dankcushions Yes, that's Final Fight there too.

    I am pretty sure the TV is not some higher resolution screen, like 576 lines - almost certainly it is a standard PAL TV :)

    To be honest, as long as it fills the screen I am pleased. I am now trying to set RetroArch to use a 5:4 by default for all games by setting video_aspect_ratio = 5:4 and video_aspect_ratio_auto = "false" in the /opt/retropie/configs/all/retroarch.cfg file, but it doesn't have any effect, I have to set it manually every time by first loading a game and then changing the RetroArch settings. That's kinda strange, but it doesn't take very long to do so it isn't a big deal really. Also, any upright games would have to set back to 3:4 manually anyway, and I play them often enough.


  • Global Moderator

    @BingoLittle said in Border Issues, Black Bars, and Screen Stretch:

    @dankcushions Yes, that's Final Fight there too.

    I am pretty sure the TV is not some higher resolution screen, like 576 lines - almost certainly it is a standard PAL TV :)

    yeah i think composite and your TV won't care - it's up to you to send the TV the correct signal - if you care to line up with scanlines, that is.

    To be honest, as long as it fills the screen I am pleased. I am now trying to set RetroArch to use a 5:4 by default for all games by setting video_aspect_ratio = 5:4 and video_aspect_ratio_auto = "false" in the /opt/retropie/configs/all/retroarch.cfg file, but it doesn't have any effect, I have to set it manually every time by first loading a game and then changing the RetroArch settings. That's kinda strange, but it doesn't take very long to do so it isn't a big deal really.

    you shouldn't change the file manually - use the configuration editor.



  • @dankcushions Thanks for the tip, I changed the setting to 5:4via the Configuration Editor, that then made the changes to the retroarch.cfg file and that's now the default when I load games. Interesting that by changing it manually it did not work. Anyway, thanks again for all the help over the past few days. I hope this thread is useful for someone else one day who also wants to use a CRT and really wants fullscreen :)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.