Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Cannot run retropie-setup, WiFi config, or Bluetooth config etc on 4.0.2



  • Pi Model: Pi 3
    RetroPie Version Used: 4.0.2
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: PS3 controller
    Controller used: PS3 controller
    Error messages received: Did not find needed package(s): git dialog wget gcc g++ build-essential xmlstarlet gcc-4.9 g++-4.9. I am trying to install them now.
    Guide used: n/a
    File: n/a
    Emulator: n/a
    Attachment of config files: default
    How to replicate the problem: dd if=./[retropie-4.0.2.img] of=/dev/[sdcard]

    Vanilla official retropie flashed, nothing added or removed, only modified config.txt on /boot to get proper video out settings

    I tried to configure my PS3 controller with bluetooth, but I got an error message that certain packages were missing and there were attempts to download them, and following that are error messages saying "(does network require authentication?)" so I tried to configure WiFi, same problem, so I hook up Ethernet with dhcp and restart retropie, retry these options, packages still don't download... So I tried "show IP" from the retropie menu but still getting errors about these missing packages.

    Not sure what to do, going back to an earlier version I guess


  • administrators

    I don't know why you would get Did not find needed package(s): git dialog wget gcc g++ build-essential xmlstarlet gcc-4.9 g++-4.9. I am trying to install them now. on the image - as those are already installed.

    if you get the message above even when trying to configure wifi, it sounds like sdcard corruption or the image wasn't written properly or something.



  • @BuZz Thanks :) I will try again with a different SDcard r/w device as I have tried reflashing with no luck

    Come to think of it I will try another sdcard as well since this one is brand new just for retropie, maybe it is defective. This probably is the problem, I should have tried this before posting. Thanks again!



  • @GirlUSoCrazy working now, sdcard was indeed bad, thanks again!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.