Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroArch Setting Stuck?



  • Hello,

    I recently toggled in the RGUI Settings>Configuration>Save On Exit to ON. Now it will not save as OFF. I tried to press "Save current configuration" but nothing happens. I haven't modified any .cfgs or anything, I rather like using RGUI or any GUI if I can before digging in any files.

    Also, how would one view "Default" values for RetroArch? Sometimes I would like to do a sanity check to make sure I haven't bumped other things.



  • @GreenHawk84 there are backup cfg files in the root installation of RA. You should use those or download it again. Make sure both config files, RetroArch and the respective system cfg have save on exit switched off if you no longer want it. You need to read up on the RetroArch website a little more because these questions are quite easily covered.



  • @GreenHawk84 said in RetroArch Setting Stuck?:

    Hello,

    I recently toggled in the RGUI Settings>Configuration>Save On Exit to ON. Now it will not save as OFF. I tried to press "Save current configuration" but nothing happens.

    This is a curious situation: The "Save current configuration" only works if the "Save On Exit" is ON. Therefore: there's no way to turn OFF the "Save On Exit" through RGUI.

    You have to edit the /opt/retropie/configs/all/retroarch.cfg and set config_save_on_exit to "false". Probably your system specific retroarch.cfg files are messed... Well, using config_save_on_exit in RetroPie is a little confusing for the newcomers. Maybe this post can clarify something for you:
    https://retropie.org.uk/forum/topic/1714/retroarch-config-confusion-and-issues/2

    Also, how would one view "Default" values for RetroArch? Sometimes I would like to do a sanity check to make sure I haven't bumped other things.

    My first suggestion is to check if you have this file /opt/retropie/configs/all/retroarch.cfg.rp-dist. This is your retroarch.cfg with the "factory settings. Maybe there are retroarch.cfg.rp-dist files In the system specific directories too, those are the RetroPie defaults.

    My second suggestion is reinstall RetroArch from binary, it will bring the file I mentioned in my first suggestion. ;-)

    @DrMaxwell said in RetroArch Setting Stuck?:

    there are backup cfg files in the root installation of RA.

    that file is the RetroArch default, not the RetroPie one. If you look carefully you'll see that the file is fully commented. ;-)



  • @meleu, so I went into /opt/retropie/configs/all/retroarch.cfg and the setting for save on exit was already false. But loading a ROM and going into RGUI shows it still ON.

    I have my shader set as "crt.pi" for default, and the vertical games have an extra file with".zip.cfg" so they load the vertical shader appropriately. I loaded Donkey Kong, it used the vertical shader. Then went back to Mortal Kombat, and the vertical shader held, I suspect due to "save on exit" still on.

    So now any time I load a vertical game, it loads the vertical shader, and overwrites the horizontal shader.



  • @GreenHawk84 Did you read the post I linked? It can explain why the situation you described is happening. ;-)



  • @meleu, oh boy, I see this now. I have a lot of reading to do. : [



  • @GreenHawk84 OK lazy boy, I can summarize it for you: If you turn on "save config on exit" in RetroPie's RetroArch, $#it happens. :-)
    That reading is only necessary if you wanna know why it happens.



  • @meleu lol yes I woke up now and I'm gonna try to fix this nonsense.



  • Okay, I got it. Thank for the help. I had to go into Arcade configs too and set it. I also had to remove the setting of the vertical shader saved to the arcade retroarch.cfg. I know now that I have multiple .cfg's to worry about.


  • administrators

    RetroArch bug - https://github.com/libretro/RetroArch/issues/3605 (or by design perhaps - but should be changed imho).


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.