Please do not post a support request without first reading and following the advice in

NTSC Sega Genesis/ Mega Drive roms not working on retropie-4.0.2-rpi3

  • Mega Drive PAL and hacked roms work, but when I try to run NTSC roms it goes to a black screen keeps black for a few seconds then it returns to the menu. I have a raspberry pi 3 b and I installed retropie-4.0.2-rpi2_rpi3. I tried both emulators (lr-picodrive and lr-genesis-plus-gx) and it behaves the same...

    extended info:

    Pi Model: 3B
    RetroPie Version Used: 4.0.2
    Built From: Pre made SD Image on RetroPie website (retropie-4.0.2-rpi2_rpi3.img)
    USB Devices connected: Snes USB controller
    Controller used: Snes USB controller
    Error messages received: none, just a black screen for a few seconds, then gets back to menu
    TMHT Hyperston Heist (PAL - Worked),
    Bare Knuckle 3 (JAP version with english patch - worked),
    Sonic CLassic Hereos (Romhack - Working)
    Toe Jam & Earl (NTSC - not working)
    Michael Jacksons Moonwalker (NTSC - Not working),
    Contra Hard Corps (NTSC - Not Working)
    Castlevania Bloodlines (NTSC - Not working)
    Emulator: lr-picodrive and lr-genesis-plus-gx (both behave the same)

    This rom files work fine on kfusion on my PC, also on my genesis emulator for android, wiiu, psp, ps2, and even on real sega hardware (EPROM flash)

    thanks in advance

  • You need to go into the core settings and set the region to "auto" or something like that.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.