Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first
  • administrators

    also please remove / reboot / re-install it again , then reboot and run the above command.


  • @BuZz just saw your post. Will do it tomorrow morning.


  • Before re-install

     sixad.service - LSB: Start sixad
       Loaded: loaded (/etc/init.d/sixad)
       Active: active (running) since Wed 2016-10-19 20:17:03 UTC; 11h ago
      Process: 403 ExecStart=/etc/init.d/sixad start (code=exited, status=0/SUCCESS)
       CGroup: /system.slice/sixad.service
               ├─ 442 sudo /usr/bin/sixad --start
               ├─ 496 /bin/bash /usr/bin/sixad --start
               ├─ 684 /usr/sbin/sixad-bin 0 0 0
               └─3839 sleep 5
    

  • After remove/reboot/installing (did not try to pair)

     sixad.service - LSB: Start sixad
       Loaded: loaded (/etc/init.d/sixad)
       Active: active (running) since Thu 2016-10-20 07:30:26 UTC; 1min 34s ago
      Process: 1830 ExecStart=/etc/init.d/sixad start (code=exited, status=0/SUCCESS)
       CGroup: /system.slice/sixad.service
               ├─1837 /bin/bash /usr/bin/sixad --start
               ├─1885 /usr/sbin/sixad-bin 0 0 0
               └─2173 sleep 5
    

  • Tried to pair, no luck

  • administrators

    @Paholainen It's running correctly, so not sure why the official ps3 controller won't pair. Mine pairs fine. I just connect USB, disconnect and press button. I'm out of ideas, sorry.


  • @BuZz I even tried 3 different cables and on two separate Raspberries. When I plug it in nothing happens with the lights on the controller. I´ll just have to use my 2,4ghz dongle gamepad instead

  • administrators

    the controller doesn't even work when connected via usb ? That's the main problem then as that's the point where the controller is "told" to connect to the raspberry pi bluetooth when disconnected. It should work out of the box over usb.

    In case something is wrong with your install, you should download a fresh images, then update it before doing anything else via retropie-setup, then try. If you get the same problem, I suspect it's a hardware issue or something with your controller that makes it incompatible.


  • @BuZz Downloaded fresh image, and did the steps. still same issue. Strange that none of the two ps3 controllers worked via cable or BT, on two different Raspberries. The controllers are confirmed working on a PS3


  • @BuZz Thanks for trying to get it fixed.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.