Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Hi everyone,

    My PS3Shanwan doesn't connect via Bluetooth. I can connect it via USB, even though it rumbles all the time, but when I disconnect it and try to connect via Bluetooth, it does not. I have a Raspberry B+ with a Bluetooth dongle and Retropie 4.0.2 installed.I have also installed the PS3 (and clones) drivers through retropie_setup.sh

    I am sure my dongle works and the drivers are correctly installed because I have an original PS3 gamepad and this works perfectly via Bluetooth. I follow the same steps with my PS3Shanwan with no success.

    I am not a Linux specialist, but here are all the messages I got from dmesg when I try to connect the PS3 Shanwan gamepad:

    [ 2340.165025] usb 1-1.4: new full-speed USB device number 22 using dwc_otg
    [ 2340.271226] usb 1-1.4: New USB device found, idVendor=054c, idProduct=0268
    [ 2340.271309] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [ 2340.271330] usb 1-1.4: Product: PS(R) Ga`epad

    [ 2340.271352] usb 1-1.4: Manufacturer: ShanWan
    [ 2350.305275] sony 0003:054C:0268.001D: usb_submit_urb(ctrl) failed: -1
    [ 2350.305367] sony 0003:054C:0268.001D: timeout initializing reports
    [ 2350.306104] input: ShanWan PS(R) Ga'epad as /devices/platform/soc/20980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:054C:0268.001D/input/input27
    [ 2350.312406] sony 0003:054C:0268.001D: input,hiddev0,hidraw1: USB HID v1.10 Joystick [ShanWan PS(R) Ga`epad] on usb-20980000.usb-1.4/input0

    [ 2350.505219] usb 1-1.4: reset full-speed USB device number 22 using dwc_otg
    [ 2351.383764] input: ShanWan PS(R) Ga`epad as /devices/platform/soc/20980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:054C:0268.001E/input/input28

    [ 2351.393731] sony 0003:054C:0268.001E: input,hiddev0,hidraw1: USB HID v1.10 Joystick [ShanWan PS(R) Ga`epad] on usb-20980000.usb-1.4/input0

    [ 2351.394019] sony 0003:054C:0268.001E: can't set operational mode: step 1
    [ 2351.406614] sony: probe of 0003:054C:0268.001E failed with error -32
    [ 2351.454942] usb 1-1.4: USB disconnect, device number 22
    [ 2351.695408] usb 1-1.4: new full-speed USB device number 23 using dwc_otg
    [ 2351.801355] usb 1-1.4: New USB device found, idVendor=054c, idProduct=0268
    [ 2351.801396] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [ 2351.801420] usb 1-1.4: Product: PS(R) Ga`epad

    [ 2351.801473] usb 1-1.4: Manufacturer: ShanWan
    [ 2355.808111] input: ShanWan PS(R) Ga`epad as /devices/platform/soc/20980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:054C:0268.001F/input/input29

    [ 2355.814281] sony 0003:054C:0268.001F: input,hiddev0,hidraw1: USB HID v1.10 Joystick [ShanWan PS(R) Ga`epad] on usb-20980000.usb-1.4/input0
    [ 2355.821149] sony 0003:054C:0268.001F: can't set operational mode: step 1
    [ 2355.829050] sony: probe of 0003:054C:0268.001F failed with error -32
    [ 2355.831465] usb 1-1.4: USB disconnect, device number 23

    Could anybody help me? Am I doing something wrong? Should Retropie 4.0.2 work fine with PS3Shanwan?

    Thank you in advance

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.