Please do not post a support request without first reading and following the advice in

  • Hi there,

    I have Duke 3D running perfectly using eduke, except for the controller. I have the following issues:

    • Sensitivity on the thumbsticks is insane, even with slight movements it is impossible to hit anything you just spin around. (see below)
    • No way to reach main menu, I would love to be able to bind ESC to select.
    • Only actions that are working are:
      • Shoot which is bound to A and works reliably (eduke32.cfg: JoystickButton0 = "Fire").
      • Crouch which is bound to X and works when double tapped (eduke32.cfg: JoystickButtonClicked3 = "Crouch").
    • Not sure how to rebind keys, I looked in the eduke32.cfg and the control names (JoystickButton0) don't align with the hardware numbers.

    Any help would be greatly appreciated!


  • You're running this through Ports, right?

    I rarely play Duke Nukem 3d, but on Doom and Quake (both in ports) I always had similar issues. My partial fix was to use XboxDrv (Xbox 360-like pad driver) - I normally used the Xpad driver for everything else (which for the record RetroPie 4.1 doesn't need either driver to use Xbox 360-style controllers anymore I've read). That got everything working pretty decently with a dual analog stick setup (as in how we're used to moving around with both sticks in modern consoles like Xbox 360/Xbox One/PS3/PS4)

    BUT I could never remap the fire button from a face ABXY button, to be a trigger like "fire" is in every other shooting game for the last decade (and if you're using BOTH sticks to move around you can't very well use a 3rd thumb to hit "fire") my crappy fix (instead of spending hours researching this), is to play these games on DOSBox with a keyboard and mouse (which is how they were designed to be played anyway WASD style). Sorry I'm not more help - these guys should be able to sort you out.

  • I've done some more experimenting:

    8bitdo eduke mapping

    This is how eduke maps the nes30pro, you can configure every button. You can also change the sensitivity of the axis in the Duke menus, 0.25 makes it playable (to me).

    The only outstanding issue I have is not being able to bind any of the controls to ESC / Menu to allow exiting the game from the controller.

  • Further configuration I've done to setup the controls:


    Still unable to setup escape to menu as a bound key on the controller.

    I have also found a bug where the controller works in the menu fine when you first launch. But when you go back to the menu (pressing ESC on the keyboard) after starting a game, you can navigate up and down with the controller, but you can no longer go forward or back.

  • @BlackICE Have you tried to input this on the console?

    in_joystick 1

  • @Rion Yes, the controller works fine in game, I just need to bind escape.

  • @BlackICE I think your next steep would be to have a look at this thread

    Guide: Advanced Controller Mappings

  • @Rion said in Duke Nukem 3D (eduke) - 8bitdo nes30pro issues.:

    Have you tried to input this on the console?

    I know this is really old, but I can't find out how to access the console. The docs say you just press "F1" to open console, but that displays a help menu for me.

  • @mattrixk Have you tried the tilde key?

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.