Please do not post a support request without first reading and following the advice in

Neogeo x Arcade Stick

  • Hi guys, I tried plugging in my Neogeo x Arcade Stick and retropie doesn't seem to even recognize it. Is there anyway to get it to work?

    This is the Arcade stick that I purchased

  • Okay I found out that Retropie thinks that the Neogeo x Arcade Stick is a keyboard. It only works in the Retropie setup menu. Is there anyway to fix this?

  • I suppose it's the tommo neogeo x arcade stick. You are lucky, i had to fix this for a friend last year and i still had the fix somewhere on my computer.

    Create the file "/etc/udev/rules.d/10-neogeox.rules" with the following content :

    SUBSYSTEM=="input", ATTRS{name}=="TOMMO NEOGEOX Arcade Stick", MODE="0666", ENV{ID_INPUT_JOYSTICK}="1"

    Then reboot your pi.

    If it's not the tommo one, i think you'll have to change "TOMMO NEOGEOX Arcade Stick" by the right name (use "dmesg" to find it), this trick should work with almost any stick/pad recognized as a keyboard, i first heard of this trick when i had this issue with a 8bitdo pad i bought.

  • It works!!! barbudreadmon your the best!!! Thank you!

  • I have a SNK NEOGEO PAD USB that I'm not being able to configure.

    EmulationStation detects that the new gamepad is connected but no button works when it says to hold a button to configure it.

    Any ideas? How do I know if it is being detected as a keyboard? Maybe it's better to create a new topic.

    [ 662.573804] usb 1-1.2: new full-speed USB device number 8 using dwc_otg
    [ 662.687621] usb 1-1.2: New USB device found, idVendor=1f4f, idProduct=0008
    [ 662.687650] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 662.687663] usb 1-1.2: Product: USB JOYSTICK PS3
    [ 662.687676] usb 1-1.2: Manufacturer: EXAR
    [ 662.687689] usb 1-1.2: SerialNumber: 1.0.0
    [ 672.693866] hid-generic 0003:1F4F:0008.0006: usb_submit_urb(ctrl) failed: -1
    [ 672.693896] hid-generic 0003:1F4F:0008.0006: timeout initializing reports
    [ 672.694133] input: EXAR USB JOYSTICK PS3 as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0/0003:1F4F:0008.0006/input/input5
    [ 672.694512] hid-generic 0003:1F4F:0008.0006: input,hidraw3: USB HID v1.11 Gamepad [EXAR USB JOYSTICK PS3] on usb-3f980000.usb-1.2/input0

  • @delusion666 said in Neogeo x Arcade Stick:

    [ 672.693866] hid-generic 0003:1F4F:0008.0006: usb_submit_urb(ctrl) failed: -1
    [ 672.693896] hid-generic 0003:1F4F:0008.0006: timeout initializing reports

    Feels like a kernel issue, it is unrelated to the first issue, and it seems like a known issue :
    What's your kernel ? Did you try updating it ?
    If your kernel is up to date, i don't think there is anything else you can do, except perhaps writing a bug report on

  • I updated the kernel just before writing my comment above. It wasn't working either before or after the update.
    Damn, it's a really good pad for fighting games.


  • @barbudreadmon OMFG thank you so much, I just bought a Neo Geo X arcade stick and thought I was going to have to send it back as it didnt work with Retropie (initially).

    This solution worked a charm however, once I managed to get to grips with terminal (Mac), SSH, sudo, cd .. and nano

  • @barbudreadmon i just real about the neo geo x configuration, i'm new with retropie, is there any step by step that i can follow in order to modify/add the files you mentioned?

  • @castillo88 you have to use ssh to access remotely to your pi (if you are on windows, download a software called "putty"), you'll need your login / pass, which are probably pi / raspberry, once you are connected :

    • type "sudo nano /etc/udev/rules.d/10-neogeox.rules", i think the system will ask for your password again
    • copy / paste what i wrote above (paste to putty is handled by the right click on your mouse)
    • ctrl+O to write the file, ctrl+X to leave the editor
    • type "sudo reboot" to reboot the pi

  • Just a word @barbudreadmon Thanks a lot for this trick :)

  • @Wildpumpk1n I'm happy it's still useful years later, i'm even more happy to see people searching the forum instead of just asking again :)

  • @barbudreadmon Im another one whos late to the party, Just got the pi side all working and now time to throw it all into a neogeo x dock to finish it off.

    My project wouldnt be nearing completeion if it wasnt for your post on how to get the neo x stick recognised and working.
    Im planning on running two sticks in this setup. Do you know if it will pick player twos stick up or will I need to do any more?

    Thanks again for your help!

  • @Happypants said in Neogeo x Arcade Stick:

    Do you know if it will pick player twos stick up or will I need to do any more?

    It should work the same whatever the number of stick you are using.

  • Thanks for the prompt reply!

    Mission nearly complete :)

  • Managed to get the Neo X stick working... or so I thought, It would appear that on both sticks i have the A+B and C+D are swapped during gameplay.

    The front end menu works great its literally just in game that its screwed up. Does anyone have any idea on how I set it up so it works correctly in game?

  • @Happypants Did you have any luck with Retroarch's (per-core or per-ROM) input mapping?

  • Have mapped the sticks buttons according to the eta prime video now, so A is B and X is Y which works great ingame but now on the ES menu when you press A to select the game I have to use B as it now thinks the buttons are wrong, But they work as they should in game.

  • @IanDaemon Not tried that, How do I access that option?

  • EmulationStation's button mapping is separate from Retroarch's input mapping. Retroarch will just default to use EmulationStation if there is no override. You seem to have changed EmulationStation's button mapping to suit the game and now the "ES has backwards buttons". If you launch a game in EmulationStation and then bring up the Retroarch menus by pressing X and select you can set the inputs to be different for that ROM only. This way EmulationStation will have its button mapping within EmulationStation and then when Retroarch launches a game it can use the "rom specific" or "core specific" (depending on how you save) input mappings.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.