Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Logitech F710 Button Mapping Issue



  • I configured two Buffalo USB controllers without issue. I wanted to configure the other two Logitech F710 wireless controllers I have.

    When I perform lsusb I can see the raspberry pi does in fact recognize that there are two of them (F710's) connected to it. The first controller works absolutely fine. The second will not register inputs when I try to configure it. It does tell me two Gamepads are connected (and they are the only gamepads connected). I thought this might be a conflict but the second F710 doesn't do anything even as the first player in any game, so I unplugged the first controller and then performed sudo reboot. I tried to configure only the second logitech F710 and it's inputs are still not being recognized. They are both using XInput.

    Is the controller bad?

    Pi Model: 2
    RetroPie Version Used: 4.01
    Built From: Pre made SD Image on RetroPie website



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.