Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Samsung TV "Mode Not Supported"



  • I found a similar issue in another thread, but it doesn't appear to have a solution. I hope someone can help me figure this out. I installed retropie as directed and it works perfectly on my son's television. However, when I switch to our main TV, a Samsung, I get the message "mode not supported." Does anyone know of a fix for this other than getting a converter box to change the HDMI to RCA? From the little I've found out about it, it appears to be a Samsung/pi compatibility issue...

    FYI: I am a newbie to using a raspberry pi -like many, found it as an alternative when the NES classic wasn't available. I am good with computers and used to build my own back in the late 90s, but its been a while and this is a new technology for me. If there are other ways to fix it, please feel free to over-explain.


  • administrators

    @josiemy Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

    Did you try forcing a mode in /boot/config.txt ?

    eg

    hdmi_force_hotplug=1
    hdmi_group=1
    hdmi_mode=16
    


  • @BuZz Perfect thank you! This solved it!


  • administrators

    @josiemy glad it's sorted :)



  • @buzz

    this may be a simple question but i've searched the the FAQ and the other posts and i cant find it answered anywhere...

    how do i open the config.txt to edit these settings?



  • @ameis314 Easiest way is in the terminal sudo nano /boot/config.txt Make the changes then CTRL+X to exit Y to save then enter to write, Then reboot.



  • @jonnykesh

    Thanks, that worked (i was able to edit through the text doc as well) but my issue is still happening.

    I have changed around a few of the settings to lower the resolution to 720//lower the HRz to 50// forcing the group to set and nothing seems to make a difference. It works perfectly on my Acer computer monitor but my samsung TV will only display the "mode not supported" box.

    are there other solutions i have not tried yet? the TV model is a Samsung PN51D430A3D
    if it helps. my googlefu is not strong enough and it keeps leading me back to this post.

    thanks for any help you are able to provide



  • @ameis314 Run this command in terminal tvservice -m CEA It will tell you what your TV is capable of supporting. Post the results here.
    Mine for eg is:

    Group CEA has 15 modes:
               mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive 
               mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive 
               mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive 
               mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive 
               mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced 
      (prefer) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive 
               mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive 
               mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive 
               mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive 
               mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced 
               mode 21: 720x576 @ 50Hz 4:3, clock:27MHz x2 interlaced 
      (native) mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive 
               mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz progressive 
               mode 33: 1920x1080 @ 25Hz 16:9, clock:74MHz progressive 
               mode 34: 1920x1080 @ 30Hz 16:9, clock:74MHz progressive 
    

    So I would use:

    hdmi_group=1
    hdmi_mode=16
    

    Don't just change the values randomly. Also make sure the hashes # are removed from the front of the line to activate the setting. Also make sure to reboot after the change as these settings are loaded on boot and can't be changed on the fly.



  • I need help with this - my Samsung TV is about 12 years old. I've tried altering the config to no avail.

    Any ideas?



  • @rrs run the command in the post directly above yours. It tells you how to do it.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.