Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Problem with 4 -player megadrive/ genesis with lr-genesis-plus-gx



  • Re: 4 player on Sega Genesis/Mega Drive - not working

    I have read the above post..in fact I have read these posts as well:
    http://blog.petrockblock.com/forums/topic/how-do-i-enable-4-player-games-multitap-for-sega-genesis/
    https://libretro.com/forums/showthread.php?t=7691
    https://github.com/ekeeke/Genesis-Plus-GX/issues/116

    changing the game configuration file didn't work as was mentioned...

    The main issue I am having is to quote the old thread...
    "...."controls" and under " user 1 player device type" and "user 2 device type" change the controller to "3 button + team player". Then choose "save game remap file". Then exit out of the rgui and you should have 4 players working"

    I don't have that option seems like..that is to say I can choose between retropad or none there is no 3 button teamplayer option. (and this is not just my pi3 also x84 64-bit linux)

    I've noticed that on the nes for bomberman II, super spike v-ball the "tap" will enable automatically...and the tap has to be enabled for snes or psx (which work fine) soooo I'm lost. Any help would be MUCH appreciated!

    I have tried general chaos and nba jam T.E. (both are multi I know..they work in kega fusion just fine..).



  • Ok I found a solution..and want to post it here for any that are having the same problem. Thanks to progets at the Attractmode forum for this one:

    "First, I want to make sure you are using genesis_plus_gx since picodrive is the default retroarch core in the RetroPie image. Second, I can confirm that the RetroPie base genesis_plus_gx core is missing the option that you're looking for. Third, if you update the retropie script and install genesis_plus_gx from source (not binary) you will be able to see and use the "+ 4-WayPlay" option."

    I tried it the first time and it didn't change even after a reboot of my pi...but I tried again and yes it did work. So if you are having the same problem I hope that this helps you. I'm not sure what the difference is between the default setup and the source install but the source worked as it should. In fact it doesn't say "retropad" but instead "Joypad Auto" thus it being the sega pad..and all the choices there of..that I DIDN'T have with the default binary install.

    original post here.



  • Hi akafox,

    I have the same problem i'm confused with the third step "Third, if you update the retropie script and install genesis_plus_gx from source (not binary) you will be able to see and use the "+ 4-WayPlay" option."

    • normally i could see "+4-WayPlay" as an option in my retroarch menu but currently can't see it. how do i install it from source?

    sorry i'm a noob :(



  • @rhj501 Step by step..

    1. Go to RetroPie menu
    2. Go to rpsetup
    3. Go to manage packages
    4. Go to Manage main packages
    5. move down to "lr-genesis-plus-gx"
    6. select it (press ok)
    7. choose update from source
    8. Wait
    9. Back out the the main menu
    10. Start a 4 player megadrive/genesis game
    11. Go to the retro arch menu (default is select+x)
    12. Go to quick menu..then controls
    13. Then select user device type*
    14. press left or right on the d-pad..you should see it

    *depending on what game you are playing determines the port (1 or 2) the "tap" must be on (plugged in) and also depending on the game depends on what adapter you need 4- way play or team player)

    more info:
    https://github.com/RetroPie/RetroPie-Setup/wiki/Genesis-Megadrive
    http://www.segaretro.org/4_Way_Play
    http://www.segaretro.org/Team_Player



  • @akafox Thanks for the support. I have updated twice from source now but am still unable to see either " + 4 way play" within the controller options on the retro arch menu (step 14) or "Team Player". The game i'm playing is NBA Jam. When i got this working previously with another pi i had to get "+ Team player" but neither of these options are available. Not sure what else to do :(



  • That is strange...

    You can try removing lr-genesis-plus-gx and then install it from source..

    first though check to see what emulator you are using by default. The picodrive core does not have 4-way or team player ability.



  • I tried your steps and I was able to get a new list of available controllers in the right emulator, but none say teamplayer or 4wayplay

    Any other ideas?


  • administrators

    No need to install from source on rpi. The binary is up to date.



  • That's very strange. You can try the binary..it might work.

    All I know is that I had the "newest" retropie image when I setup my rasp-pi...and I still had to update the cores to get that funtion to work..but I had to use the source. That was also (according to the op) eight months ago..software changes fast.

    @randark said in Problem with 4 -player megadrive/ genesis with lr-genesis-plus-gx:

    I tried your steps and I was able to get a new list of available controllers in the right emulator, but none say teamplayer or 4wayplay

    Any other ideas?

    what options does it give you? Remember you have use left and right on the controller to select the mode. And you can not be in the "main" controller configuration screen. You need to be in the "quick menu" then controls then move the pointer using down the controller to "device type 2". Now press left or right on the controller to select the device type. The default should be "Joypad Auto" from there if you press right four times you'll get to the "3-button+4-way" if you press it six times you'll get to the "3-button+team player."



  • Pressing it that many times to the right worked, I couldn't read the entire option titles that were available.



  • Ok then you are gold... I can't help you with the reading...there might be a way to use a smaller font...but just wait a few seconds and let it scroll and read what it says. Look what I posted above...

    After that has been set...go back to the "quick start" menu and then go to save game configuration file....then resume and quit the game then restart it to see if the settings stuck.

    You can do a quick test by enabling the 4-player device and then backing out and choosing reset then resume..this resets the game and it will see that has been changed. But you have to save the configuration file for it to stick...unless you want to have to enable it every time you want to use it :P



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.