Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

lr-glupen64 input lag



  • RPi3, not overclocked. 8bitdo NES30 Pro controller.

    Using lr-glupen64, specifically Ocarina of Time, I get a very noticeable input lag. Switching over to Mupen64, it disappears.

    The reason I'm trying to use lr-glupen64 is for shaders, and I don't get the annoying infamous pause delay when going to the item screen. (I did at first, but turning framebuffer emulation on then off, it disappeared). The CRT shader I'm using seems to not have anything to do with the lag. Even though I'm using a BT controller, there is no noticeable lag on any other system or emulator I've tried.

    Just wondering if there's a way to fix it, or if my best bet is to deal with the framebuffer issues and use Mupen.



  • I also found this:
    https://github.com/GLupeN64/GLupeN64/issues/156

    If experts know what exactly is going on, I'm having trouble following that thread. But it seems nothing was figured out by that last post.



  • The input lag is caused by Framebuffer Emulation. Framebuffer Emulation fixes the pause screen delay. If you have no pause screen delay, that means that Framebuffer Emulation is enabled.

    So basically you can't have it all, either you have the pause screen delay, and no input lag, or you have input lag and no pause screen delay.



  • By the way, framebuffer emulation on the Raspberry Pi is very buggy, that's why mupen64plus has it disabled.

    The most recent versions of lr-glupen64 disable it on the Raspberry Pi as well, so if you were to update from source, your only option would be Framebuffer Emulation disabled (no input lag, pause screen delay)



  • @loganmc10

    Sorry I wasn't very clear, I have framebuffer off currently. I turned it on, and then I turned it off. There's a noticeable graphical difference, so I know it's definitely off, but somehow the pause delay is still gone. Framebuffer On does increase the lag even worse though.

    But even before I messed with the framebuffer, there was input lag is what I was trying to say.

    I don't think there's a fix though, it's just how it's currently coded it seems.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.