Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Controller not working, Retroarch [controller] is not configured when loading rom.



  • So i can't for the life of me figure out why my PS4 controller won't work on retropie.
    I got myself a Raspberry Pi MODEL B with a 16GB sd card, i'm running RetroPie 4.1. My premade image is: retropie-4.1-rpi2_rpi3.img.
    A keyboard, wifi adapter, Dualshock 4 controller. The controller works fine in emulationstation but not retroarch/roms.

    Every time a load ANY rom i get the "[controller] is not configured". I have tried so much stuff. Ive edited retroarch configs multiple times. For some reason "retroarch-joypads" doesn't contain anything.

    My runcommand.log:
    Parameters: 0 SYS nes /home/pi/RetroPie/roms/nes/Super Mario Bros. 3 (USA).nes
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-fceumm/fceumm_libretro.so --config /opt/retropie/configs/nes/retroarch.cfg "/home/pi/RetroPie/roms/nes/Super Mario Bros. 3 (USA).nes" --appendconfig /dev/shm/retroarch.cfg



  • @TheSwedenGuy When you configure input in emulationstation, it automatically create the retroarch-joypads/YOUR_JOYPAD_NAME.cfg file. Try to configure your joypad input in emulationstation again and look if the "retroarch-joypads" file will be created.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.