Please do not post a support request without first reading and following the advice in

ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred

  • I'm working on setting up my Gameboy Advance Pi Zero and when launching a game from EmulationStation I'm seeing a slew of
    ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred messages before the runcommand prompt.

    Some Googling around says everything from "it's not a problem" to "here's how I fixed it" on a non-Raspberry Pi system, but nothing that seems to have fixed it on my Pi Zero.

    Has anyone else run into this? I've not seen it before on my Pi2 or Pi3 systems.

    I'm running a fresh RetroPie image that was updated to 4.1.15 today. I am using sound through a USB soundcard and that works fine, but I was seeing the error message before I ever plugged in the USB soundcard.

  • I do not have a fix but I do have the same problem on my retropie latest rpi3 so at least you have someone that is having this issue I heard one fix is removing pulseaudio but I don't it installed

  • look at the /dev/shm/runcommand.log on mine i had to update the specific emulator because it didnt have the video plugin it need cheers

  • Nothing showing in there, but I'm wondering if it's because I'm running a TFT via GPIO and the Zero can't keep up.

  • It seems linked to a recent update. I updated my Super Famicom Pi 3 to 4.1.16 this morning and now I get the ALSA error/warning. It didn't do it when it was on 4.1.11. Weird.

  • How and when do you see that error? I saw it one time but cannot find any log of this.

  • @Duveldg I see it after I select a game in EmulationStation (the screen goes black, it's not actually in EmulationStation) but before the runcommand prompt appears

  • Ok that I don't see anymore. I have changed the audio driver for alsathread to sdl2 in all emulators because I did not have sound. Before that I saw the error I think.

  • I started getting the same errors immediately after installing Kodi 17, if I remove it they go away. I do get semi frequent sound issues now when gaming but just learned to deal with it

  • @gopherguts420 Does it appear only when launching Kodi first, or also if use any emulator withouto using Kodi ? Do you notice any sound issue when you see it ?

  • Did you ever get this resolved? I'm having this problem now too. Granted, this topic is 3 months old, and it might have been fixed in a new version of something. I haven't updated any of my stuff in that long a time. Just curious.

  • @hansolo77 I haven't noticed it recently

  • Hmm.. reading about it says it has to do with the driver not getting samples fast enough to play back. I just started scraping a bunch of video snaps for my system and notice the stack of errors when a game launches after I've spent awhile looking at videos. Might be the videos causing the problem..

  • @hansolo77 I've never had video previews on any of my systems. I do try to keep them up to date with the latest RetroPie build. I check every few weeks or so.

  • Yeah I'll try updating and see if it goes away.

  • I'm also getting this, with a fresh install of 4.2 on top of Ubuntu 16.04.3 (for the Odroid XU4).

  • @raelik I just bought an Odroid UX4 and installed Retropie. As soon as Emulation station loads I can see the same ALSA lib underrun error. Any clues about what could be causing this?

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.