Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Cannot connect via WinSCP



  • I have been playing with my Pi3 and especially with Retropie for almost a year, but I have never managed to connect to it via WinSCP or any other SFTP program.

    I can connect through putty with no problem, but I would also like to transfer ROMs more easily.

    I followed steps described here: https://github.com/retropie/retropie-setup/wiki/Transferring-Roms#sftp, but it did not work. From messages WinSCP gives me, it looks like it connects to the device, authenticates, but fails to read from the directory "home/pi". I connect just like in putty, through IP and port 22. With default "pi" username and password, once again, just like in putty.

    When these steps did not work, I tried to seek help from uncle google, but I did not find anything. I went through some config settings and tried to enable SSH, which was useless as well.

    I have no idea what to try next, so I would appreciate a help from someone more experienced, thanks.



  • Since nobody helped, I gave it another try and after trying everything I could think of, I managed to make it work from Network folder in Windows. It did not find Pi, but accessing \\192.168.0.107 surprisingly worked!



  • Finally figured this out. You need to enable both the SFTP and SSH logins.

    Click Edit --> Advanced. Choose the Tunnel menu under the Connection Category.

    Check the "Connect through SSH tunnel" and type in the same info you used for the SFTP.

    WinSCP.png


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.