Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

lr-mame2010 on retropie 4.2.2 not working



  • Lr-mame2010 v 1.5.0 works fine, but whatever version is on retropie 4.2.2 is not working for me. Is there anybody on 4.2.2 that can verify it is not working for them?



  • Yeah, it's not working all of a sudden for me, too. No more Spy Hunter or Punch-Out or Rampage.


  • Global Moderator

    @OhOhOne

    No more Spy Hunter or Punch-Out or Rampage.

    If it happens that a fix doesn't come anytime soon, it's worth noting that those games work well in advmame.



  • I reinstalled retropie and updated to 4.2.2..and the few games I use with mame2010 work fine. I installed the binary. The list of games is getting a shorter since system 16 games now work on latest fba. No real reason to use 2010 unless all the other emulators won't run the game or not run it properly. I had issues with super punch out in 2010 showing only the top screen but 2003 is fine.

    Update: wow, didn't know rampage and spy hunter aren't emulated in fba or mame2003. I tried them in 2010, they both load fine. Use the correct romset. It hasn't changed in any version of retropie.



  • @edmaul69 After removing and reinstalling mame2010 from both binary and source several times without success, I swapped out my SD card with an older version of my build, I think it is 4.1, and of course Mame2010 worked fine. So I SSH'ed in and copied the main emulator file from the /opt/retropie/libretrocores/mame2010 folder. I then swapped SD cards back to my 4.2 build and upon comparing the files noticed they are slightly different sizes. So I overwrote the new file with the older version from 4.1 (after changing the file permissions), and now have mame2010 working again! This confirms that there is definitely something wrong with the version of mame2010 included with 4.2.


  • Banned

    @OhOhOne not many people use the MAME2010 core on RetroPie. It's a resource sucker, plus it only supports 2 players. If you want Arcade stuff I recommend lr-FBA, MAME2003 or AdvanceMAME. All superior and pretty much optimised for the Pi3.



  • Just came in to re-verify that this is a user error problem. I got a pi3 a few weeks ago, so I reinstalled a fresh copy of retropie 4.2 (again), then updated to 4.2.7, updating all packages except for kernel, because my pad driver doesn't work with the new kernel. I tried spy hunter and rampage, and it works without issues (well, aspect ratio problems..). I have "Mame 2010 0.139 b9c98d0". Re-transfer your roms, I guess.



  • @AlexMurphy Yeah, I prefer mame2003 and FBA too but Spy Hunter doesn't work on either of those. And Advancemame has its own issues, as in that it's not a libretro core and also has aspect ratio issues (with Spy Hunter at least).



  • @Darksavior I'm really not sure what you mean by "user error". I updated retropie again, all packages, and even removed and then reinstalled Mame2010 and it still wouldn't work. And yet the older version works fine with all my ROMS. And clearly I am not the only one having this issue. Sorry, but I for one don't want to start over from scratch to just to get mame2010 working again. If there is something I did wrong I'm all ears. Although as I said, I got it working again by using the old version that came with 4.1.



  • @OhOhOne so what i did was make new folders in the libretro folder for both my fba and mame2010 emulators. Then i put the old emulators for fba and mame in them. Then i changed the emulators.cfg files to look for the emulators in those folders. I actually made a second entry in the emulators.cfg files so i could switch back and forth. That way when i update, i can test the new mame. Also that way the updates dont mess that up. I have no desire to redownload either of those sets. I named them the exact same but with a 2 at the end.



  • @edmaul69 Very clever!



  • @OhOhOne said in lr-mame2010 on retropie 4.2.2 not working:

    @Darksavior I'm really not sure what you mean by "user error". I updated retropie again, all packages, and even removed and then reinstalled Mame2010 and it still wouldn't work. And yet the older version works fine with all my ROMS. And clearly I am not the only one having this issue. Sorry, but I for one don't want to start over from scratch to just to get mame2010 working again. If there is something I did wrong I'm all ears. Although as I said, I got it working again by using the old version that came with 4.1.

    I don't know what you did to your pi to make it cause that but trying a fresh install will verify it's a problem with your existing retropie install. Did you goto "update all packages" in retropie-setup? Look at your logs and see if anything's out of the ordinary in there. Uninstall mame2010, and make sure that folder is empty before reinstalling. Just taking guesses at this point. I'm using the same 0.139 roms I've been using since retropie 3.x.



  • @Darksavior i did all of that. It still doesnt work. I did a binary update and install from source. It doesnt work. Im certainly not going to do a fresh install to fix it either.



  • @edmaul69 said in lr-mame2010 on retropie 4.2.2 not working:

    @Darksavior i did all of that. It still doesnt work. I did a binary update and install from source. It doesnt work. Im certainly not going to do a fresh install to fix it either.

    I make fresh installs often, I just backup my configs and stuff. Either way, a fresh install will: verify it's not a problem with upgrading retropie 4.2+ and maybe a problem upgrading from whatever versions you two we're using. None of you are posting logs so I'll stop asking for more info.



  • @Darksavior i will get a log the next time i update.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.