Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Announcing Pegasus Frontend



  • @fluffypillow great to hear the relative path is working now!

    When I have a chance I'll update my metadata files back to the relative paths to give it another shot and confirm all is working with the latest builds. Thanks!



  • @sergioad yes that's a very old bug in the main theme, I really should fix it some of these days.

    @Darksavior yes, no scraper supports Pegasus yet, but that's also why there's support for ES's and Skraper's output, that most of them do. Hopefully the situation will get better in the future :)

    As for renaming the files, perhaps that could scripted in some way to save time?

    @Meldrak I've just pushed some updates, could you check the launching with the latest version (alpha11-34)?

    Yes, could be added, some of them were also requested by others so will take a look on them.

    @hooperre both collections have same launch command, so they should (unless RetroArch itself does some additional logic).



  • @fluffypillow by the way could you add an option to hide the mouse cursor? In RetroPie I rarely use a mouse, maybe it could be implemented by a flag being pegasus-fe --nocursor; another great posible flag could be --nologs to avoid the pegasus logs in the background (the text that appears when launching a game or a RetroPie settings app) making the UX cleaner



  • @sergioad yes the cursor hiding will come eventually as an option under Settings, to make it easier. There's also already a --silent flag to turn off log printing (or you can just redirect it to /dev/null).



  • @fluffypillow excelent! thanks, please @ me when you implement the cursor hiding please



  • @fluffypillow Just wanted to pass along that I updated my metadata.txt files to use relative paths and all is working as expected now. Thanks for fixing this!!



  • hey fluffy! long time i've posted smth here ...
    i've "completed" my rom collection on a nvidia shield tv and wanted to add pegasus as a frontend (again), but it's totally changed it seem :D the only thing i can see on all themes is the main menu ...what do i need to change / update to see my roms again :D ?

    found smth useful in the doc, i'll try it on my own first :)

    edit: ok, tried it, but still nothing. My pegasus frontend is totally empty ...no systems, no roms nothing. What am i doing wrong? o.O



  • @sergioad sure, will try to. There's also this issue you can subscribe to to get notified the moment it gets fixed.

    @Purg-Derren yes there've been a few changes since alpha 10, you can find the details and update help on this page. But feel free to ask if you run into any troubles!



  • @fluffypillow Ok, thanks



  • @fluffypillow figured it out, finally :)
    any solution on preventing pegasus to "crash" on android after closing an emulator?



  • @Purg-Derren also having this issue. By chance are you on shield TV or a different device cause I'm on shield and was wondering if it was an isolated issue?



  • @jerzeeloon i'm on shield, but also had tha issue on a different android based streaming device time ago



  • @fluffypillow: hello :)

    => Could you post an example (screenshot/XML)? It seemed to be correct for me (though I don't use ES much these days)?
    sure. To be clear below is what I have and what I see today in ES2 UI as one game description. I have a blank line between the 2 paragraphs (\n\n if you will).

    A follow-up to the original Lode Runner, with identical gameplay.
    This package contained 50 of the most challenging levels ever designed, and was
    intended for expert players only. It did not include the level editor, you had
    to play through the levels in order, but a save-game option was provided
    (although you lost one life every time you restored).
    
    Successful completion of Championship Lode Runner provided the player with a
    victory code, which could be written on a special card included with the game
    (photocopies were not accepted) and mail it in for a free certificate.
    

    After converting using the online tool this gives:

    description: A follow-up to the original Lode Runner, with identical gameplay.
      This package contained 50 of the most challenging levels ever designed, and was
      intended for expert players only. It did not include the level editor, you had
      to play through the levels in order, but a save-game option was provided
      (although you lost one life every time you restored).
      .
      Successful completion of Championship Lode Runner provided the player with a
      victory code, which could be written on a special card included with the game
      (photocopies were not accepted) and mail it in for a free certificate.
    

    Which translates in Pegasus left panel into:

    description: A follow-up to the original Lode Runner, with identical gameplay.
      This package contained 50 of the most challenging levels ever designed, and was
      intended for expert players only. It did not include the level editor, you had
      to play through the levels in order, but a save-game option was provided
      (although you lost one life every time you restored).
    Successful completion of Championship Lode Runner provided the player with a
    victory code, which could be written on a special card included with the game
    (photocopies were not accepted) and mail it in for a free certificate.
    

    Adding a second dot below I can successfully have my blank line back in Pegasus frontend:

    description: A follow-up to the original Lode Runner, with identical gameplay.
      This package contained 50 of the most challenging levels ever designed, and was
      intended for expert players only. It did not include the level editor, you had
      to play through the levels in order, but a save-game option was provided
      (although you lost one life every time you restored).
      .
      .
      Successful completion of Championship Lode Runner provided the player with a
      victory code, which could be written on a special card included with the game
      (photocopies were not accepted) and mail it in for a free certificate.
    

    I have successfully moved 100% to Pegasus now, no more ES2 at all. I'm extensively testing Pegasus hence I do have additional feedbacks to share if you don't mind.

    1. Pegasus launch time. When I was relying on ES2 gamelist.xml Pegasus launched in a matter of few seconds (under 10 seconds always). Now with my metadata.txt I can see in the lastrun.log file that it takes almost up to 18 seconds. That's ok though this is just a feedback.
    2019-03-24T11:16:37 [i] Games found in 17907ms
    2019-03-24T11:16:37 [i] Assets and metadata found in 54ms
    2019-03-24T11:16:38 [i] 6351 games found
    
    1. That one is more problematic as it tends to hang up Pegasus process. It occurs whenever the "collection" or metadata.txt refers to a non-existing file (or files). It's ok if only image (asset.boxFront) or asset.logo are missing as Pegasus will show a black frame instead of the image. It goes bad should the asset.video caption be missing. In that case, Pegasus does freeze completely as its process eats up 100% of my Pi CPU. Luckily I can still ssh to the Pi to terminate the process but it's a bit annoying. For the record here's what being recorded in the lastrun.log file whenever I encounter such issue.
    2019-03-24T11:26:48 [w] file:///home/pi/.config/pegasus-frontend/themes/custom/layer_grid/GameGridItem.qml:44:5: QML Image: Cannot open: file:///home/pi/.config/pegasus-frontend/metafiles/nes/Castle of Deceit (USA) (Unl)-image.jpg
    2019-03-24T11:28:45 [w] file:///home/pi/.config/pegasus-frontend/themes/custom/layer_gameinfo/PanelRight.qml:46:5: QML Image: Cannot open: file:///home/pi/.config/pegasus-frontend/metafiles/nes/Castle of Deceit (USA) (Unl)-marquee.png
    2019-03-24T11:28:46 [w] GStreamer; Unable to pause - "file:///home/pi/.config/pegasus-frontend/metafiles/nes/Castle of Deceit (USA) (Unl)-video.mp4"
    2019-03-24T11:28:46 [w] GStreamer; Unable to pause - "file:///home/pi/.config/pegasus-frontend/metafiles/nes/Castle of Deceit (USA) (Unl)-video.mp4"
    2019-03-24T11:28:46 [w] GStreamer; Unable to pause - "file:///home/pi/.config/pegasus-frontend/metafiles/nes/Castle of Deceit (USA) (Unl)-video.mp4"
    2019-03-24T11:28:46 [w] GStreamer; Unable to pause - "file:///home/pi/.config/pegasus-frontend/metafiles/nes/Castle of Deceit (USA) (Unl)-video.mp4"
    2019-03-24T11:28:46 [w] GStreamer; Unable to pause - "file:///home/pi/.config/pegasus-frontend/metafiles/nes/Castle of Deceit (USA) (Unl)-video.mp4"
    [and it goes on and on forever growing file size as well]
    

    Thanks again, this is a great frontend.



  • @fluffypillow said in Announcing Pegasus Frontend:

    @Meldrak I've just pushed some updates, could you check the launching with the latest version (alpha11-34)?
    Yes, could be added, some of them were also requested by others so will take a look on them.

    It works, but finally there's another issue from cemu emulator
    This one create configurations files in directory from the rom launch
    from E:\games\wiiu\cemu\cemu.exe -g E:\games\wiiu[ARPP0101]\code\red-pro2.rpx -f
    shaders, profiles, settings should be read from E:\games\wiiu\cemu
    but instead it create new files in E:\games\wiiu[ARPP0101]\code\

    It's not a Pegasus issue, so I Don't think you can do anything
    as workaround I'm launching bat file for each rom like that

    @ECHO off
    CD E:
    CD E:\games\wiiu\cemu
    SET HOME=E:\games\wiiu\cemu
    E:\games\wiiu\cemu -g "E:\games\wiiu\[ARPP0101]\code\red-pro2.rpx" -f
    


  • @Purg-Derren @jerzeeloon yes Pegasus started crashing on Android not too long ago. Not sure what causes it yet but will look into it.

    @nemo93 ah I see the problem now, thanks. Yes, the single dot should mean an empty line, it's fixed now in the latest release.

    1. Pegasus launch time.

    Will look into it. If you have example XML and metadata files where this can always be reproduced, that'd also help.

    1. It occurs whenever the "collection" or metadata.txt refers to a non-existing file (or files).

    Hm will see if I can control GStreamer somehow. Do you have lots of assets in the metadata that don't exist?

    @Meldrak yes some programs seem to have troubles when they're started from outside of their directory. I'll try to fix this in the next release.



  • Weekly changelog! Had some real life issues this week so there aren't too many changes, however there are fixes in several important areas:

    • Changed the default working directories
      • Currently the working directory when launching a game defaults to the game's directory. Unfortunately several programs have issues when launched outside of their own directory (esp. on Windows), resulting in various files written to the game's folder. To make launching more natural, the default working directory is now the launched program's folder, except when the program is a globally installed command (more common on *nix), in which case it remains as the game's directory.
    • Added support for variables in the working directory field of the metadata files. The variables are the same you can use in launch commands.
    • Handled some corner cases of launch commands
    • Fixed empty line handling in metadata files
    • Fixed Unicode support not working well in metadata files on certain platforms
    • Fixed Debian package release
    • Minor performance improvements for metadata file reading

    (By the way I understand these aren't particularly interesting changes for most, but such things have to be worked on as well. Hopefully we'll reach some more exiting features in the future!)



  • @fluffypillow please do not worry, although those are """ minor""" changes those are important, please keep going and fix whatever needs a fix either in the frontend or in your life, I hope the boxart size bug is fixed anytime soon or the hide cursor option is added but better focus yourself in what is important, thanks friend



  • When I changed my source from Skraper to both it and EmulationStation I get a crash.

    332C5041-BE65-4C81-9A46-3FCC3DEA1718.jpeg



  • @fluffypillow I just want to say thank you for fixing the issue on Android not returning to frontend when exiting an emulator. The latest automatic build works perfect and finally the front end I want as my daily driver will be.



  • @hooperre Could you check it with the latest version? It won't fix the issue but has slightly more logging during the loading. I have an idea where the crash comes from but couldn't reproduce it yet, so this'd be to confirm my suspicion.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.