Please do not post a support request without first reading and following the advice in

Announcing Pegasus Frontend

  • Weekly update! The week was more spent with experimenting and trying out a few things, so only some smaller changes this time:

    • Added support for disabling the mouse cursor if needed
    • Fixed the file selector not appearing for multifile games
    • Fixed the main theme not remembering the last launched game

    Also there'll be likely no updates next weekend (I'll be away for a few days).

  • @fluffypillow is there a way to configure/map controls inside pegasus-frontend and tell retroarch to use that configuration from pegasus-frontend?

  • @spartan not yet :(

  • Hello,
    I test Pegasus-fe since some times, and it's very promising. Unfortunately, it's difficult to find new themes.
    I 've find only an additional one (very nice, so it's the one I used)...

    I've just a question, and don't find it in the docs. Is there a way to change the video playback volume ? or simply disable the video snapshot sound ?

  • @carlhungus74
    I too would like this volume-feature, I would guess that the video playback is consistently about 30% louder than the actual game sound.

  • I just installed Pegasus this morning and really like the look of it. I'm currently using a SN30 PRO controller from 8bitdo and I have them configured and working properly in the front end. When I launch a game they don't work however the keyboard I have attached does work. The controller works perfectly in EmulationStation.

    Any suggestions on how I can fix this?

  • Global Moderator

    @Magma You'll need to configure the controller in your emulator also, Pegasus is just the frontend, has no influence on the emulator's settings.

  • @mitu I have to configure it per emulator even though it worked fine in EmulationStation on Retropie? How would I go about doing this? I didn't see a per emulator option in Pegasus.

    Is there a way to just copy the settings that were used in EmulationStation?

  • Global Moderator

    @Magma You didn't mention you're using RetroPie. If you configured the controllers in Emulationstation, at least the RetroArch cores should work. Can you get a verbose log from Runcommand from a RetroArch based emulator ? and post it on ?

  • @mitu Sorry I'm a bit inexperienced. Is there a command to run from a prompt for that or something?

  • Global Moderator

    @Magma When starting a game, use the Runcommand launch menu to enable verbose logging. After the game is run or you exit it - get the /dev/shm/runcommand.log file and post it on
    And add some more info about your setup -

  • Pi Model or other hardware: 3B+
    Power Supply used: CanaKit 2.5A USB Power Supply with Micro USB Cable and Noise Filter - Specially designed for the Raspberry Pi 3 B+ (UL Listed)
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.4.12
    Built From: Premade RetroPie image
    USB Devices connected: Logitech keyboard
    Controller used: 8bitdo SN30PRO
    Error messages received: NA
    Log found in /dev/shm/runcommand.log (if relevant):
    Guide used: NA
    File: NA
    Emulator: Retroarch SNES
    Attachment of config files:
    How to replicate the problem: Launch a game from Pegaus Front End. Controller works in front end but not in game.

  • Global Moderator

    @Magma The log shows the controller is not configured for RetroArch:

    [INFO] [udev]: Keyboard #0 (/dev/input/event0).
    [INFO] [udev]: Plugged pad: Pro Controller (1406:8201) on port #0.
    [INFO] [udev]: Pad #0 (/dev/input/event1) supports 0 force feedback effects.
    [INFO] [Autoconf]: 0 profiles found.
    [INFO] [Autoconf]: no profiles found for Pro Controller (1406/8201).

    Re-configure the controller in Emulationstation - Controller Configuration - and try again.

  • @carlhungus74

    I test Pegasus-fe since some times, and it's very promising. Unfortunately, it's difficult to find new themes.

    Yes, there aren't too many yet, hopefully it will get better in the future! (I should also update the theme making tutorials)

    @carlhungus74 @AndersHP the playback volume is based on the system's main volume. I think it'd be possible to change that with eg. amixer when Pegasus starts up or launches a game.

    @Magma Unfortunately the gamepad setup is not shared with the emulators yet on RetroPie. Would like to add this feature eventually though!

  • @mitu I rebooted the Retropie and reconfigured the controller. Loaded a game and confirmed it was working.

    Exited EmulationStation and loaded Pegasus. Launched a game. Controller works fine in the front end but still does not work at all once a game is launched.

    Here is the pastebin of the log.

    Looks like the same issue.

  • Global Moderator

    @Magma I think I know what's the issue - you're running Pegasus as root or via sudo, while Emulationstation runs as the user pi. As a consequence, the auto-configuration folder - where the gamepad configs are stored - are different.
    Don't run Pegasus as root / via sudo - it's not advisable and it will break other configurations also.

  • @fluffypillow said in Announcing Pegasus Frontend:

    @carlhungus74 @AndersHP the playback volume is based on the system's main volume. I think it'd be possible to change that with eg. amixer when Pegasus starts up or launches a game.

    But wouldn't lowering the main volume lower the volume in the games also, so the issue will remain the same?

  • @mitu Perfect that did the trick. Thanks so much.

  • @AndersHP You could work around that by first reducing the volume before Pegasus starts, raising when a game is launched (by eg. writing a game-start script), reducing again when you return from a game (game-end), and finally raising again when Pegasus is closed.

    Other alternatives could be changing the code of the theme to play the videos less loud, or changing videos themselves (eg. some kind of volume normalization), though I haven't tried that yet.

  • Ok new question. I want to play around with what images Pegasus uses. Originally I was using the setting from EmulationStation. I went and converted my gamelist.xml's to Pegasus' metadata.txt using I then disabled EmulationStation in the list of data sources.

    After relaunching Pegasus 0 games were found. I believe this is because there is no Collection info at the top of the metadata.txt in each rom folder. Here is an example of the top of one metadata.txt

    I'm not sure how to configure it correctly to work with Retroarch. Currently only have the following systems, SNES, NES, Genesis, and FinalBurnAlpha.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.