Please do not post a support request without first reading and following the advice in

Announcing Pegasus Frontend

  • @fluffypillow I tried the same microsd on my pi2 and it also happens. Then I tried a fresh retropie stretch image without updates and it doesn't crash on my pi3b+. So now I have to update and try and recreate the bug. Fun stuff.

  • @fluffypillow Need your help here on the new collections textfiles:

    If I am adding a .exe windows game, how would I set up the path to it?
    Say my game is in D:/Games/Firewatch/Firewatch.exe

    I've tried a few different types but Pegasus can't find any games

  • @Darksavior interesting, thanks for testing!

    @halfmanhalfcake in this case I'd create a D:/Games/collections.txt looking like this:

    collection: Windows games
    file: Firewatch/Firewatch.exe
    launch: {file.path}

    and add D:/Games to [config directory]/game_dirs.txt. File paths like above are relative to the collection file; I'll add a note about this in the documentation.

  • @fluffypillow Thanks, but no luck.

    Here's what I have as a test:

    • game_dirs.txt in my '[config]/pegasus-frontend' - (which was found in the 'lastrun.log' as I checked).

    "Found C:/Users/Me/AppData/Local/pegasus-frontend/game_dirs.txt"
    ES2: system config file not found
    Steam: no installation found
    Data files loaded in 3ms
    0 games found

    Which inside 'game_dirs.txt' contains:


    I have collections.txt and metadata.txt in D:/Games.

    In collections.txt:

    collection: Indie Games
    file: Firewatch/Firewatch.exe
    launch: {file.path}

    and still says no games found :(

  • @halfmanhalfcake hm you should also get a Found D:/Games/collections.txt on the log... perhaps something goes wrong with the Windows path handling, I'll see if I can reproduce this the weekend.

  • @fluffypillow I'm now stumped, heh. Updated clean retropie stretch image = ok. Same clean image but copied my /configs/ folder over = crash to commandline with no working kb and EGL error. Oh well, I don't use reicast often.

  • @darksavior hm, is there anything graphics/OpenGL related in the configs maybe?

  • @fluffypillow Yea, it must've been. I started from scratch again, and this time I only transferred the scraped art and gamelist xml's. All's good. I did have that minor inconvenience of the kb not working while doing this. Hope there's some progress in catching the bug with that.

    Also, @administrators @Global-Moderators @buzz or whoever can help, I haven't been getting any notices at all for almost a week. I don't get notified on replies and watched threads.

  • Global Moderator

    @darksavior Try to check you settings and make sure you disable/enable the relevant notification settings.

  • Been a while since we last had a proper changelog; here's what happened this week:

    • Added page up/down support to the default theme (keys are PageUp/PageDown and L2/R2 (>> @AndersHP)
    • Fixed some games appearing multiple times
    • Improved shutdown/reboot implementation (somewhat more important on Windows and Mac)
    • Added program icon and Windows .exe icon
    • Fixed a bug where some assets were missing from symlinked dirs
    • Fixed some formatting errors in the log output
    • Slightly reduced the memory usage
    • Slightly faster startup time
    • Builds for all platforms are now also available here

  • @fluffypillow Any luck re-producing this?

  • @halfmanhalfcake hm it seems to be working fine for me, on a Windows 7 test setup. I've created a new E: partition, a Games folder on it, and a fake E:/Games/test/hello.txt file. Then added E:/Games to the game_dirs.txt, and created E:/Games/collections.txt with the following content:

    collection: My Games
    file: test/hello.txt
    launch: notepad {file.path}

    Then, Pegasus detects the game_dirs entry, the collections file and the text file, and opens it in notepad on select. So with the Windows paths working, I'd guess the issues might be caused by something else. Probably you've already checked, but make sure that the file names are correct (D:/Games/collections.txt, not Collections or collection, and not .txt.txt -- some editors save it like that). Also there's no need for quote marks in game_dirs.txt(not sure if that's part of the file or just forum formatting). The direction of the slashes (\, /) shouldn't matter either.

  • @hooperre the hidden tag ended up somewhat more complex than I've imagined from such a small feature. In Pegasus' config files the games to ignore are defined in the collection file, and so they aren't included in the first place. But if it's in the metadata file, like with gamelist.xml, then the list of games will have to be modified again after the reading. While that isn't hard to do, I'd prefer to do it only on the collections' level for now. As a workaround, you could use the Pegasus-style collections file: use ignore-file to exclude individual files, or comment out a whole collection block to hide a system.

  • @fluffypillow Thanks, I've got it working... somehow.

    I re-downloaded and overwrote the files and it now works?

  • Computers are powered by magic ;)

  • @Darksavior You've mentioned an FXP bug earlier (embarrassingly long ago, sorry); did you mean using the FXP protocol directly in whatever program, or just a regular FTP connection? I've tried opening an SFTP channel before both reboot and shutdown, but everything seemed to work fine on my side. If it's only with FXP, what kind of setup do you have exactly?

  • @fluffypillow Now the artwork doesn't work.
    It's not meant to be :(

    I have the /media folder, which worked for ES2 xml files, but not for this new config. I've tried to add the -boxFront suffix, copied the filename of the rom, but no luck.

  • @halfmanhalfcake that might be a bug, I'll check tomorrow.

  • @fluffypillow I haven't had that bug in like the month+ I've used the stretch version of retropie. I use flashfxp in Windows 10 to transfer files via ssh (port22). I figured it was either the new os or something you did. Thanks, though.

    The keyboard not working is still there,though. So for something that requires a keyboard like the alsa mixer, I'll have to exit pegasus first.

  • @Darksavior Yeah that keyboard issue is quite annoying, but I couldn't fix it yet. It seems as if some underlying component fails to get the input, so I might need to contact the Qt devs.

    @halfmanhalfcake I can confirm that bug, will fix it as soon as I can!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.