Please do not post a support request without first reading and following the advice in

Kat5200 installer (experimental)

  • @future-child said in Kat5200 installer (experimental):

    Zerojay makes his own decisions for his restopie extra's scripts , if you want changes to emulators you can contact him as well but last i read he was not all too eager supporting retropie 4.4 (stretch).

    I'm only intending on supporting stretch, however it looks like stretch broke a lot of stuff in my repo and no one's figured out how to fix those issues yet.

  • @zerojay said in Kat5200 installer (experimental):

    Stretch broke a lot of stuff in my repo and no one's figured out how to fix those issues yet.

    Is here a topic referencing this ? Do you have any examples for packages that are broken on Stretch ?

  • @zerojay I see, my bad i remembered you stating no longer knowingly supporting one and mistakenly assumed it was stretch.
    As @Mitu asked, is there a active topic for these packages that need help ?

  • Not that I know of. It looks like an issue with EGL and the glshim program I was using for 3d games.

  • @adriansos666 could you please share MD5 checksum for BIOS and M.U.L.E file you used? i tried many OSA and OSB files, multiple M.U.L.E. .atr files and kat5200 always hangs on start screen with just rainbow MULE graphics and moving sprites but no text at all at the bottom (no option for select number of players and game type selection is also not visible). same .atr under atari800/atari800-lr seems to be working good but from what i see those two emulators do not support more than 2 players and i need 4 player support.

  • @aeon_flux
    I have the following checksums on kat5200-0.8.1 where M.U.L.E does what you describe, same checksums with Atari800 do work correct.

    5200.rom     md5: 281F20EA4320404EC820FB7EC0693B38
    atari800.rom md5: C07454070635C73B4BFF043122D31344
    ATARIBAS.ROM md5: 0BAC0C6A50104045D902DF4503A4C30B
    ATARIOSB.ROM md5: A3E8D617C95D08031FE1B20D541434B2
    ATARIXL.ROM  md5: 06DAAC977823773A3EEA3422FD26A703
    M.U.L.E.atr  md5: C06EF1C6223A5A32600C3FAB3EE5C02F


    Seems like an emulator bug of some kind, you can contact the autor of kat5200 here if you wish. i have contacted the author about this, if i receive a reply i will post an update.

    I've seen some code relating to multi tap MultiJoy4 support in atari800 which would indicate support for four controllers, i'll see if i can find out if it actually works.

  • @future-child i'm getting same screen as you attached. no text for game/number of players selection + sprite of plot is broken. it looks emulation is not working good for mule on kat5200. found single file (.com) version but it behaves same way as original disk image which is using 2 stage loading (.atr)

    i tried atari800 as well with same ROM and game image - when i setup it for 800/OSA machine it shows option for 4 players on main screen but only two controllers are detected. i tried also multijoy4 but it is not detecting any controllers (not even single one).

  • @aeon_flux browsing in the source code of atari800 i came upon two comments indicating there should be support for four joysticks in atari800:

    2015-06-02  Petr Stehlik <>
    * sdl/input.c: preliminary support for four real joysticks
    2018-05-01  Petr Stehlik <>
    * implemented joyhat support for all four real joysticks (command line,
      configuration file and also the F1 TUI configuration). Original patch
      from Michal "Baktra" Kalous, with my fixes and clean up.

    There is also (sdl) code initializing/reading the four joysticks but i am unable to find any code to configure settings for the extra two.

    I am not able to test this myself as i have no additional controllers, you may want to try compiling the latest version of atari800 and start it with parameters -joy0hat -joy1hat -joy2hat -joy3hat added to the runcommand (or add SDL_JOY_2_USE_HAT=TRUE and SDL_JOY_3_USE_HAT=TRUE to the config file) and see what happens.

  • @future-child i have tried both (parameter and configs). unfortunately it still detects only 2 controllers with atari800 binary. i tried also with latest source from github but no success too :(

  • @aeon_flux i have opened a ticket here maybe they can confirm it working or not.

  • I installed Kat5200 using the link above (wget -N - ROMS are in the atari5200 folder, BIOS files in BIOS - when I try to launch a 5200 game, I get the config screen, and every time I fill it out it works (e.g. I can run the game if I go to "return to game"), but it does NOT save the configuration - when I start up again, I get back to the setup screen, and it says it couldn't load the profile/settings.

    My kat5200.db3 is empty, zero size, and the log file tells me the tables don't exist - so I think I need a "clean" install copy of the db3 file? Where can I find it? I tried reinstalling and nothing changed....HELP!

  • @wolfgangrumpf normally the install script downloads the database to /home/pi/.kat5200/kat5200.db3
    It is done by this line in the script:
    wget -N -O kat5200.db3
    Possibly the download was incomplete causing the zero sized file.

    Also if you have not yet rebooted your pi, the default database should still be in the /tmp/src directory where kat5200 was built.

  • Utilized this script today and it worked like a charm. Be sure that the system rom is named 5200.ROM, not 5200.rom. :)

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.