Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PowerBlock Endlessly Reboots



  • I just received my PowerBlock and followed the auto-install instructions on the GitHub home page. I then shutdown my Pi, disconnected the power and plugged it into the PowerBlock. I then plugged the PowerBlock onto the GPIO, and jumpered the pins for the SWITCH. The Pi turns on, and the RetroPie splashscreen displays while the system boots up. Right before EmulationStation is set to display it's loading splashscreen, the system shuts down then reboots. It continues to do this reboot cycle over and over again until I pull the plug.

    I saw an issue already posted on GitHub about this, and added my own input to the thread. I wonder if either the install script is not getting fully installed (as I have some warnings appearing in the terminal log) or if maybe my PowerBlock is faulty.

    Has anybody else had any experience with this, and had this happen to them? What is the solution? Is there any way I get the boot log so I can see what's causing the reboots?


    EDIT - I feel I should also mention that I tried to install it via the terminal, and it didn't work. So I uninstalled it in the terminal then tried to install it again with the same results. My latest test was to uninstall it, erase the entire folder, and then install it via the RetroPie-Setup scripts/menu. I still have the same results.


  • Global Moderator

    When the system shutsdown after boot it is an indicator for the PowerBlock driver installed and running "properly". Somehow the driver gets the signal to shutdown.

    Can you tell me, which RetroPie image you are using? Could you also post an image of your hardware setup here, please?

    You can read out the filesystem when you, e.g., mount the SD card in another computer with extfs2 support.



  • I'm using the 4.2 version of RetroPie, but I have also been keeping it updated via the RetroPie Seteup scripts.

    I have noticed a couple of times that I"m getting a lightning bolt incon just before it shuts down. I'm using a 5.2v 3A power supply.

    As for an image.. there's nothing to show. It's a Pi 3 , HDMI out, SD card in, PowerBlock on top, power in to PowerBlock, and jumpered SWITCH pins (haven't even bothered trying to wire up an actual switch.

    I don't have another computer that can read extfs2. Just Windows 7 which reads my SD cards via a reader (which gives me just the boot folder).



  • I did some further experiments.. Power through the PowerBlock, driver not installed. Jumper the pins, and the Pi powers up. FULLY powers up. System is stable. I go in and tell RetroPie to shutdown the system. It exits ES, then nothing. I pull the plug and reconnect it. Insta-boot (forgot I had the pins still jumpered). Shut down again, pulled plug, removed the jumper, power in. Nothing (like it should). Jumpered pins, powers up and system stable. So the power functions of the PowerBlock seem to be working right.

    Go in through the RetroPie-Setup scripts to install the PowerBlock driver. Nothing happens. I pull the jumper, nothing happens. I then go into the Config options in the script and tell it to disable the driver. It says success. Then I go back in and re-enable the driver. The system starts the shutdown routine and fully shuts down (like it should). Power LED (on the Pi) off and everything. I then jumper the pins, system starts up then reboots just like before.

    So is this a driver issue, or a hardware issue? It seems to only do it when you're using the driver software.



  • I managed to get a photo of my boot log screen (by pressing ESCAPE during the splash screen). Please excuse the white blob, that's my flash. And the BB-8 is my, well.

    alt text

    To be honest, this screen flashes by so quickly, I don't know if there are more lines or not. Basically everything goes by good, then all of a sudden it goes really quick then does it's reboot. I'm not sure if more lines follow or not.

    It is interesting that there is an error mounting the USB, although I never have issues without the PowerBlock, so it may not be related. Hope it helps.


  • Global Moderator

    One idea: We had several reports in the past about problems that arise when the power supply or the USB cable do not provide enough power or are too thin (i.e., too high resistance), respectively. You should get rid of the lighting bolt by trying out another power supply. We made excellent experiences with the original Raspberry Pi power supply, but others have also reported that they are using all other kinds of power supplies that have enough power with success.


  • Global Moderator

    BTW: You can show the information from the boot process with the command dmesg.


  • Global Moderator

    I will try to reproduce your observations to better understand what might go wrong in your case ...



  • I really don't think it's a power supply problem. I've been tackling the power for a couple of months now. Originally, I was getting the lightning bolt all the time, using a cheap knockoff brand. So I spent a little more money and got a good name brand CanaKit power supply. I was still having issues. This is all with the power supply going directly into the Pi. I bought another CanaKit, thinking mine was faulty (it was buzzing). It too had the lightning bolt but only when the system was under heavy load (pulling data from the hard drive). So I upgraded to a higher voltage, higher amperage, thicker wire power supply. All of the lightning bolts were gone. The system is 100% stable.

    Fast forward to using the Mausberry Circuit (direct plug). As soon as I connect it up, I started getting the lightning bolts again during heavy loads. Nothing changed in my setup, only that I added the Mausberry between the power plug. Everything works like it should, but the lightning bolt was annoying. I played around with turning off that alert, but ended up corrupting the SD card. I don't think it's related, as I discovered the flat SD card cable I was using had gotten "chewed" when I tried to reassemble the case this is all in. But, since I was still getting the lightning symbol (only hidden), I decided to try the PowerBlock.

    Now, using a clean install, and nothing is hidden, I've got the system completely stable again. 100% running, heavy loads and all, and the lightning bolt doesn't appear. I receive your PowerBlock and install it as described. The only issue I have is the reboots. I only saw the lightning bolt twice, in the 30-40 times I've been watching it. I only mentioned it because I thought it might have been a possible cause for the reboot. Where the circuitry detected a drop in power somewhere and took that as an indication that it needed to shut down. Since the pins are jumpered, it automatically powered back on.

    I wonder if the PowerBlock is bad. I looked at the scripts and saw the command the installer uses to do the shutdown. shutdown -h now As an experiment, I took my 100% working system (without the PowerBlock) and opened up a terminal. I ran that command to see what it does. The screen displays a lot of "stopping blah blah", before shutting down. With the PowerBlock connected, I never see those lines. I don't believe the PowerBlock is getting a true shutdown signal. If it were, it would display all those stopping lines. Instead, I see the screen I posted. A lot of "starting blah blah", and then instant power off and reboot.


  • Global Moderator

    Thanks for the elaborate information!
    Ok, I will prepare an SD Card image with the PowerBlock driver installed. In that way we can ensure that the software part is working as intended. I will use the current RetroPie image, ok?



  • @hansolo77 You should be using a switch rather than a "jumper" connection just in case you have forgotten to remove the jumper. The PowerBlock seems to be working well from your previous post. The Pi boots when the jumper is in place and shuts down when you remove it.

    Are you using standoffs when the PowerBlock is installed on the RPi3? Or are you just relying on the GPIO pins to hold the PowerBlock in place? There are SPI pins on the RPI3 that lie under the PowerBlock when installed. If you do not use standoffs that are tall enough to clear these pins when the PowerBlock is installed, they will cause a short on the PowerBlock which can cause momentary lost of power.



  • @ortsac said in PowerBlock Endlessly Reboots:

    @hansolo77 You should be using a switch rather than a "jumper" connection just in case you have forgotten to remove the jumper. The PowerBlock seems to be working well from your previous post. The Pi boots when the jumper is in place and shuts down when you remove it.

    I've never had it do a shutdown when I remove the jumper. The Pi never gets fully booted for me to test that functionality. The only thing I know is that it won't power on if the jumper is off, then it comes on when I put it on.

    Are you using standoffs when the PowerBlock is installed on the RPi3? Or are you just relying on the GPIO pins to hold the PowerBlock in place? There are SPI pins on the RPI3 that lie under the PowerBlock when installed. If you do not use standoffs that are tall enough to clear these pins when the PowerBlock is installed, they will cause a short on the PowerBlock which can cause momentary lost of power.

    This could be an issue. I'll have to double check. I don't have anything to use as a standoff, and the PowerBlock didn't come with any.



  • I can now confirm that it is definitely NOT getting shorted out because of the contacts touching something it shouldn't.

    I did some more software-side troubleshooting. I wonder again if maybe the installer didn't fully install right. If I install the drivers via the RetroPie-Menu, it then gives you an easy to use Config, to enable or disable the driver. However, if I tell it to disable the driver, and then edit the file /etc/powerblockconfig.cfg, the status is still written as "activated" : true. So I wonder if the RetroPie installer is to blame? It's clearly not changing the status of the "activated".



  • I uninstalled everything made through the RetroPie-Setup script for the driver, then went through the lines one at a time to manually install it (just in case there was an issue with the auto installer. I got as far as installing it (not the daemon service) and tested it. The system stays off (like it should) until I jumper the switch pins. Then it powers on (like it should). This time, it goes all the way through and the system is running. I then tested the shutdown by removing the jumper. The system didn't react, just stayed running like it should.

    So to me, this is a new problem, and constant rebooting is an issue with the daemon service part. But I am closer now. :)


  • Global Moderator

    I have uploaded a RetroPie V4.2 image that has the PowerBlock driver and service installed. You can find it at https://db.tt/lMXMBQ1Suf. I tested it also with a jumper as switch.

    Also, I took the chance and wrote a dedicated getting started tutorial for the PowerBlock and RetroPie: https://blog.petrockblock.com/2017/08/17/tutorial-powerblock-retropie/

    You also find a short video demonstration there.



  • Thanks, downloading it now. I will test on my end to see if I still have the same problem.



  • The PowerBlock still isn't working right. I installed the clean image you provided. I then installed the SD card to the Pi, connected HDMI and the controller. I then plugged on the PowerBlock, connected power, then jumpered the switch pins. The system came on like it should, and didn't do a constant reboot (this is good). But then when I tried to switch it off by removing the jumper, nothing happened. It just sat there like nothing happened. I re-connected the jumper, and all of a sudden the system rebooted. It didn't shut down, just rebooted. It came fully back up, and I tested pulling the jumper again. Nothing happened again. I re-connected the jumper again, only this time it didn't reboot, it just continued to sit there. I pulled and re-connected the jumper 3 or 4 more times, then it just randomly rebooted again.

    I think there's a problem with the PowerBlock. Either a poor solder connection, or the IC isn't programmed right, or something. I'm doing everything right on my end. I think the automatic installation scripts on the PowerBlock git page needs tweaked, as it just won't work with that at all (causes constant reboots). Doing it line per line manually works as far as halting the reboots, but the system still won't do a graceful shutdown no matter what I do.


  • Global Moderator

    @hansolo77 Sorry to hear. The instructions at Git are correct, I tested these recently. Also, since you are facing the issues also with the prepared image, it is some sort of a hardware issue.

    Please send me an email with your order number for a replacement.



  • @petrockblog Thanks.. I just forwarded a copy of my receipt to info@petrockblock.com.



  • Just for sh!ts and g!ggles, I connected the LED to the LED pins. As soon as I connect the power (before connecting the switch jumper), the LED is pulsing. It's not rapidly blinking, and it's not steady ON, but fades in and out. I think I read somewhere that this is what the LED does to let you know that a shutdown is in progress before it completely turns off everything. So if the LED is indicating this now, before even attaching the PowerBlock to the Pi, might that be a reason for it not to be working right? The circuit is in "shutdown" mode. This would explain why pulling the jumper has no effect. But it doesn't explain how it got in that mode. Is there something I can try to do to fix that? I'd still like to get that replacement too, just in case.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.