Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PowerBlock Endlessly Reboots


  • Global Moderator

    @hansolo77 Sorry to hear. The instructions at Git are correct, I tested these recently. Also, since you are facing the issues also with the prepared image, it is some sort of a hardware issue.

    Please send me an email with your order number for a replacement.



  • @petrockblog Thanks.. I just forwarded a copy of my receipt to info@petrockblock.com.



  • Just for sh!ts and g!ggles, I connected the LED to the LED pins. As soon as I connect the power (before connecting the switch jumper), the LED is pulsing. It's not rapidly blinking, and it's not steady ON, but fades in and out. I think I read somewhere that this is what the LED does to let you know that a shutdown is in progress before it completely turns off everything. So if the LED is indicating this now, before even attaching the PowerBlock to the Pi, might that be a reason for it not to be working right? The circuit is in "shutdown" mode. This would explain why pulling the jumper has no effect. But it doesn't explain how it got in that mode. Is there something I can try to do to fix that? I'd still like to get that replacement too, just in case.



  • @hansolo77 Here's what the LED status mean:

    The LED will blink in four different patterns that depend on the power state of the Raspberry Pi:

    1. Off: The LED is simply off.
    2. Booting: The LED slowly fades in and out.
    3. On: The LED constantly stays on.
    4. Shutting Down: The LED fades in and out twice as fast as during boot up.

    How fast does the LED "fades in and out" on your power up?
    If it is like #2, then the service is not running or stopped, and it is trying to boot up.
    If #4, then there is definite something wrong.



  • Not knowing how fast it's supposed to be one way or the other is a problem. I would say it's slow, completing a whole ON/OFF in about 1 second. I've seen it do rapid blinks, like maybe 2 or 3 in a second, so I'm guessing that's the other one. Troubling thing is, it's pulsing before I even connect it to the Pi and before I jump the pins.. It does it's blinking as soon as I connect the power to it. But in the trials I've been doing, it's never been a solid on.



  • @petrockblog - Did you get a tracking number by chance when you mailed the replacement? I only ask because the first one I ordered was shipped out on August 7th and I forwarded you the confirmation email on the 17th with the order number. So that was a 10-day turn around, with a couple days worth of troubleshooting. It's now the 29th.. you said you mailed it the next day (being the 18th). So it's been 11 days and I still haven't received it yet. I'm not mad or nothing, just understandably concerned. I hope it wasn't lost in the mail or anything. If you do have tracking information, can you check on it's progress? I'm just eagerly anticipating. :) Thanks!

    EDIT - My bad. Looks like it just arrived today. I'm on my way out for work but I'll give it a go when I get home. May I ask.. what is the best way to install the driver? First thing I'm going to do is test the circuit on that prebuilt image you sent me. If that works, I'll be starting from scratch again on the build I've got going already. Is it better to install manually, automatically using the install auto-install script on github, or to use the installer in the RetroPie-Setup script?


  • Global Moderator

    Glad to hear that it finally arrived. I would go for the way that is described in the tutorial at https://blog.petrockblock.com/2017/08/17/tutorial-powerblock-retropie/ - using the quick-install script.



  • Thanks for the advice/tip. As it turns out, I think my Raspberry Pi is damaged. I can't get it to power on even with the power plugged into the Pi directly. The red power LED comes on, but the green access light never does. I thought maybe it was the SD card ribbon I'm using, but without it I'm still getting the same results. I then thought maybe it was the card itself. Tried 2 different ones, and I get the same thing. Tried a different power supply, same thing. Tried the power and SD card in another Pi and it works fine. So I have to get a replacement Pi. Until then, it's the waiting game again. :(



  • Got my replacement Pi in the mail today. Just got home from work and tested the new Pi with the new (replacement) PowerBlock. Works exactly like it's supposed to, with the jumper at least. I hooked up an LED to watch it and it blinks slowly then goes solid when the system comes on. Then it blinks while it shuts down (faster) until power off, then the LED is out. Jumper on again and it boots right up. This is all with the "pre-installed" PowerBlock driver version of RetroPie you sent me. One thing I noticed, when it's shutting down it looks like it hangs on a line saying something about "Stopped dhcpcd on all interfaces". Is that normal? Anyway, I then swapped out the SD card with the one in my current build. Instantly it starts endlessly rebooting again. I remembered I hadn't installed the driver yet (because I was using a "pre-powerblock" backup). So I powered up directly and first tried to do the install via the RetroPi-Setup menu. I know you said I should the tutorial on the blog, but I thought I'd try it this way first. Well, it installed ok, but when I hooked it all up through the PowerBlock, the LED never stops blinking. It fully boots up now (yay!) but pulling off the jumper doesn't cause it to start shutting down. I don't think the install went through. Not sure what's wrong there. Anyway, I went back to the working SD card with the "pre-installed" driver and just used that as a base and just started over. Everything looks like it's working correctly now.

    So 2 things:

    • Why does it appear to hang when shutting down at the line saying:
    [  OK  ]  Stopped dhcpcd on all interfaces
    
    • Why doesn't the "Install PowerBlock Driver" work from the RetroPie-Setup menu?

  • Global Moderator

    After the installation of the PowerBlock and the ControlBlock drivers you need to enable the driver in a second step. I realise that this is not intuitive so that I created a patch for the RetroPie Setup. In the future, the drivers will be enabled with the installation.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.