Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

ControlBlock reset button



  • For some reason the reset button now works...

    Only thing I did was power down the pi for a couple of days.


  • Global Moderator

    Strange.Sounds like a

    But glad that it is working for you now.



  • @petrockblog
    It must be a wiring issue, I'll redo the wiring to the reset button tomorrow.

    Strange though that it also didn't work with the jumper wire trick...



  • @petrockblog
    Sadly the button has stopped working again. When I run JSTEST I see that it does register inputs, but it just doesnt do anything.

    I checked everything with a multimeter and the button itself works flawlesly. I'm thinking of a few things that could be causing this:

    1. A config problem, as in I need to set something in a .cfg file to make it work
    2. the fact that I haven't wired up the snes controllers yet, nor that I've configured the snes Controlblock controllers.
    3. My PSU isn't passing on enough current to make it work correctly. ( I noticed that I do get the occasional lightning bolt)
      or
    4. I'm cursed

    Any help would be greatly appreciated



  • @petrockblog

    Well I finished my christmas project for 99% (see pic).

    I configured the correct controller for each emulator using this method: https://github.com/meleu/RetroPie-joystick-selection/blob/master/README.md
    The only problem I have now is that the reset button still doesn't work. It issues a two button command and the escape key as stated in the description. Sadly this doesn't close the emulator.

    I can work around this in (s)nes games but for megadrive/genesis games, the only solution is to reboot the pi...

    Very annoying. I'm now 99% certain that this is a configuration problem as pressing the escape key on a keyboard also doesn't close the emulator.

    Any help would be greatly appreciated again.

    (I also started from scratch today with a new retropie image)



  • Anyone...?



  • Well I think I've solved it..
    I did a full reinstall and it still didn't work.
    I configured my raphnet nes controllers first and the edited the retroarch config file setting the hot btn to "nul" and the exit emulator key to "escape"

    Then I setup my megadrive controllers conected to the gamepadblock and the snes controllers connedted to the controlblock.

    I edited those configs as well, deleting the save- and load state entries while I was in there ( setting the hot btn to "nul" eliminates the need to press two buttons at once, making it so that when you pres left for example, it saves the game).

    I now have a working physical reset button for all my systems :)


  • Global Moderator

    Glad to hear!



  • @moch said in ControlBlock reset button:

    @petrockblog

    Well I finished my christmas project for 99% (see pic).

    Hi @moch, this looks amazing and exactly like I imagine my build. You don’t have a Tutorial online somewhere by any chance? (I know, it’s a year later ;))

    Best,
    Shukuyen



  • Hi @shukuyen ,

    Sorry, I didn't make a tutorial but it was all pretty straightforward in the end.
    I gutted an old Nes and dumped everything in :)

    Parts used:

    • Rpi3 + microsd
    • Raphnet dual nes to usb
    • Petrockblock's controlblock and nylon posts
    • Wiring

    The hardware part was the easiest part tbh.
    If you get it all wiredup i can make an image of my sd. That way you shouldnt have to configure anything :)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.