Please do not post a support request without first reading and following the advice in

Gamepadblock Firmware Updater Not Working

  • I've tried updating firmware on a mac, and a PC. On the Mac, the versions I tried are 10.10.x and 10.13.x. In both cases the firmware updater crashed with a bad instruction before the GUI launches.

    On the PC side, in Windows 7, the updater opens up to the GUI, but can't find the Gamepadblock (though Windows itself can see the USB device.)

    My end goal is to use it on the Raspberry PI (where it currently already works as a controller.) Is it possible to skip the GUI and use terminal commands on the PI to update the firmware instead? If not, i'm happy to try to do whatever it takes to update the firmware, but personally, I don't really care about having a GUI to get it done.

    In my search on this topic in this forum I read that another user tried changing USB cables. That made no difference here.

  • Global Moderator

    I am sorry to hear that you are having trouble with the updater. Actually, I am nearly done with rewriting the updater from scratch up. Everything is implemented, I am currently testing it on various platforms. It is a command line tool (written in Go). I could send you that tool in this beta state, if you like?

  • @petrockblog Sure. that would be great. I'd love to check it out.

  • @petrockblog so can you send me the updater?

    I have wiring tested for mutilple controllers. My next step is to test some stuff I wrote for the pi to automate switching of controllers. I can’t start testing that until I can update the firmware.

    Any help would be appreciated.


  • Global Moderator

    I have just finished the preparation. Please have a look at the new Downloads site for the GamepadBlock at The update tool for the various platforms is pre-compiled and downloadable from there.

    I am looking forward to feedback!

  • @petrockblog I’ll check it out here in a few hours. Looking forward to it. Thank you!

  • I used the new updater and it appears to have worked for the most part. I did post an issue on Github, but it's probably something minor. In the meantime I've managed to take advantage of the com port stuff, so I know the firmware update is in effect.


  • Global Moderator

    Thanks for the feedback!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.