Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Custom configs for CRT using the built-in composite out



  • @Sakitoshi said in Custom configs for CRT using the built-in composite out:

    @tix to make a particular game use the retropie defaults you can make a game override (inside retroarch. quick menu -> overrides -> save game overrides) and then modify it replacing the contents of the override file (should be located at configs/arcade/config_crt/MAME 2003 (0.78)/*name of the game.cfg*) with the default retroarch config (you may have a copy of it named retroarch.cfg.rp-dist).

    arcade default:

    # Settings made here will only override settings in the global retroarch.cfg if placed above the #include line
    
    input_remapping_directory = "/opt/retropie/configs/arcade/"
    
    #include "/opt/retropie/configs/all/retroarch.cfg"
    
    

    that will make that game behave as if you don't have my configs and of course you can edit that config file to your liking to make the game look as you wish.
    Thanks man !

    I guess vector games will benefit greatly by turning on 480i mode ?
    Can you give an example of a override config, doing this ?



  • @tix 480i mode is a thing of my scripts, not part of retroarch, so editing that config file will not activate it.
    for that you need to put a file named 480i.txt inside the folder of the system you want to force 480i, inside the file you have to write the name of the rom file (preferably with its extension) and that's it. this is explained in the readme at github btw.
    if is an arcade game and you have the optional arcade tweaks the 480i file should be already there, so you only have to add the vector games to the list.



  • @Sakitoshi
    Hi, I have a little problem. Perhaps I misunderstood something or missed something?
    Of all the guides for setting up a RetroPie for CRT TVs, one general advice can be made - disabling the overscan. It really contributes to a better picture. However, after disabling the overscan, my screen shifts to the left, up and down, so I do not see many elements of the UI ​​in games. For example, I made this image.
    001.png
    002.png
    Of course, in the retroarch settings, you can adjust the offset and scale, but in this case the pixel perfect is violated and the whole point of this idea disappears. Therefore, I had to adjust the offset and scale in my TV (thanks to the service mode). I did it, but on other TVs the picture is still cropped. Is there any way to fix this?
    So I wonder, is this a common problem, or is it just me?



  • @frgn are those images just examples or the grayed out area represents exactly how much image you are missing?
    because if those are direct captures from your raspi I can easily tell that the nes emulator is cutting overscan (and the genesis emu too, but the image is adjusted correctly, so it doesn't matter). it's natural to lose some of the borders, but that castlevania screenshot is obviously wrong.

    fceumm, nestopia and genesis plus gx (picodrive has the option too, but it only disables vertical cropping, not horizontal) have settings to not crop overscan.
    1e1cda13-ff8c-4322-ad12-27d664e95951-image.png
    that image is from my pc, but you need to turn off both cropping settings.
    my configs have that already set up, so you missed copying some files (or the settings changed so my pre-configuration broke, I haven't checked).

    for reference, here is how many pixels are missing on my tv set:
    NES:
    240pee-200126-030306.png

    SNES:
    240pSuite-200126-030504.png

    Genesis:
    240pTestSuite-v15-200126-030558.png



  • @Sakitoshi
    thanks for the answer. I will check these settings soon and I hope this helps.
    I painted these images in paint. Of course, they do not show an exact picture, but only an example, so that it is clear what I'm talking about.
    I didn’t copy anyone’s settings, I tried to do everything myself from the very beginning (but at first I read a lot of manuals, including yours). I did this in order to figure out how scan and image rendering work on older gaming systems.



  • @Sakitoshi
    I copied all your settings and now everything looks great! but I have a problem with psx games (driver and driver2). for some reason they are flattened. other games work well.
    2020-01-30 15-20-37.JPG 2020-01-30 15-16-27.JPG
    I also would like my menu to work in 240p so that there is no flicker.
    can this be changed somehow?

    UPD - Destruction Derby 2 has the same problem.
    And they are all from one publisher. Very interesting...

    UPD2 - if change the vertical resolution in the settings to 512 pixel or more, the screen aligns. I decided to change the render resolution for psx system (videomodes.cfg file):

    lr-pcsx-rearmed_render = "690x512"
    

    this solves the problem of a squashed screen, but now the image is not as perfect as with your settings.
    I really hope that this can be somehow fixed - for example, add an exception somewhere in the script for games that have this property?



  • @frgn are you using integer scaling? or are those eur isos perhaps?
    both driver games use a wide native resolution (512x240) so integer scaling is a bad idea.
    and european games typically use a higher vertical resolution (256) that the default configs are not prepared to handle, my configs are for ntsc only after all. but that doesn't mean it cannot be fixed, in retroarch you can crank the custom height to 512, adjust the Y pos accordingly and save a game override.



  • @Sakitoshi
    No, initially I did not change anything in the settings. it is these games that behave this way. and yes, all these games of the PAL european region. I noticed that they have a vertical resolution of 256 points (although this is usually 240). I found a PAL-NTSC patcher on the web that corrects the resolution and makes the PAL game work in NTSC mode. I hope this fixes my problem. but I was hoping that in your configs I can change a couple of lines so that it works for such games too?

    What about progressive scan in the ES menu? What needs to be changed so that it is always in 240p, while don't breaking anything?



  • @frgn to always have 240p you'll need to edit a line of your /boot/config.txt from:

    sdtv_mode=0
    

    to:

    sdtv_mode=16
    

    and go to configs/all to delete runcommand-onstart.sh and runcommand-onend.sh

    I also recommend uncommenting (deleting the # at the beginning) this two lines of /boot/config.txt so you can read retropie setup and runcommand:

    #framebuffer_width=580
    #framebuffer_height=360
    

    by doing so you'll lose the 480i blacklist/whitelist support though.



  • @Sakitoshi
    thanks for your work, it was really good. I don't feel any difference being playing there or on a console.
    I'm having a hard time getting kodi to work on it, as I would like to watch my movies in a classic way. Do you know what I need to do to change this?
    I would also like to know if I can distribute a retropie for free on the Internet with its modifications applied? there are people who don't know how to make these changes and it would be a way to help.
    again THANK YOU SO MUCH!


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.