Please do not post a support request without first reading and following the advice in

ControlBlock Sw5 / Sw6 not recognised

  • I seem to have another odd problem, I can map most buttons (I'm primarily using Libretro Mame on RetroPie) but when I try to allocate SW5 and SW6 for either Player 1 or 2 the Mame config interface (accessed by pressing TAB after game is launched) neither button is recognised.

    I've tried replacing the signal cable, checked the Ground connection and replaced the microswitches - nothing seems to work.

    Any idea's?

  • Hope @petrockblog is back online - my problem has got worse since posting. Now none of my buttons or joystick are recognised in ES or the Mame setup. Interestingly ES behaves as if detects a new Gamepad at startup, but none of my button holds cause it to recognise and move to the config input screen.

    However the ControlBlock is at least partially working - the power toggle still works perfectly.

    I'm about to re-check my ground connectors in case one of those has come loose, and if that fails, build a new Retropie and ControlBlock install on a new SD card. If anyone has any suggestions I'd appreciate the help.


  • OK - no reply from @petrockblog but I get the sense he's not very active at the moment due to family commitments.

    I've rebuild RetroPie / ES with ControlBlock drivers onto a completely new microSD card and whilst it all boots perfectly and recognises the keyboard and my USB generic controller handset, the arcade buttons aren't recognised at all in either ES or MAME.

    It looks like my ControlBlockCard has partially failed (power switch still works) after just a couple of weeks use. Anyone know any other contact details for the store that could help me diagnose further, or get a replacement?

  • Global Moderator

    Hello, sorry for this delayed answer!

    Does the input controller configuration work with EmulationStatation? As an alternative, you could also these the "raw" controller signals with the command line tool "jstest". Doing that directly shows what the ControlBlock driver sees.

    Can you provide one or more images of your hardware setup here?

  • @petrockblog Thanks for the reply - not sure if you're the same person who responded by email earlier - don't want to trouble two people!

    The buttons/joysticks aren't detected in Emulation Station, I've tested continuity in the ground lop (after disconnecting from shared ground connection!)

    My jstest seemed to suggest all the buttons are "On" constantly - but pressing them/moving the joystick seemed to have no effect.

    Just in case photos uploaded here as well as sent via email:

    alt text
    alt text
    alt text
    alt text

  • Global Moderator

    If the ControlBlock driver says that a button is "ON" (in this case all buttons are ON) it means that the driver observes a GND level on the GPIO input on the ControlBlock. This should only occur when a button is pressed and pulled to GND.

    To isolate the problem one way would be to disconnect all but a minimal set of wires and see at which point things start to not work anymore.

  • @thedon

    I`m sure meanwhile you solved the Problem.

    Do you remember what has been the reason for the controlblock showing all Buttons are constantly "ON"?

    I am trying to set up a new Arcade Station with RPi3+Controlblock V1.6 + 2 x Sanwa Joysticks & Buttons and I have the same Problem right now.

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.