Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

What famous games have you never ever played?



  • I was scrolling through my games lists earlier and came upon Rainbow Islands in Mame. This is a game that I have read about since it was released, but despite having it available on multiple platforms via emulation for very many years I have never once tried to play it.

    Even when I realised this fact today I still didn’t bother and went and played some Circus Charlie instead!

    So, what games which are highly regarded and very well known have you just never bothered to even try once?



  • Undertale.

    Also, while I really liked Link's Awakening, I haven't played any other Zelda game (I tried A Link to the Past, but quit very early, because it seemed a lot worse than Terranigma)



  • This is proving to be harder than I expected. Since I've gotten back into emulation and this particular project is just awesome I've found myself at least trying all the of famous games I missed out on. I would have to say most arcade games though as we didn't really have any arcades near where I grew up. But I can't say I've actually play A Link to the Past, up until recently I could have counted Final Fantasy VII and Chrono Trigger but I've started them both.



  • I haven't played... Landstalker. That's it.

    I haven't played very much of Ocarina of Time at all. I'm still trying to get the cheat code that fixes the inventory to work.



  • @Efriim Use lr-mupen64plus for OOT. Menu delay fix/hack is already in place (you may need to update from source if you havent done so in a while). The lens of truth will also function properly, which it does not if you are using standalone mupen+rice plugin. In retroarch menu turn less accurate blending off as well otherwise certain effects dont render properly. Currently lr-mupen64plus is the only real way to play OOT properly on the raspberry pi, though I would highly recommend overclocking v3d frequency and core frequency for best performance.



  • @quicksilver I updated from source. I admit the inventory is faster, it doesn't seem totally fixed though. I still get a lot of framedrops, especially when I'm talking to someone, it's probably one of my settings.

    I think lr-parrallel ran better than this, lr-parallel fixed the inventory as well.
    The main problem I was having with lr-parallel was that I couldn't save the settings for some reason, I tried all the overrides, and it saved just a couple of the settings but not all of them. Then I was able to edit the handful of settings manually but couldn't get to the other ones. It still has me baffled. I noticed it with some of my other emulators too.



  • @Efriim I had the same problem with lr-parallel, no setting would save even if I saved overrides. However it was extremely slow even on my overclocked pi 3b+ so wasn't very useful for me. Using lr-mupen64plus @ 320x240 resolution the game runs pretty much full speed for me all the time with only the occasional framerate drop. Mupen64plus-gles2rice runs smoother overall but since the lens of truth doesn't work it's a no go.



  • hate to say this but any zelda games.

    i know, i know.

    i only had PC back in the day. and still have yet to really play anything on my system. to busy tweaking it. lol



  • @ExarKunIv said in What famous games have you never ever played?:

    still have yet to really play anything on my system. to busy tweaking it. lol

    I'm pretty sure that a lot of us here are in that same boat. I'm always trying to find little things to make my build just a little bit better.



  • Yeah, I'm just trying to flesh out these last few emulators; arcade machines and dos, and a few ports. Want to try and free up as much space as I can and figuring out what I want to do with it. Maybe adding somehow to ES; faqs or guides, using firefox or xpdf or even Acrodos adobe acrobat for dos. I think the raspbian system almost takes up a third of my sdcard at 9gb.

    Games I have played on my PI:
    Actraiser, I got to the ending its a pretty short game.
    Dragon Quest III, I would have named this as a famous game if I didn't just play it recently.
    Front Mission Gun Hazzard, I might be like halfway through
    Heracles no Eikou IV, actually I'm not that far but I'm past the beginning and getting into the game.
    Ogre Battle: I'm on the fourth map or so.
    Ghoul Patrol: I don't know but if there is like 200 levels as Zombies ate my neighbors then I'm not very far along.
    Shantae,
    Monster Hunter Freedom Unite, I put in like 33 hours.
    Aladdin for sega mega drive
    Lunar SSSC.
    Ultima 8. I have some of the enchanted items and max stats anyway
    Oh and Final Fantasy 4 complete. I have to replay the return to baron after you become a paladin because I forgot to save.

    And as for a famous game I havent played
    Star Fox



  • There was another topic like this last year where I added my own shameful list of missed greats of the past.



  • @chubsta Any final Fantasy game. I really don't like turn based games. So you could count any famous turn based game in that also.


  • Banned

    This post is deleted!

Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.