Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

ControlBlock not communicating with RasPi 3B+



  • RetroPie boots normally using retropie-4.5.1-rpi2_rpi3.img on a 16GB SD card and I have no trouble configuring the USB keyboard as a game controller. However, when I push a button wired between the ControlBlock's ground and player 1 UP, RetroPie does not recognize that I'm pushing a controller button.

    To boot the system, the ControlBlock's power switch works fine, the RPi boots and the LED fades in and out. When RetroPie appears, the LED continues fading in and out. Also, the power switch does not cause a shutdown and the LED continues flashing. (I'm assuming this is because the RPi hasn't signaled that it's shut down yet.)

    Everything behaves as if the ControlBlockService2 isn't loading at all, even though I didn't see anything obviously wrong go by during it's installation.

    Does anyone have any ideas? Thanks.



  • I re-imaged the SD card with a fresh image of retropie-4.5.1-rpi2_rpi3.img . Then I followed the instructions here: https://github.com/petrockblog/ControlBlockService2#quick-installation

    I noticed that I get messages that fly by during the install script that aren't in the example video. From the video I took with my phone, this is the first thing that looks funny:

    While "Building CCX object src/lib/jsoncpp/src/lib_json/CMakeFiles/jsoncpp_lib_static.dir/json_value.cpp.o", this message comes up:

    In file included from /usr/include/c++/6/map:60:0,
    from /home/pi/ControlBlockService2/src/lib/jsoncpp/include/json/value.h:17
    from /home/pi/ControlBlockService2/src/lib/jsoncpp/src/lib_json/json_value.cpp:0:
    /usr/include/c++/6/bits/stl_tree.h: In member function 'std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Allec>:: {something}

    These error messages continue, but I'm hoping this is enough for someone to point me in the right direction to make my ControlBlock work. Or, if there are other parts of the error message required, tell me what you need.

    BTW, my ControlBlock board says it's "rev. 2.1".

    Thank you in advance.

    Paul


  • Global Moderator

    Try updating your RetroPie-Setup script, then install the driver from the RetroPie packages menu - it's in the drivers section.



  • I ran both of these lines from the quick-installation instructions:

    git clone --recursive https://github.com/petrockblog/ControlBlockService2.git
    wget -O - https://raw.githubusercontent.com/petrockblog/ControlBlockService2/master/install.sh | sudo bash
    

    Doesn't the "wget" line download the newest version?



  • @paulmalko did you try manually enabling the interface for the ControlBlock in the raspi-config?

    In terminal:

    sudo raspi-config
    

    Then, go down to “Interfacing Options”

    Enable SPI, you should see some sort of confirmation screen

    Reboot and cross your fingers. This worked for me, hope it helps.



  • @oddoink This fixed my issue! Thanks


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.