Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Fairchild Channel F



  • Would love it if a Fairchild Channel F emulator could make it's way to RetroPie in a format that's as easy to get working (as with the C64).

    It was the first ROM cartridge based game console, and has some really nice games. I'd love to get Shooting Gallery working to replicate TV Powww! voice controlled games at game events. Sadly MESS installation blew my puny mind, and I couldn't get it working following RetroPie Wiki.

    (Oh and a BBC Emulator from the experimental packages would be the icing on the cake). Hope someone smarter than me can make this happen one day.



  • @OneSwitch i have been using it for a while now on advmess. Please read my post here:

    https://retropie.org.uk/forum/topic/3971/lr-mess-and-gx4000-setup-not-working/4



  • Thanks, but that looks like a not very easy way to get it working, but promising. I'm guessing...

    1. You still have to install adv-mess (takes about 3 hours doesn't it?)
    2. There'll be no libretro benefits, so possibly no way to exit the emulator via a gamepad controller once you've started (I'm trying to avoid the need for a keyboard being connected).
    3. There's still a lot of manual editing of config files to get it working.

    How do these fledgling efforts make their way into the RetroPie optional / experimental packages (such as the Commodore 64/Pet/Vic access)? Just curious.



  • @OneSwitch downloading that zip that has the stuff already in it for channel f except for the roms. It takes about 10 minutes to have channel f up and running. I linked you there because i said how to download the zip file that has advmess already in it with all the channelf stuff (configs and stuff) already in it. The other stuff i explained was because he wanted to use a different system



  • @OneSwitch So here is how to get it working for you.

    1. Go to intellivision.us
    2. On the left side choose ultimate console.
    3. Scroll down and choose the retropie 3.2 zip
    4. Open the zip file.
    5. Copy these parts to your pi and give 0777 permissions to all the files and folders:
      /opt/retropie/configs/channelf/
      /opt/retropie/configs/mame-advmame/
      Opt/retropie/emulators/advmame/
    6. Then in that zip file open up /etc/emulationstation/es_systems.cfg and find the section for channel f and copy that part into your es_systems.cfg file.
    7. Copy your es_systems.cfg into /opt/retropie/configs/all/emulationstation/
    8. Add your roms to /opt/retropie/configs/mame-adv-mame/image/
    9. Give 0777 permissions to all your roms
    10. Reboot emulationstation.
    11. Choose a game then in the game press tab on your keyboard. Choose "input this system" and configure your controller.


  • @edmaul69 Thanks for trying to help more. I can't work out how to get root permission to write (I'm using FileZilla and getting permission denied error messages galore).

    I can see how to change to 777 permission, so that's something. :)



  • Going to try this...

    sudo chown -R pi /opt/retropie/
    sudo chown -R pi /etc/emulationstation/
    sudo chown -R pi /home/pi/
    

    from putty/terminal



  • @OneSwitch log in as root and not pi. If you havent set up a password for root i am going to post instructions. Need to switch to my computer to post them



  • Why can't I SSH as root anymore?

    The root password is disabled by default (as is the case for Raspbian and many other linux distros).

    before setting a root password, the following must be edited

    sudo nano /etc/ssh/sshd_config

    look for

    PermitRootLogin without-password

    change it to

    PermitRootLogin yes

    then ctrl+x to save,

    next set your root password:

    sudo passwd root

    restart your Pi to register your changes



  • or you can do what he said but im not sure if it is recommended to do it his way or not



  • I've been able to copy most things across and change to 777 set-up, but I'm not seeing anything in EmulationStation. I'm a bit confused about step 6 and 7.

    Am I to pick up this code...

    <system>
    <name>channelf</name>
    <fullname>Fairchild Channel F</fullname>
    <path>/opt/retropie/configs/mame-advmame/image/channelf</path>
    <extension>.bin .BIN</extension>
    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 0 SYS channelf %ROM%</command>
    <platform>channelf</platform>
    <theme>channelf</theme>
    </system>

    and just copy it into the same config file on the SD card? I've tried retracing my steps. Is there a Channel F system ROM I need to copy too that I'm missing out (I just have a few game roms in the image folder?



  • Tried dropping the Fairchild Channel F BIOS SL31253 (1976)(Fairchild).bin into the image folder, but made no difference. Sadly, it's not working still. Knew it was fatal when you said 10 minutes. :)

    Thanks again for your help. Would be cool to get this working, but I think I need some clarification on those steps 6-7.



  • @OneSwitch you need to add that to your es_systems.cfg if you have an es_systems.cfg in /opt/retropie/configs/all/emulationstation/ then copy that info and put it there otherwise add it to /etc/emulationstation/es_systems.cfg. Save and then reboot emulationstation. See if it shows up on your system list. Try to play a game.



  • I've got a little further along, thanks.

    An ugly "chan..." section has appeared across a white background. Games are being displayed when I go into the "Fairchild Channel F" section, including the BIOS.

    When I select a game, I get no option to change the emulator from the launch dialogue box, and just the dreaded flashing cursor top left then returning to the selection screen. Nothing starts.

    I'm assuming the Fairchild Channel F BIOS is misnamed, and in the wrong place, but no idea what to do with it. Any more help appreciated.



  • I've copied sl31253.rom, sl31254.rom and sl90025.rom direct to the /opt/retropie/configs/mame-advmame/image/channelf/ directory.

    Made no difference. Tied popping them in the retropie/bios (from //retropie) - and it made no difference either.



  • @OneSwitch you dont need those bios there. They are in the /opt/retropie/configs/mame-advmame/roms folder. Do you have the folder and files in/opt/retropie/configs/channelf/ on there?



  • @edmaul69 read last post. Also did you copy all the files from /opt/retropie/configs/mame-advmame/ ? Also did you give permissions to all those files and folders including the game roms? Also make sure you give 0777 permissions to /opt/retropie/emulators/advmame/ also make sure you copied all the files from the zip into there as well.



  • I followed your advice point by point, but still no luck. Thanks for info on the bios. Can I just clarify with you please...

    1. I don't need to install MESS from the optional/experimental packages area.

    2. I don't need to place Channel F system roms anywhere (beyond the folder copying that you specified), as they'll be in the folders copied from the "ultimate console" download.

    3. This should work with RetroPie 3.8.

    4. It will be possible to start, play and exit the Channel F games using the joypad alone (once set-up).

    Thanks again for trying. When I get time, unless nothing new surfaces, I'll try again.



  • @OneSwitch as long as you copied the folders
    /opt/retropie/configs/channelf/
    /opt/retropie/configs/mame-advmame/ &
    /opt/retropie/emulators/advmame/
    And gave full permissions to all files and folders in
    /opt/retropie/configs/mame-advmame/image/
    /opt/retropie/configs/mame-advmame/roms/ &
    /opt/retropie/emulators/advmame/
    It will work.



  • I'm pretty sure I did, but when I have time I'll try again. Thanks again for trying to help. I'd still love a nice very easy to install version. One day hopefully.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.