Please do not post a support request without first reading and following the advice in

Power and Power Switch

  • I just got around to setting up a ControlBlock v. 1.6 on my Pi2B+. The LED works on the ControlBlock, but the power switch does not.

    When I plug the powersupply into the ControlBlock the Pi LED has a single green flash and then is dark. I can't get the PI to boot when powered from the ControlBlock. Before I disabled the switch in the config file the Pi would shut down immediately after booting up.

    What I have tried:

    Checked all solder joints
    Tried 3 different power supplies all rated at 2 amps/5v.
    This is the second time attempting to get the ControlBlock working, I turned on both SPI and I2C. Is there a different service for the controlblock v1.6? The only one I could find is Control BlockService2.

    Thanks in advance for your help!

  • Global Moderator

    If you disable the power switch functionality in the config you need to attach the power supply not to the ControlBlock, but to the Raspberry Pi itself. The ControlBlock is then powered via the Raspberry.

    What kind of switch are you using? It is important that you have a toggle switch and not a momentary one. "Toggle switch" means that you need to press the buttons one time, then it is turned on. If you press the button a second time it turns off again.

  • I'm not using a momentary switch, I'm using a SPST switch which is closed in one position and open in the other. I did a complete rebuild yesterday where I reinstalled Raspbian and then built Retropie and Controlblock libraries from the command line. Same issue. The LED continues to blink as if booting the entire time. it never goes solid. I'm gong to attach a button today and see if jstest can see the button press. If not I'm at a loss.

  • @petrockblog do I need SPI and I2C enabled for the v1.6 ControlBlock? The instructions on the old site seem contradictory.

  • @numbercrow hooked a button up and used jstest and the pi is not seeing the change in state from the ControlBlock. I'm open to suggestions. Thanks

  • Global Moderator

    For all ControlBlocks with revision number 1.X you need to enable the I2C interface via raspi-config.
    For all ControlBlocks with revision number 2.X you need to enable the SPI interface via raspi-config.

    Thanks for pointing me to the command-line setup instructions. I have corrected the repository URL for the rev. 1.X driver. It is git://!

  • @petrockblog Thanks, I'll give this a try with only I2C and the other controlblockservice.

  • Update: I started from scratch with a fresh install of Raspbian then a command line install of retropie from binaries. I installed the correct ControlBlockService.

    The power switch functionality still does not work (after booting the Pi shuts down with the switch in either position. So I disabled the power switch in the config.

    Running Jstest now the pi is seeing the button pressed from the ControlBlock. So at least basic functioning of reading keypresses works, I would really like to have the ability to shut down the pi using a switch (the reason I bought this) but will settle for doing so using retropie.

  • Global Moderator

    Could you post an image of your hardware setup / wiring here? Maybe I get an idea for the cause then ...

  • Sure, here is a picture:

  • Global Moderator

    Thanks for the image, that helped.
    If you want to use the power switch functionality it is mandatory that you attach the USB connector to the ControlBlock.

  • Tried with the power applied to the ControlBlock and the Pi led has a single green flash upon plugging in but the switch won't turn on the pi. Tried also applying power to both the pi and the ControlBlockk and it shuts down with the switch in either position.

  • Global Moderator

    A single green flash upon plugging inis normal. If the switch does not turn on the Pi, then the wiring with the switch or the switch itself would be the next components to look at.

  • Switch is fine. Checked and double checked. When I get a chance this Summer I'll examine the code and see if I can figure out what is going on with the service and hardware. Any suggestions on where to start?

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.