@dudleydes said in Jetpac on ZX Spectrum: @Yorick According to World of Spectrum, Jetpac runs on a 16k machine. By default, lr-fuse, which I assume is you are using, runs the the 128k machine - you will see the line fuse_machine = "Spectrum 128K" in the file /opt/retropie/configs/all/retroarch-core-options.cfg. If you change to 48k machine type in the RGUI, then Jetpac will run. Now this will be a pain to change between 48k and 128k machine for newer games that require the extra memory. This is my solution. It may be not be optimum but it works. In the folder /opt/retropie/configs/all/, create a text file called retroarch-core-options-fuse48k.cfg and add the following line: fuse_machine = "Spectrum 48K" Now we need to make sure Jetpac uses the 48k machine so in the ZX Spectrum roms folder, create a text file called Jetpac.tzx.cfg. The file name must match the tape so you may have to amend. In this file, add the following line: core_options_path = /opt/retropie/configs/all/retroarch-core-options-fuse48K.cfg Save and Jetpac should now run. If you take a look at retroarch-core-options-fuse48k.cfg after launching Jetpac, you'll notice RetroArch will have added extra lines. It's best to leave these. For any other games that run a 16k machine such as Deathchase, all you need to do is copy the cfg file and rename it so that it matches the tape. Hello Dudleydes, Apologies for digging this post from it's grave, but I'm struggling trying to get your fix to work for loading 48K Roms in LR-Fuse? Is there any chance you could give me some guidance?