Please do not post a support request without first reading and following the advice in

Emulationstation V2.1.8RP from Source Aborting when changing Themes

  • @pjft @jdrassa hey guys, wanted to report this issue with ES v2.1.8RP as downloaded from source. When i enter the Main Menu, go to UI Settings and choose to change themes, i select a theme, go down and hit back to exit to the system select screen and I instantly exit to the command line interface with the following error:

    emulationstation: /home/pi/RetroPie-Setup/tmp/build/emulationstation/es-core/src/components/OptionListComponent. h:239 T OptionListComponent<T> :: getSelected() [wtih T = std :: basic_string <char>]: Assertion 'selected.size() == 1' failed.

    How i got here: I was testing out why my system was stalling while updating from source. I changed my settings to basic carbon and updated emulationstation from source. Update went as expected and installed properly. Carbon was the set theme. I went Main Menu to change themes, received this error. Rebooted and went to main menu, tried to change to pixel. Got this message. Tried to change to flat. Got this message. I am unable to change to any theme. Not sure if anyone else is experiencing this with the Main ES build V2.1.8RP from source? Thanks

    Edit: @pjft - i reinstalled your V2.1.7RP-OMX-MERGED from the script. I am able to change themes correctly without any issue. I am now going to try to reinstall the main branch 2.1.8RP and see if i can replicate the issue.

    Edit: Update #2 - Re-installed v2.1.8RP from source and once again i am unable to change themes. I get the same error as before. Thanks

  • It's related to the fact that your es_settings file has random video as screensaver, but that build does not have that option:)

    If you do want to change themes and such, I'd recommend editing the es_settings.cfg file and changing that to black or dim, which I believe are the values for that option.

    Anything in the 2.1.8 update that you're needing, or was it just curiosity?


  • @pjft I am confused - prior to 2.1.8RP i was able to do this and it just changed my random screensaver to black, now it will not do that any longer? That is fine if it is the issue, no worries, it won't affect me. I thought it was a bug!

    the only reason i was in 2.1.8RP is to test why I am having trouble loading from source. See my response in our other thread.

  • @TMNTturtlguy got it.

    I am unsure as to why you'd have been able to do so previously, as I'm fairly under the impression that that has been the behavior for quite a while.

    You'll even see, when you open that menu, that the screensaver setting will have a star or something. In fact, even if you don't change theme but just open that menu and try to exit without changing screensaver to a known value will crash as well, if I recall correctly from my experiences. :)

  • @pjft your right about the star....but mine always just acted as black screensaver and I never had issues and i never changed it! not sure, but i was switching between versions of my theme builds to test them on main branch and your branch all the time!

  • @TMNTturtlguy it will act as a black screensaver by default, even with the star set. The condition for the screensaver is just "if setting is different to fade, then do black" which is give as there are only two options there :)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.