Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Video Screensaver System Lockup



  • Had to terminate this little expeiment briefly tonight to continue testing the Mausberry shutdown script tonight. Pretty sure that's taken care of (happy!) so now I can devote another night of having the video screensaver running.

    One brief thing I noticed.. The top I had running in the SSH terminal had locked up when I went into to try changing the script. Pressing CTRL+Z did nothing, as did anything else I pressed. I had to close the SSH terminal and open a new session. The system wasn't locked up though. I could access Retropie Manager, and the screensaver was still chugging away with 2 different videos at least while I tried to restart a session. So I don't know if having top running till the Pi locks up will be much help if it locks up itself after only about 2 hours...



  • So, there shouldn't be a problem with missing videos in the tags - I mean, the worst that will happen is that it will default to the Black screensaver if it can't find a random video for 20 times in a row or something. The video screensaver will randomly pick a video tag, check if the video exists, and if it doesn't moves on to the next random one. If 20 times in a row it doesn't find a video, it'll default to the black screensaver.

    What may be causing lockups may be a specific video or so that may have a weird format or encoding. You may to well in re-encoding your videos with Handbrake or so, see if it helps.

    I am not a script guy per se - a simple bash will be able to do it, certainly, though.

    The "OptionListComponent too narrow!" messages relate to the popup menu - start or select - on occasion. Don't quite know what triggers them.

    You may also want to try out the Black screensaver, and see how that goes.



  • OK, the Video Screensaver has been running all night last night and all day while I was at work. The forums here say it was 20 hours ago.. so that's a record for me. It's probably one specific file that's causing the lockup. I just wish I knew which one it was so I could fix it. With no way to test that, I"m out of luck. I'd still like to be able to see a log of what it's doing, so I can see if it DOES in fact run into an issue and let's me fix it. Right now, I'm not getting anywhere with the tools I have. When I came home from work, the Video Screensaver is still running. My SSH connection crashed:
    http://image.ibb.co/hZMD9k/Untitled_1.jpg
    If that clock was right, it crashed around 5:50 this morning. I say "IF" because when I run it now, it says it's 22:35, which would be 10:35pm, but it's only 6:35pm. So I think it's 4 hours fast. Takeaway would make it 1:35am last night. I was asleep then, so I don't know what it could have crashed on. Might it be a session time out? Like after 2 hours of no input it disconnects me?

    The only other bit of help is the es_log from Retropie Manager:
    https://ghostbin.com/paste/af8hw



  • Heading to bed... I've gone in and changed my settings in Putty to send keepalives every 1 second. I've also got top running with 1 second updates. Probably overkill, but it'll help me identify the exact second the terminal is halting. I also adjusted the system time to be in the US/Eastern so now it's the right time. As of now, I'm still running the video screensaver without any issues. Really kinda pissed about that because it's not doing it now and I can't identify something that's causing it to crash! The es_log hasn't updated yet either. One thing I have started to notice though is that every now and then there seems to be a large amperage draw on my power supply. I'm getting an occasional lightning bolt icon on my TV whenever it goes to load up a new video. It doesn't ALWAYS do this, so I'm not sure if it's happening on a specific system, or just randomly.

    Looking at top though, is it normal for ``top` to be taking up 100% cpu?
    http://ibb.co/gwAJaQ



  • Just got home from my early shift. Screensaver is still running. There must be a bad video or path somewhere, and it's just working like it should. I would have liked to have been able to figure out what the problem is, but now it's not doing it. I mean, what if it's crashing when it's trying to find a video for the 20th time and goes to black? I can't test it! But hey, it's working and that's all that matters. I'm not going to keep an eye on logs and top anymore. My bedroom is really hot now from the computer being on for 3 days keeping a constant watchful eye.

    Here are the results of the SSH session. I thought setting up a keep alive would keep it from disconnecting. Must be something else that's causing the disconnect. Maybe it's related to the occasional lightning bolt icon, and the system is crashing but recovering with a reboot. The SSH disconnects, but the screensaver "appears" to be working because after rebooting it starts up again:

    http://image.ibb.co/bCZP0Q/Untitled_1.jpg

    Also, my Retropie Manager, while still connected, shows NO new lines added to the es_log, and those other ones it had before have also stopped showing up. I dunno what's up.

    https://ghostbin.com/paste/u6x4z



  • @hansolo77 Yeah. You're probably better off running all videos through Handbrake, re-encoding, seeing if per chance it ends up fixing any odd one.

    The connection dying on you is quite normal, depending on the software and the keep-alive settings for the connection. I wouldn't read too much into it. Maybe Windows is going into deep sleep mode and that's when the connection drops. The error message seems to suggest that it's PuTTy who's dropping it.

    As for the ES log, this one in particular started at 23:46:24 , so it should help you understand whether that matches the time you booted it up, or if it might have really restarted. Your PuTTy log also suggests that the session had been running for 22h at least, before the connection dropped.

    Might also be helpful, if the date doesn't match what you expected, to check whether the date on your Pi is actually correct, as the Pi does not have an internal clock and reads the date from the internet, and adjusts based on the time zone you have set for your Pi. Easiest way to check is, when you go to the terminal or log in via SSH, to check the time it shows you and see if it matches your current time.



  • I'm spending the day today rebuilding my rom drive. I've got a backup made now so if anything happens I can always restore it. Not sure what's going on.



  • I'm gonna hijack my own thread to report a new problem.

    Because I had to reinstall from scratch my PiStation project, I've noticed a problem with the Video Screensaver now only playing the same video over and over. If I press SELECT to initiate the screensaver, it will choose a random video to start, but then when the video is over it repeats rather than picking another one. If I press SELECT again, it will THEN go on to a different video. Also, I set my screensaver to start after 1 minute, but it never starts.

    I installed and updated from source the core components, which includes ES. I also did an underlying kernel update, so maybe something there is wonky?

    ES v 2.5.1RP



  • @hansolo77 there's a bug with the power savings changes that were recently introduced that's being addressed right now.

    If you go to the start menu there'll be a place (maybe under other options?) where you have power savings. Just disable them.



  • Yeah I noticed those. I just left them at the default settings. I will try to disable them.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.