Please do not post a support request without first reading and following the advice in

"B" turns to "X" on second controller after restart

  • Pi zero loaded with retropie. Config snes controller one works fine, config snes controller two works fine, restart pi and controller one "B" and "X" switch. I've tried redownloding pi zero img file, I've tried 3 different SD cards, I've tried 3 different USB hubs, I've tried 2 different pi zero boards, and finally I've tried 5 different snes controllers. All with the exact same results.

    Plot twist. If I do this with a nes controller "B" turns to "X" and "X" obviously isn't an option.

    I've searched high and low for answers or someone with the same problem.

    Please help me.

  • @notechskill Please don't spam the forum just because you didn't get an immediate answer. You asked essentially the same question around 2 hours ago.
    Forum users are based all over the world from the USA, South America, Europe, Australia to Japan, try and appreciate the time differences.

  • @jonnykesh I bet you're fun at parties. I couldn't figure out how to add extra tags after it was posted and I reworded the issue I'm having to help others understand the problem I'm having. If you don't have anything nice to say don't say anything at all. I'm new to this and I'm trying to get help.

  • @notechskill You can edit posts. If you had taken the time I'm sure you would have figured it out.
    No spamming is a rule in most forums. If you can't follow simple rules like that you won't be welcome very long. And if you take an attitude with people you are unlikely to receive any help. I was in the middle of typing a response to your issue but I deleted it to type this instead.

  • @jonnykesh im going to guess you don't know how to fix it. For future reference, no one likes being attacked for making a mistake the first time they use something. I spent a lot of time trying to figure this out before asking for help. I figured my first experience wouldn't be with the retropie post police but I was wrong. Back to the drawing board.

  • Global Moderator

    @notechskill said in "B" turns to "X" on second controller after restart:

    For future reference, no one likes being attacked for making a mistake the first time they use something.

    No one's attacking you. Spamming isn't allowed and forum posts can be edited. The prior is outlined in the forum rules and both are true just about anywhere. Mistakes happen, but for you to move forward effectively, you need to read the following links.

  • Global Moderator

    @notechskill Can you post your controller exact model ? You seem to be having an issue with persisting the configuration of the 2nd controller - right ?
    The controller configuration is stored in /opt/retropie/configs/all/retroarch-joypads, one file per controller. You can save the controller configurations between reboots and compare them to see what's different.

  • @mitu they are all generic Chinese eBay USB controllers. My pi3 works fine with them so I've eliminated the controllers as the problem. I write the pi zero image to the SD card, put it in the pi zero, it boots up and says config gamepad, with both plugged in I configure the first and then the second (both work correctly) I turn the system off then on, it boots up and the first controller I configured now has "B" as "X". I reconfigure that controller and turn it off and on. Then the previous controller turns "B" into "X". If I use a nes controller the "B" turns into "X" but there is no "X" on nes controller. Thank you so much in advance for any help you can provide. I'm not tech savvy at all so please be very "step by step" descriptive with any solutions you have.

  • Global Moderator

    @notechskill As I said, check the folder and see if you have 2 configuration files, one for each controller. You'll have to use the command line (F4 while in Emulationstation) or ssh to get to a command prompt.
    Make sure your controller(s) work the way you want first. Start the mc file manager (just type mc at the command prompt), then open the folder I mentioned earlier, copy the 2 configuration files to the /home/pi so you have them saved.
    Reboot the system, executing sudo shutdown -r now from the command prompt, then compare the contents of the files in the /opt/retropie/configs/all/retroarch-joypads to the ones you have saved.

  • @notechskill This issue occur on the Emulationstation or after loading a game on Retroarch? If you go to the Retropie Configs Menu, you'll find an option called "Retroarch". Open it and try to configure the inputs directly to it. Don't forget to save before leave the Retroarch. If your problem is on Emulationstation, you could edit the file /home/pi/.emulationstation/es_input.cfg or /etc/emulationstation/es_input.cfg to force ES recognize your inputs. Be sure to make a backup of the original file to revert if things gone crazy.

  • @danielmewhouse just to be clear. On my keyboard hit f4 and go to the command prompt and type in exactly what you have typed out there?

  • @danielmewhouse it happens before there are any games in the ES

  • @notechskill said in "B" turns to "X" on second controller after restart:

    @danielmewhouse just to be clear. On my keyboard hit f4 and go to the command prompt and type in exactly what you have typed out there?

    I know you purposefully selected a username to proclaim your skill level on tasks like this, but I am hopeful this is more of a tongue-in-cheek moniker, as you clearly know enough to image an SD card, swap Pi Zeros, and you figured out how to exit to a command prompt.

    Yet, I think you need to set your expectations appropriately for much of the help you will get here. It is generally expected (and required per the agreement in the forum sign-up) that you have read the documentation, that you explain the source and version of your software setup. I scrolled back through the questions and responses and I cannot tell what you are running. Is it an image you downloaded here?

    Something else to be aware of that isn't obvious when you look at the breadth of emulation coverage in RetroPie and you read about all of the development effort is the fact that the Pi is still an educational platform. The RetroPie image and accompanying script does make a lot of the installation steps much easier than it would be if you had to figure all of it out on your own, but it is by no means as easy as a commercial solution--and it was never meant to be. I make this statement not to intimidate, but to explain that a lot of the answers you get here will require an investment in understanding the environment. For example, when someone suggests you check a file, or edit a configuration in a given folder, it is expected that you will know how to navigate to that folder, either over a network connection from another computer, or through commands at the command line. Rarely will folks give you every last keystroke. You may in fact need to google answers about how to navigate in Linux, how to change directories, copy files etc.

    There are many guides that aim to streamline steps that would otherwise be a barrier to people with no tech skills, but troubleshooting is always going to be unique to your configuration. I say it a lot on the forum to newcomers that almost none of us uses the same hardware. By committing the Pi you are also committing to learning--a process that is supposed to be fun.

    With that said, welcome to the forum! Please, do provide more background about what you are building, how you setup RetroPie and other details requested here. We are genuinely interested in your project and want to help, but most of the time it will be helping you help yourself.

  • @caver01 I do understand what you are conveying. Unfortunately before I started my research, I could hardly figure out how to turn my old laptop on. I found someone selling the pi zero in an nes cartridge on eBay and decided that it would be more fun to learn how to do it myself. With that being said I watched tons of tutorials on what to purchase, the basic setup, etc so I can play some old school games that take me back to a simpler time. Either way I just want to get the two controllers working harmoniously without having to configure the one every time I boot it up. I apologize that I need this one spelled out for me but I can't find anyone with the same problem. "B" turns to "X" on the first controller (after restarted) I configured prior to reboot. If anyone can help an old geezer get through this one issue, I could be playing instead of researching.

  • @notechskill Understood. I like the anecdote, but you are still not providing details about how your software is installed. It is possible nobody has had this problem because none of us are using the configuration you are.

  • @caver01 I'm not sure what you mean by that. I downloaded the retropie image off the official site. Unzipped with 7zip formatted a new 16gb sandisc sd card with sd formatter dropped the image file into win32disc imager. Clicked "write" and then put it into my pi and let it load up.

  • @notechskill Ok, that is a good start. What I mean is that the forum as a READ THIS FIRST link at the top of every page, and on that page linked there are a series of important questions that must be answered. These form the foundation of details that allows helpers to better understand your situation. Otherwise, we end up asking the same questions over and over again. You'd be surprised how many people post questions here and we cannot figure out what is going on, only to learn that they downloaded (or purchased) their SD card image from some obscure (or popular) source, often violating copyrights, but always with an origin that cannot be verified. In such situations it could be literally anything causing problems, from a missing config file to deliberate sabotage and malware. As volunteers, we enjoy helping other enthusiasts, but not at the expense of our own sanity, and definitely not so that law-breaking profiteers can shift onto our good nature their suckered customers' support requests.

    Anyway, there is a list of items you really need to provide so we know how your system is setup. Some of it is coming to light, but it is much more helpful if you simply answer the requested details by editing your first post and adding that information up-front.

    By the way, I have never heard of "B" becomes "X" problems like you are describing. Yet, @mitu above has given you some places to check. Do follow through on those.

  • @caver01 i have heard of this issue. The problem is when the controllers are listed as “generic gamepad” or something like that. I have seen 3 different nes usb controllers from the same manufacterer that had different button inputs.

    To the original poster, if you have 2 of the same controllers, do not configure both controllers. Only configure player 1’s controller then restart emulationstation. However, i think your problem is what i stated above. When you go to configure your controllers in emulationstation what name does each controller list as? If they list a generic name that matches both, it is most likely your issue

  • @edmaul69 I'm off work and back at it. I turned the pi zero on with just one controller plugged in and the "B" became "X" and visaversa. I reconfigured (showed gamepad 1)and it worked fine afterwards. I powered down the pi and turned it back on with another controller that was configured previously and it also did "X" becomes "B" so I go in to reconfigure and IT SAYS GAMEPAD 1 again.

    I think you isolated the problem. Please tell me you know how to fix this.

  • @notechskill you can manually configure each emulator to use different controls for player 1 and 2 but you always have to have the correct controllers for each player. Or get 2 controllers that are truly identical or have different names that they show when you configure them.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.