Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

All of the sudden Problem with SSH...



  • So yeah its been good ever since i got the pie like more than 5 months now and now all of the sudden im getting host does not exist, i use Winscp for rom trasnfering , only way i fix this issue somethimes is unplug and plug back again the router... any idea why this is happening now? Also this issue started right after i migrated to a bigger 128 gb sd card...



  • Can anybody help me with this please? Sorry for the bump



  • @nestor1924 can you get into the routers settings and edit it to use a specific ip address for the pi. Like a high number? A lot if times if you have an IP address of something say 192.168.1.5 if something else is the 5th device connected (technically 4th because the router is always device 1) it can steal that ip address. So setting the pi to use a static IP address between 100-254 can resolve that issue.



  • @edmaul69 sorry for the late response i wrote it just before went to sleep, sorry my lack if knowledge but how do i do that?



  • @nestor1924 Do you know how you change the settings of your router? If not, do you have a manual for it? What brand and model is your router?



  • I was having this problem too (especially as I was having to power it off and on frequently in the early stages of setup).

    Until I realized you can just use "raspberrypi" as the address instead. This didnt work at first but then later started working for me.

    ssh pi@raspberrypi

    That way it just connects to it the same regardless of what rolling IP the router assigns it.

    Or to access files via windows File Explorer

    \\RETROPIE



  • @alturis so even if winsco doesnt work somethimes, if i use \RETROPIE on the windows file network will it work? Im at work at the moment, but as soon as i get there ill try that, and is "ssh pi@raspberrypi" is a command i have to put somewhere?



  • @nestor1924 I am at work as well so I cannot check myself but I think you just use the address "pi@raspberrypi" instead of the IP address.

    And yes \\RETROPIE will work from windows explorer but it limits you to only accessing files in the BIOS, configs, and roms folders.



  • Actually you just use "retropie" instead of the IP address.

    This is how I have my FileZilla server info setup.

    0_1520298000142_1bb3a795-dd00-46b8-8d0f-c6790a917998-image.png



  • @edmaul69 i still need help on how to do this, i maanaged to get into my router setting and dont know what to do next, i do see an option to edit the ip adress of the pi whats next???



  • @nestor1924 look for connected devices while your pi is connected and when you find it you should be able to set a static ip address to it.



  • @nestor1924 It would really help if you told us the brand and model of your router, as each has its own kind of setup.



  • @alturis i use ip address on winscp to connect to it



  • @nestor1924 on the retropie can you go into retropie menu and then show ip and verify that the ip address matches the one on your winscp?



  • You may also try to ping retropie.local
    On some systems the .local domain of zeroconf is not searchable, so you have to use fqdn (so retropie.localinstead of simply retropie).



  • @clyde i have a technicolor model: TC8715D



  • @edmaul69 i can connect to winscp using the ip adress of the pi instead of the username?, everytime i cant connect to winscp it says username does not exist and thats when i have to unplug and plug back the router to get it to work again, when im connected to my wiscp it says pi@RETROPIE



  • @nestor1924 instead of host name as retropie or whatever use the ip address. user name is still pi



  • @nestor1924 Does @Alturis' screenshot match your Winscp window? Instead of "retropie" in the "Host:" field, you would simply enter the IP that Retropie shows you. Beware that the IP might change if you reboot the pi or after losing the connection.

    Alternatively, you could give your Pi a static ip address in your router. This site tells you how to find your router's address and log into its web interface (or "Admin Tool" as Technicolor calls it). You can also download the TC8715D's manual there. On page 64, it tells you how to give a "reserved" (i.e. static) IP address to a connected device, such as your Pi. You should use one of the IPs your Pi had before, as the chances are good that those IPs are not used by other devices. To be sure, look at the list of connected devices in the router's web interface to check their IPs.

    However, static IPs should be the last resort in an otherwise dynamic network. If looking up your Pi's IP in Emulation Station does the job for you, stay with it.



  • @clyde said in All of the sudden Problem with SSH...:

    However, static IPs should be the last resort in an otherwise dynamic network. If looking up your Pi's IP in Emulation Station does the job for you, stay with it.

    Care to explain why? I've never heard anyone else say that. I'm also having some networking issues on my RP setup. But I do use dhcp reservation on my wndr4500 to get static IPs, so your comment has me thinking maybe that is my problem.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.