Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

ZEsarUX-7.0



  • It can do Sam Coupe?

    No virtual keyboard I guess, right?



  • @mediamogul Oh really? I'll have to give it a try myself later; I'm guessing it runs well since it's not exactly demanding hardware.

    I've also tested the Super Cassette Vision on lr-mess (it was in fact the first system I tested) and can confirm it works perfectly fine. A couple others I've tried (to varying levels of success) include:

    • Various plug and play units by Jakks Pacific (which by the way, a lot of these haven't been dumped or emulated yet; not really relevant to the conversation but I figured I'd point it out)
    • FM Towns
    • Arcadia 2001


  • Those posts about the ZX81 got me curious, and I wanted to see if I could use lr-EightyOne on the Pi. I git clone'd this repository and compiled it, and it turns out that it runs really well! The only caveat is that you have to set player 2's controller to "Spectrum Keyboard" in order to use the keyboard, and I'm unsure if sound is properly emulated. (I did hear a couple of buzzes when turning on a game, but otherwise nothing; not sure if this is normal for the 81 or not)

    I'll probably move my lr-81 shenanagains to their own thread, as to not derail this one.

    Edit 6/16/18: Welp, lr-81 is now a part of RetroPie! Just head on over to the experimental section and install it. I'll write some documentation for it on the RetroPie wiki shortly.



  • @pyjamarama said in ZEsarUX-7.0:

    It can do Sam Coupe?

    No virtual keyboard I guess, right?

    ZEsarUX has virtual keyboard for Spectrum, ZX80 and ZX81
    It also emulates Sam Coupe, but this machine is in beta stage



  • @chernandezba Hi. I'd like to see whether ZEsarUX-7.0 works with the Sam Coupe, because there are 2 non-standard disk games (960kb .sad disks) - Lemmings and Prince of Persia - that don't work with simcoupe. I've tried ZEsarUX-7.0 with both games, but neither works.

    Having looked at the runcommand.log, would I need to set the machine type as --machine Sam in the commandline or do you think it probably won't work because these are non-standard disks?



  • @chernandezba In fact, I've just noticed that the Retropie version of the emulator I've installed via the menu remains 5.0 from April 2017, rather than 7.0. Would you have any instructions on how to compile version 7.0 for Retropie? I note that you do provide some binaries but the Retropie version is noted as 3rd party.



  • @spud11 hi. Disk formats are not supported on Sam coupe emulation (yet ;) )
    About compiling on retropie, it’s the same procedure as compiling on raspberry. See the install file.



  • @spud11 To install version 7.0, you would need to edit the ZEsarUX scriptmodule. Try changing line 26 to the following:

    gitPullOrClone "$md_build" https://github.com/chernandezba/zesarux.git
    

    If you do this, then updating the setup script will fail unless you run the following commands before you update:

    cd RetroPie-Setup 
    git reset --hard
    

    (I think this is correct - hopefully somebody will correct me if I'm not.)

    The scriptmodule should add a new entry in the Sam Coupe emulators.cfg file for ZEsarUX that includes the --machine sam flag.



  • @dudleydes Thanks. I'll give it a go in the next day or so.



  • Hi chernandezba

    I really like your work :)

    I read that zesarux also emulates MK14, zxspecnext, QL. Are those available in the retropie version? I've installed via the above (changing line 26 to point to - https://github.com/chernandezba/zesarux.git etc) - but note the .sh only adds spectrum, amstrad, samcoupe.

    I see the machine options in the menu.

    Do you please (please!) have plans to add the other systems to retropie build, or advise how to force emulation direct into each machine?

    TIA

    Iain


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.