Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[Solved] PowerBlock not powering up Pi



  • RPi 3B
    Retro Pi 4.4 image from this site, last updated June8th, 2018
    PowerBlock (version B)
    32GB Sandisk SD Card
    64 GB Sandisk usb drive

    I am having trouble getting a PowerBlock running. I installed the drivers as on the Petrockblog site, and installed the RetroPie driver too. I used an led toggle button with 5 terminals

    Common
    Normally Open
    Normally Closed
    Plus
    Minus
    And wired the PowerBlock leds to plus and minus, and the switch terminals to Common and Normally Open.

    When I try to power up, absolutely nothing happens. Then I plugged the power directly into the Pi, and when I do that it boots up and then shuts down straight off with the led slow blinking, so I know that at least the leds and the software works. Can anyone see what elementary mistake I am making?



  • I found the solution. The switch has a removable harness, which has the connecting wires on it. It also can be turned 180 degrees and attached, which is what I did. Once I realized and rotated it, everything works perfectly.

    This is what is known as an IBCK error - Idiot Between Chair and Keyboard



  • @douga said in [Solved] PowerBlock not powering up Pi:

    This is what is known as an IBCK error - Idiot Between Chair and Keyboard

    At my company we refer to that as a P.E.B.C.A.K. resolution! (Problem Existed Between Chair And Keyboard)

    Great that you solved it though!



  • @douga as @tba mentioned, the scientific term is PEBKAC.


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.