Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroPie is not displayed in the Windows network environment


  • Global Moderator

    @xabib2302 From the screenshot (although I don't understand what language is), it looks like your RetroPie is not reachable from your PC. You either have a firewall between the 2 devices or the Router has AP Isolation enabled and the devices are not able to communicate with each other. Either way, you need to find out what's preventing the communication and fix it outside RetroPie.



  • I don't think it will show up unless the Samba shares are enabled. Once I set up the samba shares, I can usually get to the Pi by IP address. After I connect to it once, it can be accessed by name.

    I have had lots of trouble with this very problem. I've still never been able to get my Pi 3 to work on WiFi. It only works when wired. I have an OrangePi as well and that worked for a while then went haywire on WiFi. Eventually I reset all device addresses on the Router and they started working again.



  • @Xabib2302

    Please ping 192.168.100.5
    alternatively you can ping retropie

    You pinged wrong adress. Come on you were born on the "Day of the Army" ;)


  • Global Moderator

    Yeah, @cyperghost is right, didn't even notice I put the wrong address in the ping command.



  • @mitu It's nice to observe synergy at work. :)



  • @cyperghost The communication check failed to detect the retropie node.
    Check the host name and try again.



  • @mitu AP Isolation disabled


  • Global Moderator

    @xabib2302 If pinging 192.168.100.5 still doesn't work (i.e. you get host not found) then the same comment as before applies - your RetroPie device at 192.168.100.5 is not reachable from your PC, so there's nothing RetroPie can do. Check if you have any firewall/Antivirus(?) installed on your PC and maybe temporarily disable them while repeating the ping test to see if they interfere.



  • @mitu The SmartScreen and firewall disabled and still the result is zero



  • @xabib2302 Can you access the console of Retropie? (i.e. connect a keyboard to your Pi and press F4 in Emulation Station)

    Then, you could check how it looks from Retropie's side with the command

    ifconfig     # NOT ipconfig like in Windows
    

    or you could try to ping your router or Windows from the Pi:

    ping 192.168.100.1    # or whatever your router's IP is
    ping 192.168.100.2    # or whatever your PC's IP is
    

    As a desperate measure, you could even test if your Pi responds to pings by pinging itself:

    ping localhost
    

    Remember, all commands are to be issued on the Pi's own console you land in after pressing F4 in Emulation Station.

    Unfortunately, my knowledge about solving network issues is very limited. The above commands are meant to provide further information an to rule out some unexpected problems on the Pi's side.



  • @Xabib2302 I found if you have Windows 7 or higher, you may have to turn on network discovery if it isn't enabled by default : Windows Network Discovery



  • Not sure your having ssh or samba issues.
    For ssh (you can do a reinstall):

    sudo apt-get -y purge openssh-server
    sudo apt-get -y install openssh-server

    For Samba:

    sudo nano etc/samba/smb.conf
    Just change the workgroup (and should be find in Windows)



  • mine never showed up on a static ip for some reason but worked with dchp(on the windows machine)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.