Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retro Amiga Build with 2 * ControlBlock and SNES controller issue



  • Thanks for this pal:). I’ll have another look tonight to make sure I have all the pins connected; I think I have but I will check. As I am using a power connection to the first board I didn’t connect 11&12 to the second board, is that right? I’ll take a couple of pictures too, can I upload those here?

    Thanks

    Danny


  • Global Moderator

    Yes, you can upload the photos here.



  • Board 1

    0_1541805263867_board_1.jpg

    Board 2

    0_1541805289804_board_2.jpg

    Overview

    0_1541805301741_overview.jpg

    Not sure if these help or not :) Happy to supply more images if it will help. I tried connecting pin 3 too as from your image it looked like it was required, but it made no difference. Interestingly, when I run jstest /dev/input/js2 & jstest /dev/input/js3 while leaving the pad in the same port, I see output. When I move the pad to the other port I don't see output on js2 or js3. Feels like something is wired incorrectly, or perhaps not mapping correctly?

    Thanks

    Danny



  • Did the pictures help? Have you been able to replicate the behaviour by any chance?


  • Global Moderator

    Yes, thanks. I am currently rebuilding that setup to replicate the issue. Will get that done today or tomorrow.



  • Ah that’s great, thanks for your help really appreciated:). Hope it isn’t something stilly I have done!



  • Hi pal, just wondering if you have managed to replicate my issue?


  • Global Moderator

    Hi! Sorry for this delay. I set up a system with a lower ControlBlock (SJ1=1, SJ2=0) configured as arcade type and the upper ControlBlock (SJ1=0, SJ2=0) configured as snes type.

    "Unfortunately" I was not able to reproduce your observation: Everything worked as expected.

    You are connecting a DB9 joystick with the ControlBlock configured as arcade type, it might be that there is the problem: I suggest that you disconnect the DB9 joystick and test only with a jumper wire connected to ground and the individual player input pins. Maybe that gives some new insights.



  • @petrockblog

    Hi

    So I think I have this working now:). Based upon your suggestions I have changed things round a little. I left the controlblocks connected in the same way, but connected the SNES adapter to the first controlblock, and the DB9 joysticks to the second via the same boffintronics adapter. I changed the first block to SNES and the second to ARCADE. Connected everything up and I now see output on all controllers on all ports. I have managed to configure controllers in retroarch via emulationstation and all seems well.

    Still not sure why it’s working now and not before, but it does seem stable. Thanks for your assistance on this one, and if anyone is interested in pictures of the finished project or anything please let me know.

    Thanks

    Danny


  • Global Moderator

    Glad to hear that!


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.