Please do not post a support request without first reading and following the advice in

lr-fbalpha now fast on PiZero & rpi1

  • @lostless said in lr-fbalpha now fast on PiZero & rpi1:

    @barbudreadmon Im using build cb4826a. I guess some games speed up better then others. I tested neo geo and was a tad faster. Games like simpsons arcade I noticed no change. But its still not full speed on a pi zero. But was fun to test out.

    I explained it was only affecting games using the m68k cpu, simpsons is not one of them.
    Could you try using a frameskip of 1 in core options for neogeo ? To see if the bottleneck is the rendering.

  • @lostless said in lr-fbalpha now fast on PiZero & rpi1:

    Im using build cb4826a

    What the fuck with that commit actually ? It doesn't even exist in, seems to me like you are not even using the right emulator...

  • @barbudreadmon lol, that build number is from mame2003...of last year.

  • @Darksavior Thanks for confirming. I guess we are back to step 1 then.

    @lostless congratulations on pissing me off, how is it even possible to not notice you are running the wrong emulator when it is written next to the commit, and i even explained you needed to set cyclone in core options, which you obviously didn't, seriously.... no need to do more tests, you are obviously not trustworthy.

  • @barbudreadmon I’m really trying to help here. Im sorry if there has been any misunderstanding here. I’m no stranger to computers and retropie. I somehow made a simple mistake. How? Beats me. Lol. Anyway, I really want to figure this out. The real build number is cdc6d71. I have enabled the cyclone, restarted the emulator and did notice a difference in neo geo games. Turned on frameskip to 1, and it’s almost full speed. So the cyclone driver is working, just not full speed. And that’s not a complaint, but a report on the status of this emulator on a pi zero. I really do appreciate your efforts.

  • @lostless Might be that the neogeo driver had too many accuracy fixes over the years then, because on my rpi1, neogeo through the old lr-fbalpha repository (now known as lr-fbalpha2012) was close to full speed (~60 fps with some slowdowns iirc). Might be a good idea to backport the cyclone stuff to lr-fbalpha2012 actually.

    What about cps1/cps2 ?

  • @barbudreadmon cps1 and 2 (tested strider, final fight, and cadillacs and dinosaurs) are almost there. There are small moments in which they are running at full speed, but typically are running at around 90-95% speed. Soooooooooo close.

  • @lostless i'll notify fbalpha2012 maintainer about this, perhaps he'll be interested in porting cyclone.

  • Hi everyone.

    I decided to give the Cyclone (in addition to the frameskip: 1) option a try, and I have to say that it does improve performance quite a lot.

    I'm experiencing issues with the load/save state. When I try to load or save the emulator crashes, and I'm back on Emulationstation.
    I tried to delete previous save states, and/or use the autosave option without any success.
    When I try to use the autosave option, it looks like it is only able to save it once.

    I ended up testing different options, and I eventually, I was able to get things running correctly on a previous version of lr-fbalpha.

    To be more specific:

    • It works fine on 1.7.5 - lr-fbalpha v0.2.97.44 - cfbe1e1
    • it breaks on 1.7.6 - lr-fbalpha v0.2.97.44 - bd60621

    I tried everything on a fresh Retropie image to make sure nothing else was interfering with this behavior.

    Any suggestion?

  • Hi @barbudreadmon,

    I'm not sure if you are the best person to ask this question to, but since you started this thread I'm going to give it a try.

    I have been using the Cyclone: enable option and setting frameskip: 1 on FB Neo on Retropie (PiZero), and I surely see a substantial improvement in performance.
    As I wrote in my previous message from last year, when I try to load/save a game, emulationstation crashes and it goes back to the game list.

    Yesterday I saw that there is a new version of Retropie (Version 4.5.1) available, and in the change-log it's mentioned that it now supports Cyclone for improved performance.
    I tried it from a fresh install, but sadly I get the same issues.

    Do you have any suggestions that could help me in debugging and hopefully fixing the issue?

    Thanks for any help you can provide.

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.