Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Rebooting instead of turning off



  • I have the PowerBlock installed and the “driver” installed successfully. As soon as power is connected the PowerBlock the Pi boots nomather if the switch is on or off. And when switch off when the Pi is on it will just reboot. I also tried without switch and used cables to connect disconnect but it’s the same, only to be sure it’s not the switch.

    It’s fresh install of retropie, also tried removing and reinstalling the driver.

    I have used the PowerBlock in another project without issue, and it’s also running the latest stretch version of retropie.

    I double checked all the cables and soldering, everything checks out.

    It’s like it’s sending a reboot command instead of shutdown.
    I’m out of idea, any one else had this issue or know what could be wrong or is the PowerBlock broken?


  • Global Moderator

    Do you maybe have the micro-USB connector attached to the Raspberry Pi or the PowerBlock? It needs to be attached to the PowerBlock. Could you send me a photo of your hardware setup?

    Can you tell me which version of RetroPie and which version of the Raspberry Pi you are using? I could try to reproduce the issue at my site.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.