Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Dialog Boxes contain x's and q"s instead of shading


  • Global Moderator

    @Efriim Sure, but how about raspi-config. If you look at the topic, you see that the problem is that there's no common setting to make this work for both raspi-config and RetroPie-Setup at once.



  • @mitu
    ISO-8859-1 wasn't even installed on mine, so I used the raspi-config update locales and checked all en-us, and now they both work.
    I didnt actually get x and qs though.
    Reading...


  • Global Moderator

    @Efriim said in Dialog Boxes contain x's and q"s instead of shading:

    I didnt actually get x and qs though.

    So, if you didn't experience the problem reported by @papaxris or @xoan ?



  • @mitu
    I was just trying to help. OPs second image upload is what I get when I set it to ISO-8859-1 before I installed ISO-8859-1. The question was almost answered, just needed to install locale ISO-8859-1 or change console to UTF-8. I don't know what give x and q.

    Cool font by the way, I think I'm going to keep it.


  • Global Moderator

    @Efriim The question is - the Raspbian defaults have been working for so long without problems, so what exactly is causing this problem to appear now ?
    I'm interested what causes this - is it RetroPie or Raspbian ? If you have an up-to-date RetroPie setup, but don't experience the problem, then it's most likely a Raspbian thing. Is your Raspbian system also up-to-date ?



  • @mitu
    I couldn't give an x or q about setups, but I do. I didn't have any problem, I was just trying to help.
    When I first installed Retropie, last christmas. I remembered something like this. I know I installed US ISO-8859-1, and I dont think I changed the console but I didn't care that it looked different. I remember updating a package from source and reading some errors about either the codepage missing or I was using the wrong codepage, linux standard is use UTF-8.


  • Global Moderator

    @Efriim said in Dialog Boxes contain x's and q"s instead of shading:

    I couldn't give an x or q about setups, but I do. I didn't have any problem, I was just trying to help.

    I think you're getting this wrong.
    My question if you get the same error was in order to determine what's different in your setup from the other people that reported this (including me). Please re-read my previous update and try to provide an answer if you really want to help - if you're on the last version of RetroPie but you don't get the error, then it means it's something that's changed in Raspbian. That's why I asked if you're up-to-date with your Raspbian installation, because you can update now the OS and see if you can reproduce the error.

    EDIT: can you also post the contents of your /etc/default/console-setup file ?



  • @mitu
    I understand. I haven't upgraded raspbian packages. Will update.

    ACTIVE_CONSOLES="/dev/tty[1-6]"
    CHARMAP="UTF-8"
    CODESET="guess"
    FONTFACE=
    FONTSIZE=
    VIDEOMODE=
    They were blank except for codeset and CHARMAP and active_consoles, I added the fontface you use. videomode was blank.



  • I have one error, I think it was there before the raspbian upgrade but after a 4.4.9.

    Exception OSError: (9, 'Bad file descriptor') in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
    

    The update went smoothly, there was some miscellaneous errors but I can't remember what they were now, they were in the modules.

    The retropie menu looks normal
    The raspi-config menu looks normal


  • Global Moderator

    @Efriim Thanks for the test - I'll try your config file on my installation later on to see if anything changes. Just to make sure, you're opening them from Emulationstation and not via SSH ?



  • Try using the locale update in raspi config again. You can check both UTF-8 and ISO-8859 to install, try using UTF-8.

    Yeah I'm using emulation stations menu. If you use SSH there is probably a way to set the codepage for both the console and the ssh client.


  • Global Moderator

    @Efriim Sadly, the configuration that works for you doesn't seem to work in my case - I still get the same behavior as the one reported in this topic. Mind you, I'm still using the default locale - en_GB.UTF-8.
    I guess I'll have to dig a bit further.



  • @mitu
    I mistyped the command earlier but edited it.
    sudo dpkg-reconfigure console-setup
    and
    sudo dpkg-reconfigure locales
    You should be able to fix it with those, ISO-8859-1 will even work, but you want to at least generate a UTF-8 as well.

    If you're having the x and qs in ssh like me(I dunno how long its been that way), then I think if you switch back to ISO-8859 it will display properly, windows generally uses a ISO, alternatively you can likely change a setting in your ssh client program to use UTF-8 as per other linux defaults.


  • Global Moderator

    @Efriim The fonts through SSH are fine, it's just the console ones that are buggy. I don't have a keyboard on the PI, so it's a bit challenging to fiddle with the terminal settings.
    However, as part of the digging process, I installed a 4.4 image and updated RetroPie only - the error doesn't show up. Next is an OS update and I'll see if anything changes after that.


  • Global Moderator

    An OS update makes the error reported to appear - so it's definitely something OS/Linux related that triggers this. Will have to figure out which package broke what.



  • this error appears to me too, I guess it was after updating the script to 4.4.9.
    But so far everything seems to work normally, this error appears when accessing the retropie setup, so I looked in the forum this seems to be related to the update of the last scrip retropie.
    is there any way to reverse this? or is it just waiting for the next script update?


  • Global Moderator

    @brunozero It's doesn't seem to be a RetroPie problem, but one from Raspbian. Did you read the rest of the topic ?



  • @mitu said in Dialog Boxes contain x's and q"s instead of shading:

    Raspbian

    I'm sorry I'm noob, just a regular user who noticed the error, has this error been with the hardware? is there any solution for him or his cause?


  • Global Moderator

    @brunozero You can use @Efriim's solution to reconfiure your language/locale and choose an ISO-8859-1 locale.


  • Global Moderator

    OK, found the culprit - it's the raspi-config update from Jan 2019 that changes the auto-login service (https://github.com/RPi-Distro/raspi-config/commit/d33487cbeac581d2ce91d8372f5feb1e2b5b7e3a).
    TL;DR version - when configuring the auto-login (via raspi-config), the $TERM variable is replaced with the value from the current running session and added to the auto-login config file, instead of being added literally as $TERM in the auto-login configuration file.

    So, if I ran raspi-config from a SSH session, my $TERM is xterm-256color - this gets added to the auto-login session, but the Linux terminal doesn't have the same capabilities (should be $TERM=linux).
    This does not happen if you run raspi-config from the console, via the keyboard.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.