Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

lr-pcsx-rearmed won't run any games



  • @BJRetro @hhromic
    Yes GT2 works with show bios boot logo disabled.
    I'd like to add that the MGS slowdown is largely fixed by setting the PSX cpu clock to 82.
    Whereas I may have said different, this setting requires a full reset of retroarch to take effect.
    The slowdown in Brave Fencer is likely fixed by PSX CPU clock as well.
    I couldn't say for Chrono Cross, the battle scenes may just improve a little.



  • @Efriim @BJRetro at least for me, Gran Turismo 2 also works with the boot logo option set to ENABLED, however, it takes much longer to boot after the first two disclaimer screens. If you wait patiently the game will eventually start. With the bios logo option DISABLED, it boots much faster.

    Note that this is after the fix, before, it anyway won't boot with show bios set to enabled.



  • I can confirm with even the latest binary of lr-pcsx-rearmed that PSX games aren't booting. Below is my runcommand.log

    Parameters: 
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-pcsx-rearmed/pcsx_rearmed_libretro.so --config /opt/retropie/configs/psx/retroarch.cfg "/home/pi/RetroPie/roms/psx/Klonoa - Door to Phantomile (USA).cue" --verbose --appendconfig /dev/shm/retroarch.cfg
    [INFO] RetroArch 1.7.5 (Git c9c6c5a)
    [INFO] Redirecting save file to "/home/pi/RetroPie/roms/psx/Klonoa - Door to Phantomile (USA).srm".
    [INFO] Redirecting savestate to "/home/pi/RetroPie/roms/psx/Klonoa - Door to Phantomile (USA).state".
    [INFO] === Build =======================================
    Capabilities: NEON VFPv3 VFPv4 
    Built: Oct  9 2018
    [INFO] Version: 1.7.5
    [INFO] Git: c9c6c5a
    [INFO] =================================================
    [ERROR] RetroArch is built for dynamic libretro cores, but libretro_path is not set. Cannot continue.
    [ERROR] Fatal error received in: "init_libretro_sym()"
    

  • Global Moderator

    @obsidianspider Update your RetroPie-Setup script and then re-install from binary.



  • @mitu No dice. I also tried removing and reinstalling from binary instead of just updating. :-/



  • @obsidianspider what version of retropie are you on?



  • @quicksilver 4.4.11 (1446ce5)


  • Global Moderator

    @obsidianspider If you're still on a RetroPie 4.3 (Raspbian Jessie) or older image, you'll have to install from source after updating the script.



  • @mitu I'll give that a shot. I've been holding off on updating to Stretch due to not wanting to reconfigure everything (at least ROMs are on a USB drive). Will report back after the source rebuild.



  • @mitu Rebuilding from source fixed the issue. I have a feeling that when RetroPie 4.5 comes out I'm going to have to do a fresh install, my days of doing the updates and ignoring the "this isn't compatible with Jessie" warnings are numbered. Thanks again all.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.