Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Ubuntu 18.04 Reicast Not launching games



  • I haven't had any other issues with launching games besides with Dreamcast. I've checked that the md5's match up with the bios and they are in the right place in /retropie/bios/dc an put then just in copied them into retropie/bios/ because I read that worked for someone else. I tried to also install retroarch, install reicast, install the bios for that too and was unable to get any dreamcast game to work there too. Here is the coped log from runcommand.log, from some reading for a few hours I read it could by my older older integrated gpu not liking gl but that is only what I read. Thanks for taking your time to check it out!

    Parameters:
    Executing: /opt/retropie/emulators/reicast/bin/reicast.sh oss "/home/arcade/RetroPie/roms/dreamcast/Power Stone (USA)[RDC].cdi"
    X Error of failed request: GLXBadFBConfig
    Major opcode of failed request: 155 (GLX)
    Minor opcode of failed request: 34 ()
    Serial number of failed request: 38
    Current serial number in output stream: 37



  • This thread should have more info about your question as read in the rules. https://retropie.org.uk/forum/topic/3/read-this-first

    I have the same error, I also have Intel Integrated HD 2000. I am doing a reinstall, and ugrade to 18.10, I'll let you know how it goes. I installed 16.04 as OEM and then upgraded to 18.04 x64-x86.



  • I upgraded to 18.10 uninstalled RetroPie created a new user to get out of the oem, reinstalled RetroPie, thinking of what exactly I just ruled out, not much... and what we have in common besides integrated graphics. But tried it anyway, and it didn't work. When I finally realized that this may be because of X display server.

    I haven't figure out how to exit the Xserver as it persists with unity and initrc, I'll try it tomorrow when I feel up to it. I did use the hotkey ctrl+alt+f2 to change terminal and run it from there, unfortunately X is still running in TTY6 so this wouldn't help. The error I got was:

    Invalid MIT-MAGIC-COOKIE-1 keyError: Unable to open X display
    and
    Fatal Error : Renderer initialization failed
    in rend_init_renderer -> /home/$USER/RetroPie-Setup/tmp/build/reicast/shell/linux/../../core/hw/pvr/Renderer_if.cpp :362
    (core dumped)


  • administrators

    @Efriim It requires X. The issue may be due to something unsupported in gfx drivers (assuming you have acceleration and opengl working properly). I will test on my system when I get a chance.



  • Indeed. No more cookies for Rei, he will get a belly ache.

    then it is making an unsupported FBConfig window resolution in

    X Error of failed request: GLXBadFBConfig

    Since the ubuntu runcommand does not have a setting for resolution or framebuffer.

    I think still if I used "reicast.sh" that is installed alongside "reicast" bin. It will open an X on it's own terms, but I still need to Suspend Unity and close the Ubuntu X server first.

    Also the lr-reicast, lr-redream emulators close out in much the same way, which had me thinking it was something else for a while.

    The Saturn emulator; lr-kronos, has a separate issue, the colors are off and I think the Videos are non-displayed, not completely. The colors appear to be limited displaying similar effects if you were to use 256colors, but not as limited.



  • I apologize for not having all the info posted. I'll get on and collect it all a little later tonight. Never had an issue on 16.04, just when I went to try out 18..04



  • @wdcook3
    no issue on 16.04 thats good info.
    I originally installed 16.04 thinking that it was the prime intended installation version.
    Then I read that it is no longer supported by retropie, I upgraded to 18.04 then to 18.10.
    I honestly couldn't remember if I played Reicast on 16.04 but I thought I did.



  • Here is the pastebin for an updated verbose log this time trying lr-reicast instead of just reicast https://pastebin.com/embed_js/teXe8kY6

    I'm using at an old AMD Athlon II x2 220 duel core pc is a E-Machines el1352g-41w using onboard graphics

    I'd love to post whatever else info is needed I'm just not sure what other config files I should post over or how to check what versions of retropie I'm on. Thanks for the help!


  • Global Moderator

    You video driver doesn't support the OpenGL version needed by Reicast - the error is

    [INFO] Shader log: 0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES
    
    

    I see from the log that you're using the nouveau Nvidia video driver - try installing the Nvidia proprietary drivers to get better video acceleration support.



  • What's the best way of updating that driver if you don't mind me asking? When I searched online it said to use the ones listed under the Proprietary driver list but there has never been any updates there.


  • Global Moderator

    @wdcook3 When you open the Software and Updates application, do you have the option to install the Nvidia proprietary drivers ?



  • I do not, it just says "No additional drivers available"


  • Global Moderator

    @wdcook3 said in Ubuntu 18.04 Reicast Not launching games:

    I do not, it just says "No additional drivers available"

    It seems the video card on your system is no longer supported, so there are no Nvidia proprietary drivers available:

    I don't know if an upgrade to 18.10 would improve the nouveau driver to make it support OpenGL 3.x (which Reicast tries to use), but maybe Reicast can be built without OpenGL 3 support.


  • Global Moderator

    Found something similar to your problem - https://github.com/libretro/reicast-emulator/issues/203. You can re-compile Reicast and force GL2 to be used, as instructed in the issue .

    EDIT: the issue for the Libretro core, I wonder if the instructions are also working for the standalone Reicast.



  • I didn't notice on that thread how he was able to go about falling back to G2. Do I have to find the make file in HOME/retropiesetup and change HAVE_GL3 ? Thanks again for your time!


  • Global Moderator

    You'll have to modify the $HOME/RetroPie-Setup/scriptmodules/libretrocores/lr-reicast.sh and add HAVE_GL2=1 at this line. After that, reinstall the lr-reicast core and try to see if works.
    Don't forge to run

    cd $HOME/RetroPie-Setup
    git reset --hard
    

    after you do the modifications and re-compile, otherwise your setup script will not be able to update.



  • So I'm running into the same problem. The modified lr-reicast.sh did nothing but playing around with OpenGL in the terminal had some results and by some, I got Bangai-O working.. Some naomi games as well. It seems like 3D games aren't loading.

    h@h-NUC8i7BEH:~$ glxinfo | grep OpenGL
    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) HD Graphics (Coffeelake 3x8 GT3) 
    OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.1.0-devel (git-9c46046 2019-04-07 bionic-oibaf-ppa)
    OpenGL core profile shading language version string: 4.50
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 19.1.0-devel (git-9c46046 2019-04-07 bionic-oibaf-ppa)
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.2 Mesa 19.1.0-devel (git-9c46046 2019-04-07 bionic-oibaf-ppa)
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
    OpenGL ES profile extensions:
    h@h-NUC8i7BEH:~$ MESA_GLSL_VERSION_OVERRIDE=110 glxinfo | grep OpenGL
    
    

    It seems to favor GLSL version string 110 from what I tried.
    This got Bangai-O working.

    I'm running from an Intel NUC 8i7BEH.



  • Tried the edit too and did not get it to launch either. Luckily I still have no problems in my 16.04 build using reicast on another computer but this is actually a slightly nicer computer so didn't think it would be much of an issue. I have the same issue with redream too, was hoping the GL issue didn't effect that one.



  • So after doing some research about the pc it looks like it has an integrated NVIDIA GeForce 6150 SE which only support up to OpenGL 1.5. I read on Redreams website has a minimum requirment of 3.1. Does it look like I'm pretty out of luck without picking up a cheap gpu for it?



  • I got it back running. It seems "DRI 3" was the culprit.
    "DRI 2" got it running but now pcsx2-unstable fps dropped to unplayable in full screen mode..
    So playing around with the 20-intel.conf for the thousandth time I decided to look at reicast libretro's source file and boom.
    There it was. Set "HAVE_GL3" to 1 and compile.
    Delete your 20-Intel.conf if you have one and reboot.

    I'm running on a NUC8i7BEH ( Intel Iris Plus Graphics 655 integrated)


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.