Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

DosBox and problems with keymapper save conf



  • Hi everyone,

    I am having troubles in mapping a wireless PS4 DS controller with DosBox through Retropie.

    I start the desktop view from my Pi3 B+ in order to start DosBox, then I press Ctrl+F1 to show the keyboard, the mapper can seen my Wireless Controller correctly. I follow these steps:

    • push the arrow buttons (eg. to configure the movements through the left analogic)

    1.JPG

    • then I press "add button" via mouse

    2.JPG

    • move the analogic controller (and the movement is correctly registered)

    3.JPG

    • the I press "save button"

    I expect to see the confirm (as showed in different videos tutorial via Youtube) but nothing happens and the key configuration is, obviously, not saved.

    Please note than every other key on the keyboard (except for ADD-DEL-NEXT in this stage) is correctly pushable via mouse, the only exception is the Save button.

    Anyone can give me some helps?

    Thanks a lot in advance

    Mic



  • Update:

    I tried to access from VNC Server even through a mobile (I was afraid it was a mouse problem) but the problem seems to be the same with the smartphone touchscreen press. I cannot press Save key.

    I have a suspect I am missing some step.



  • After i read your thread yesterday i tried it myself, the idea of mapping keys to Joystick did sound great.

    Using 4.4.12. without any modifications and an 8BitDO30SFPro it worked, i did not have the Problems you had :/

    I did like you described an my mappings were saved at /opt/retropie/configs/pc/

    There are still some issues like the dead-point of the analog sticks in some games, but it works so far.

    I cant imagine what your Problem is, maybe write/save-permissions?



  • @rawmessiah not sure if your problem is a permissions issue or not, but on another note if you go into the dosbox config file you can change the controller to a 2 joystick (4 axis) controller. Now you now have 4 buttons you can use. In the configuration you posted, set player 2’s button 1 and button 2 with 2 buttons on your controller and now you have a 4 button controller all set up.



  • @sirhenrythe5th @edmaul69

    I don't think is a permission issue, I can access regularly at the keymapper and it let me map any key without a single problem. Moreover, in the BIND section, the mapper find regularly the Wireless Controller, so I assume it's not a problem of permission nor the number of axis of the Dualshock controller.

    The problem is connected only to the "save" button (for what I can see now) which is regularly showed on the keymap but I can't push it, and it won't let me save the configuration I chose.

    I could try to connect the pad directly via USB cable but honestly I don't have (and don't want) to use a 5mt. cable because with lr-mame2010 and PSX emulation, the pad works fine.

    Thanks for any advice or solution you can give about!

    Mic

    I haven't tried



  • My Intention was a write-protect status on /opt/retropie/configs/pc for whatever reason.
    Did you have a look in this folder if there a mapping-config file has appeared?

    I tried it with both possible connections, first with USB-Cable, afterwards with BT-connection of the pad.
    Worked like a charm, and i really did excactly what you did in the screenshots and description above :/



  • @sirhenrythe5th

    I will give a look later and I will let u know what I find inside. However I can already find the mapping file created on ~/.dosbox which is probably a hidden folder. I don't know (but I suppose) if the two mapping files are connected if not the same file.

    I will let you know later.

    Thanks!

    Mic



  • No way, unfortunately.

    I found "mapper-SVN-map" on:

    /opt/retropie/configs/pc
    ~/.dosbox

    The two files are symlinked, so technically the file is the same.

    This is the output:

    hand_shutdown "key 290 mod1"
    hand_capmouse "key 291 mod1"
    hand_fullscr "key 13 mod2"
    hand_pause "key 19 mod2"
    hand_mapper "key 282 mod1"
    hand_speedlock "key 293 mod2"
    hand_recwave "key 287 mod1"
    hand_caprawmidi "key 289 mod1 mod2"
    hand_scrshot "key 286 mod1"
    hand_video "key 286 mod1 mod2"
    hand_decfskip "key 288 mod1"
    hand_incfskip "key 289 mod1"
    hand_cycledown "key 292 mod1"
    hand_cycleup "key 293 mod1"
    hand_caprawopl "key 288 mod1 mod2"
    hand_swapimg "key 285 mod1"
    key_esc "stick_0 button 3" "key 27"
    key_f1 "key 282"
    key_f2 "key 283"
    key_f3 "key 284"
    key_f4 "key 285"
    key_f5 "key 286"
    key_f6 "key 287"
    key_f7 "stick_0 button 12" "key 288"
    key_f8 "key 289"
    key_f9 "key 290"
    key_f10 "stick_0 button 0" "key 291"
    key_f11 "key 292"
    key_f12 "key 293"
    key_grave "key 96"
    key_1 "stick_0 button 4" "key 49"
    key_2 "stick_0 button 5" "key 50"
    key_3 "stick_0 button 6" "key 51"
    key_4 "stick_0 button 7" "key 52"
    key_5 "key 53"
    key_6 "key 54"
    key_7 "key 55"
    key_8 "key 56"
    key_9 "key 57"
    key_0 "key 48"
    key_minus "key 45"
    key_equals "key 61"
    key_bspace "key 8"
    key_tab "key 9"
    key_q "key 113"
    key_w "key 119"
    key_e "key 101"
    key_r "key 114"
    key_t "key 116"
    key_y "stick_0 button 14" "key 121"
    key_u "key 117"
    key_i "key 105"
    key_o "key 111"
    key_p "key 112"
    key_lbracket "key 91"
    key_rbracket "key 93"
    key_enter "key 13"
    key_capslock "key 301"
    key_a "key 97"
    key_s "key 115"
    key_d "key 100"
    key_f "key 102"
    key_g "key 103"
    key_h "key 104"
    key_j "key 106"
    key_k "key 107"

    And, for example, it doesn't work launching Prince of Persia.

    So I tried to delete the file and change with the one I found on the bottom of this page, a customized one for PS3 (I suppose it should work the same on PS4 DS):

    http://dosonthepi.blogspot.com/2015/01/configure-game-controllers-in-dosbox_29.html

    Unfortunately nothing seems to have changed. Prince of Persia regularly stars but the joypad doesnt' work.

    This problem is making my quite disappointed because the joypad seems to work really fine with the other emulators.



  • Update:

    I figured out how to save the configuration. Easily, it was necessary to first delete the configurated key, then add a new key in order to be able to save correctly the new configuration. Here's the step I was missing!

    The keys remain correctly saved but here's another point: despite the configuration setted, on Prince of Persia, the dear Prince won't move anywhere. It works just on his left and crouch pushing the left arrow. I setted the right bump (right 3) to pause the game, it let me freeze the game and I have to reboot the Pi.

    I tried, as suggested by @edmaul69 , to change the joystick type, but making this kind of modification on dosbox-SVN.conf, DOSBOX crashed after launch.

    Any supplementary hints that can helps?

    Thanks a lot for your support guys.

    Mic



  • @rawmessiah there is no reason for a crash by making the dosbox conf change. Not sure why it crashed for you. Im going to setup prince of persia and have a go at it.



  • @rawmessiah with my wiimote i have issue of being stuck in crouch. Pressing up stands up and jumps. Same if i set the controls to the dpad or analog joystick. Investigating further.



  • @rawmessiah ok there is something seriously wrong with this game in dosbox. I created a .map file just for this game. Couldnt map anything in prince of persia. So in another game i mapped the keyboard keys to the joystick for my prince of persia .map file and in my prince of persia .conf file i set the joystick to none. Boot up prince of persia and keyboard keys i set as shutdown and mod 3 (hotkey to exit) work, but none of the keyboard keys like the arrow keys mapped to my joystick work. They work on the keyboard but not the joystick. So you might be stuck with playing with a keyboard only on this game.



  • @rawmessiah i figured out how to make the mapper work in prince of persia. In your .conf file under [joystick] you need to change

    timed=true 
    

    To:

    timed=false


  • @edmaul69, I will give it a try tonite, I will let you know.

    In the meanwhile, seriously thanks for all the support!



  • @rawmessiah no problem.



  • @rawmessiah if you already have the mapping of your joystick done your controller should already work.



  • @edmaul69 Prince of Persia still doesn't work, I'm getting mad!

    So I tried with Tennis Elbow and... great, it works really fine and all the keys are perfectly responsive! Maybe a problem of that specific rom of PoP, who knows. I will try another version to check if it works fine.

    Really thanks for the support!

    A question: are you using a specifi .conf and .map for every game on DOSBOX? Just in case, where do you put the customized files for the single game?

    Thanks again!

    Mic



  • @rawmessiah you can copy the dosbox-SVN.conf directly to your /roms/pc/ folder and just modify and rename it for your game. Then duplicate, rename and modify for all your other dos games. That way you have a specific set of settings that you can configure on a per game basis.



  • @rawmessiah all of my games boot off of a .conf file. For example pop has a conf file in the rom folder called “Prince of Persia.conf”. At the bottom under [autoexec] you list the commands to boot the prince of persia game. If it needs a .map i change the option in the conf file from mapperfile=mapper-SVN.map to mapperfile=princeofpersia.map. And when you set up the mapping for pop when you save it will create a new map in the roms folder called princeofpersia.map. I will post my conf info a second.



  • @rawmessiah https://pastebin.com/HnKtWNb3 notice that my games are in ~/roms/pc/games/ to keep them separated from the .conf files i am using as my gamelist.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.