Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[Solved]Xbox One controller(bluetooth) not working in games.



  • @mitu How do I disable this? I might have accidentally clicked something when I was messing around in the retroarch settings earlier.


  • Global Moderator

    @DavidB21 Reset - again - the retroarch.cfg files

    • the one in /opt/retropie/configs/all
    • the NES config one /opt/retropie/configs/nes

    Remove the retroarch.cfg files and then reinstall retroarch and lr-fceumm from the RetroPie-Setup script.
    Why do you keep enabling Save config on exit ?



  • @mitu I am not enabling it anywhere. And I'm sorry I am kind of a noob at this but could you give a step by step instruction on how to reinstall retroarch and lr-fceumm, so that I know that I am doing it right.


  • Global Moderator

    @DavidB21 Any package can be installed from the RetroPie-Setup script - see the Docs.
    Is there a reason you've installed on-top of Raspbian instead of using the RetroPie provided image ?



  • @DavidB21
    It looks really normal, are there other instances the controller does work? It was good for one time? If you delete both the retroarch configs (retroarch.cfg, FCEUmm.cfg) the options will be re-enumerated the next time you run.

    To install the packages start 'RetroPie Setup' from emulationstation, follow
    manage packages >> core packages >> retroarch >> update binary
    manage packages >> main packages >> lr-fceumm >> update binary
    manage packages >> main packages >> lr-nestopia >> update binary
    manage packages >> main packages >> lr-quicknes >> update binary



  • @mitu I just didn't want to reset the SD card. I wanted to keep the progress of other things that I had done.


  • Global Moderator

    @DavidB21 Then follow the instructions posted and it should be fine.



  • @DavidB21
    It will be fine, there wasn't many settings to lose in the Retroarch config most of them were default and some options are saved in retroarch-core-options and you can keep your image and progress.

    It's hard to understand exactly what is happening with the Xbox one controller, but we can troubleshoot it some more.
    Try
    jstest /dev/input/js0 or js1 (ctrl+c) to exit.
    Try deleting the bluetooth connection and then resyncing.
    Configure Input; in the emulationstation start-menu.
    And then try some different emulators.

    You don't have to be specific but just let me know if jstest or different emulators work.



  • I uninstalled and reinstalled retropie. And now it works.



  • @DavidB21 oh okay that's good. I'm glad you found something that would work.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.