Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Favorites in KIOSK mode are not working



  • Hello everyone,
    I'm new to the forum, but have already worked for a while with the retropie but now i stumbled upon a problem, i can't seem to solve by myself. So right to the case, the favorites in the emulationstation GUI is working as it should as long as I'm in the FULL UI mode. But as soon as I switch to KIOSK mode it doesn't work anymore. (Normally in FULL UI it shows up on the top as soon as I hit Y, that the game was added. but in KIOSK this does not appear and the game is not in the favorites list after)
    In the documentation is written, that it should work in KIOSK but not in KID, so I'M wondering if I'm doing something wrong, is the wiki outdated or is this an actual issue (for anyone else or just me)?
    I'm using the Retrorama theme (of course, I mean seriously how beautiful is that) but the problem persists also in the vanilla Carbon theme.

    I managed to clean up my whole gamelists for every console, also the multidisk games, by hiding the additional disks, so the game count would be accurate. The only way to make it look like that and always hide the hidden items per default after reboot is KIOSK mode so i have to use it if I want my clean gamelists and accurate counts. But now I'm having this issue and it's kind of a dealbreaker for the KIOSK UI, because i think the favorites are a important feature too.

    So maybe someone can help me how to make the favorites work in KIOSK (as they should anyhow?).
    An alternative would be to make the hidden items also persistant after reboot in FULL UI / OR is there another smart way on how to deal with multidisk games?

    Any suggestion would be much appreciated. Also it would be just interesting for me if the favorites are working for you in KIOSK mode.

    The system is build on the 3b+ with the latest retropie-image and installed updates 3 weeks ago, Version 4.4.12 . Emulationstation V2.8.3RP.



  • @bebeidon I am also having exactly this issue. Looking forward to a resolution. Using RPie 4.4.14., ES 2.8.3RP on a B+ as well.

    There’s got to be a config somewhere that enables or disables features for these different modes.



  • @t3l01v well at least now we know we're not alone^^ so maybe someone will come up and help us out :)
    Just a tweak for the FULL UI to make the filters persistant after reboot would also be a big help in my case, then i could drop KIOSK mode because as I said I mainly use it to keep the gamelists clean.


  • Global Moderator

    Looks like a bug introduced along the way. Should be fixable.



  • @mitu that's good to hear i just wonder how :) just let us know if you find something out please.



  • I’m fairly sure that by design Favorites (adding and removing) should not work in Kiosk mode. That mode is meant to be locked up pretty tight, no changes. Same reason why you shouldn’t be able to edit metadata in that mode, if I recall correctly.

    I don’t recall if it should work in Kid mode but I suspect it shouldn’t either - if it does, it was either added afterwards or it is a design bug.

    Unless I misunderstood what the issue is, apologies.

    EDIT: it seems 7 months ago a commit made it so that this should work in Kiosk mode, but still not in Kid mode.

    https://github.com/RetroPie/EmulationStation/commit/c98a5d6220ec79bf0e0f5695d4a28b489cfb4952

    EDIT 2: we need to change this line here to reflect the same change from 7 months ago.

    https://github.com/RetroPie/EmulationStation/blob/master/es-app/src/views/gamelist/ISimpleGameListView.cpp#L149

    @mitu on my tablet at the moment, apologies.


  • Global Moderator

    @pjft said in Favorites in KIOSK mode are not working:

    @mitu on my tablet at the moment, apologies.

    I already discovered that :) - that's why I said it's a bug. Initially favorites worked in Kiosk, but in a subsequent commit it was taken away.



  • @pjft yeah it's just that the documentation states fairly clear it should work in KIOSK mode so I don't get why you expect it to not to? So I understand you and @mitu found the "bug" I would be just interested how to proceed now. Can one fix that with editing configs or is that behaviour hardcoded, so we have to wait for next release to be implemented?



  • @bebeidon I expect it not to because I'm the one who originally implemented it and I recall how it was designed and what for :) What the documentation states doesn't matter much as I didn't document it. As far as I was concerned it would be a problem with the documentation.

    Though, as I said, the behavior was changed at a later stage and it should indeed work. It requires a small change in the code, which I pointed out. A change in configurations won't suffice.

    Best.



  • @pjft oh ok that makes sense :) So should this be brought to attention on github then or will you look into it or how is the correct way of proceeding? I'm really not that experienced on how development works in an open source project like this and I'm sorry if I'm testing your patience :)



  • @bebeidon no, this is fine, no worries :) You’re not testing my patience at all - I just don’t have the time exactly right now to take a stab at it, but the procedure is fairly simple, and in the places I described.

    I’ll see if I can take it on sometime soon-ish.

    Thanks!



  • @pjft That's neat! Thanks in advance and please let me know as soon as it's implemented, if that's not too much to ask :)



  • @bebeidon should be done now - at least in the emulationstation-dev branch. You probably need to install it from source in RetroPie-Setup's experimental packages, I believe.



  • @pjft Yes it works! I just hope that experimental branch is otherwise stable^^ Many many thanks! You Sir, are awesome.



  • Good to hear it works. Should be stable for the most part, meaning, it's a bit more "leading edge", but there aren't that many developments these days that it would cause it to be intrinsically unstable. Probably just less tested, but on the flipside, if you run into something that's wrong in the experimental branch, but that works on the stable one, it's easier - and faster - to fix, hopefully :)



  • @pjft Just a heads-up for everyone trying this:
    On the first device it worked like a charm no problems.
    On the second device I got errors while installing from source and it aborted. The error messages and log did not tell me clearly what's wrong (at least I didn't understand it) but then I figured it out.
    You should have at least(!) 1GB free space on the sd-card or you will run into the same erros. After deleting some roms, it also worked on that device. I just underestimated the size that's needed for installation.



  • @pjft Weird problem just fyi: After installing the emulationstation-dev branch I can't configure my Gamepads right Joysticks direction "Left". All other directions and buttons are working. I think the right joystick is not really used for anything but I thought I let you know.
    Even pasting an old controller config, where everything was working and the direction was correctly mapped will unfortunately not fix it.

    This only happens with my 8Bitdo Controllers. With my old Saitek controller I can configure his Joysticks without a problem.

    When the system just booted up, I can "press" left once with the right analog stick and it works! (8Bitdo) but only one time?! Isn't that weird? Then it stopps working again and like I said it's not responding in the Configure Input GUI as well. But this tells my the controllers are definetly not broken (There are 2 8Bitdo controller anyway it would be really weird if both were broken haha)

    Sorry I really thought we had everything sorted out now^^



  • @psyke83 does something like this ring a bell?

    @bebeidon but I take it that everything in the games and whatnot work fine, and it's just within ES? Or has installing ES-dev affected the emulator configs somehow (which shouldn't have happened at all)?

    Worst case scenario:

    1. reinstall normal ES
    2. reconfigure controls
    3. install es-dev
    4. don't touch the controls configuration :)


  • @pjft It seemed the controller Hotkey was not working anymore, that was the reason for re-configure the gamepad in the first place and then I stumbled over this. I will try to fix it with the advice you gave and let you know if it's working.
    I'm using the controllers in Dinput mode but I would really like to leave it like that. Only in this mode all the buttons and extra-buttons seem to work correctly and I also like the vibration confirmation as soon as it's paired. In my experience this is not the case with the other modes.


  • Global Moderator

    @bebeidon,

    Can you post your (correct) controller configuration mapping somewhere so I can take a look?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.