Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Hard Drive Dock Not Accessible



  • Hello, I recently picked up a hard drive dock for use with Retropie, and Kodi. I have two storage drives, a 3tb and a 5tb, both of which are picked up and read just fine when connected using their separate enclosures, power supplies and USB connections.

    However, when taken out of their cases and inserted into the dock, as soon as the 5tb drive is added, the Pi refuses to recognise either drive. I’ve tried the same setup on a Win10 machine, and all drives are present and accessible.

    I can only guess there’s some kind of conflict between the dock, and the Pi 3B+. Could this be a capacity limit, either hardware or file structure? Again, all drives should be visible through the dock by just one cable, but I can’t figure out how to get everything to work. Might an upgrade to a Pi4 help, at all?

    Hope somebody can help, and thanks in advance!



  • @pen2paper Welcome to this forum.

    For further diagnosis you could check if there are any system messages. Either enter dmesg or cat /var/log/syslog after the problem occured (both will give different outputs, so you should check them both). Instead of using cat, you can follow the syslog in real time with tail -f /var/log/syslog and then doing whatever you want to check if there are new messages produced by it. Pressing ctrl+c will stop following the syslog.

    edit: I case you don't know where to enter the commands, press F4 in Emulation Station to get to Retropie's command console. You can return to ES by entering exit.



  • @Clyde Thank you! I now believe this may actually be a down to the USB device limit on the PiB+, so am currently in the process of upgrading to a Pi4. Fingers crossed, that should resolve the issue, but if there any any interesting developments, I shall be sure to post back. Many thanks again for your time.



  • Care to elaborate on that limit? USB can address up to 127 devices, and the official RPi documentation on USB only vaguely mentions general limits that should be circumventable by a powered usb hub. If your dock has its own power supply (which dock hasn't?), power consumption shouldn't be an issue here.



  • @Clyde Somebody kindly suggested that the 3B+ had a limit of 6 USB devices connected at any one time, and that the Pi4 was capable of supporting a great deal more..?

    Yes, the dock has its own power supply, and seems to read any combination of drives on Win10 PC just fine, but not when using Retropie. That appears to be the only circumstance in which a red warning light appears on the dock itself. However, take out the 5tb, and the 3tb is read without issue.



  • In lack of explicit reasons for that advice, I suspect those 6 devices were power related. However, the effect you described seems strange. What does the manual of the doc say about the warning light?

    Alas, I'm (very, very) far from being an expert in these things. So, if you want to dive deeper into this rather than just wait for the Pi 4 and hope that this will fix your problem, I can only recommend further research and give you some links to start from:

    TL;DR: A powered USB hub may help if a device has problems although it should be within the limits, especially HDDs.



  • @Clyde It is very strange. This is the second dock, too, as I was advised by the stockist to return the original, as it was possibly defective. More or less, the same problem transpiring with the new unit, though. Rated for use with Mac, PC, and Linux.

    It always seems to be the addition of the 5tb that creates an issue. I wondered if the drive labels or signatures could be causing a conflict, but this doesn’t seem to be the case, as the dock, with all drives inserted, works as I believe it should, on a Win10 machine.

    Instruction manual is not at all clear, and manufacturers haven’t responded to a support request. Basically, the dock has four slots for either a 3.5 or 2.5 sata. Each slot has a 6tb capacity. To the side of the unit are five indicator lights. One is power/standby, and the other four are indicators for each slot. A blue status light seems to indicate power to the drive/good connection. Each corresponding light will flicker red whenever the drive is being read/written, though is permanently illuminated with the addition of the 5tb, and neither drive is recognised in file manager. There is a physical ‘clone mode’ toggle on the reverse which is set to PC mode, in mind for purely reading data, as opposed to backing up.

    I wonder if the dock also requires a USB 3.0 socket for maximum efficiency. Another potential ray of hope for the Pi4. Just waiting on a memory card. Also, thank you again for your time on this, much appreciated!



  • Thanks for the details and good luck with the Pi 4. 👍



  • @Clyde No joy with the Pi4, sadly. Tried using LibreElec, but same issue persists. Gah.



  • Did you try the dock with other computers and/or operating systems?



  • @Clyde Yes, Win10 machine seems to work with all drives connected...


  • Banned

    This post is deleted!


  • No, i meant other machines than your Win 10 machine and the Pis, preferably a very different one (e.g. a PC with Win 7 or Linux, a Mac etc.)



  • @Clyde No, I’m afraid that’s all I have.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.