Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

After the last update of Retropie for RP4 - Could not successfully build lr-flycast



  • Just to report the error when trying to compile from source :

    g++  -I./core/libretro -I./core/ -I./core/deps -I./core/deps/picotcp/include -I./core/deps/picotcp/modules -I./core/libretro-common/include -I./core/deps/vixl -I./core/deps/flac/include -O2 -march=armv8-a+crc -mtune=cortex-a72 -mfpu=neon-fp-armv8 -mfloat-abi=hard -ftree-vectorize -funsafe-math-optimizations -pipe -marm -mfloat-abi=hard -mcpu=cortex-a72 -mtune=cortex-a72 -mfpu=neon-vfpv4 -DNO_ASM -DARM_ASM -frename-registers -ftree-vectorize -mvectorize-with-neon-quad -DARM_HARDFP -DHOST_CPU=0x20000002 -fopenmp -D__LIBRETRO__  -DHAVE_GLSYM_PRIVATE -DNO_VERIFY -DRPI4_SET_UNIFORM_ATTRIBUTES_BUG -fno-builtin-sqrtf -DTHREADED_RENDERING_DEFAULT -DTHREADED_RENDERING_DEFAULT -DNDEBUG -flto -DRELEASE -funroll-loops -DHAVE_TEXUPSCALE -DHAVE_OPENGLES -DHAVE_OPENGLES2 -DFLAC__HAS_OGG=0 -DFLAC__NO_DLL -DHAVE_LROUND -DHAVE_STDINT_H -DHAVE_STDLIB_H -DHAVE_SYS_PARAM_H -D_7ZIP_ST -DUSE_FLAC -DUSE_LZMA -O3 -c -fno-strict-aliasing -ffast-math -fomit-frame-pointer -fPIC  -mfloat-abi=hard -O2 -march=armv8-a+crc -mtune=cortex-a72 -mfpu=neon-fp-armv8 -mfloat-abi=hard -ftree-vectorize -funsafe-math-optimizations -DGIT_VERSION=\"" 4565fe0"\" -marm -mfloat-abi=hard -mcpu=cortex-a72 -mtune=cortex-a72 -mfpu=neon-vfpv4 -DNO_ASM -DARM_ASM -frename-registers -ftree-vectorize -mvectorize-with-neon-quad -DHOST_CPU=0x20000002 -fopenmp -std=c++11 -D__LIBRETRO__  -DHAVE_GLSYM_PRIVATE -DNO_VERIFY -DRPI4_SET_UNIFORM_ATTRIBUTES_BUG -fno-builtin-sqrtf -DTHREADED_RENDERING_DEFAULT -DTHREADED_RENDERING_DEFAULT -DNDEBUG -flto -DRELEASE -funroll-loops -DHAVE_TEXUPSCALE -DHAVE_OPENGLES -DHAVE_OPENGLES2 -DFLAC__HAS_OGG=0 -DFLAC__NO_DLL -DHAVE_LROUND -DHAVE_STDINT_H -DHAVE_STDLIB_H -DHAVE_SYS_PARAM_H -D_7ZIP_ST -DUSE_FLAC -DUSE_LZMA -fno-rtti -fpermissive -fno-operator-names -fPIC core/rend/gles/gldraw.cpp -o core/rend/gles/gldraw.o
    core/rend/gles/gles.cpp: In function ‘void findGLVersion()’:
    core/rend/gles/gles.cpp:412:19: error: ‘GL_MINOR_VERSION’ was not declared in this scope
         glGetIntegerv(GL_MINOR_VERSION, &gl.gl_minor);
                       ^~~~~~~~~~~~~~~~
    core/rend/gles/gles.cpp:412:19: note: suggested alternative: ‘GL_MAJOR_VERSION’
         glGetIntegerv(GL_MINOR_VERSION, &gl.gl_minor);
                       ^~~~~~~~~~~~~~~~
                       GL_MAJOR_VERSION
    make: *** [Makefile:1089: core/rend/gles/gles.o] Error 1
    make: *** Waiting for unfinished jobs....
    /home/pi
    Could not successfully build lr-flycast - Dreamcast emulator - Reicast port for libretro (/home/pi/RetroPie-Setup/tmp/build/lr-flycast/flycast_libretro.so not found).
    
    Log ended at: Tue 11 Feb 20:15:33 GMT 2020
    Total running time: 0 hours, 1 mins, 3 secs
    


  • Same here. Looks like a missing lib or it's being put in the wrong place. I assume it will be corrected soon.



  • This post is deleted!

  • administrators

    I will make it build from the commit before it broke while we wait for upstream to fix. It's been reported.


  • Global Moderator

    Might worth to wait, there's a PR for fix that, but it's not merged to the master branch yet.


  • administrators

    The second WIP one fixes it? https://github.com/libretro/flycast/pull/814 ?

    I would be inclined to wait but I was in the middle of updating experimental package bins. Also I've done the changes - just testing. Can be reverted easily enough when upstream is fixed.


  • administrators

    Ah. On a different branch there's a fix? I'll check.


  • administrators

    Should build now btw.



  • @BuZz It builds but games won't run. I tried a few other games with the same results.

    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-flycast/flycast_libretro.so </dev/null --config /opt/retropie/configs/dreamcast/retroarch.cfg "/home/pi/RetroPie/roms/dreamcast/Marvel vs. Capcom 2.chd" --appendconfig /dev/shm/retroarch.cfg
    /opt/retropie/supplementary/runcommand/runcommand.sh: line 1247:  3665 Bus error               /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-flycast/flycast_libretro.so --config /opt/retropie/configs/dreamcast/retroarch.cfg "/home/pi/RetroPie/roms/dreamcast/Marvel vs. Capcom 2.chd" --appendconfig /dev/shm/retroarch.cfg < /dev/null```

  • administrators

    @Darksavior it was ok here. But I'll retest in case I messed up. Rpi4 right?



  • @BuZz Yes, I'll rebuild again just in case. My only mod to building is -j4 if it matters.


  • administrators

    @Darksavior it shouldn't if it built without failure. Maybe sure any overclocking is disabled also. I just rebuilt it here with a fresh checkout but not tested as I have another large compile job I'm waiting to finish first.


  • administrators

    I fixed an issue with the linking stage (the core is set to do link time optimisation), but it wasn't passing the processor flags which gave loads of warnings as it was linking with -march=armv6 . Technically this should improve things though. Possibly even performance (although I'm unsure as I'm unfamiliar with lto). Before it threw up lots of warnings about deprecated arm code, which does point to the the final binary not being optimised for armv8. So if anything performance should be better.

    I just tested with ikaruga and it worked fine here. Your error looks like it may be due to unstable overclock. I've seen similar errors before.



  • @BuZz I found the problem. Chd seems to be broken. None of my chd's work. I tested the gdi version of the same game and it works. I also tried a cdi game and that works. I'll rebuild again with your new changes.

    Redream loads my chd's just fine so the games work.


  • administrators

    @Darksavior maybe another recent change broke CHD. Please email me a link to a test file (see my profile for email), and I'll work out when it broke, or if my change caused it.


  • administrators

    @Darksavior no new changes since you last built. That was a change I did earlier. Sorry for confusion, was just detailing what I changed earlier apart from rolling back the code a few commits.



  • @BuZz Sorry for the delay. Sent. I don't remember when I last built flycast that worked with chd. It was either earlier this week or last week.
    Looks like it just got reported as a problem: https://github.com/libretro/flycast/issues/816


  • administrators

    @Darksavior that's good in a way as it means I didn't break it :-)

    I'll bisect it and maybe roll back/revert whatever broke it until it's fixed upstream.


  • administrators

    @Darksavior I didn't manage to build a revision that worked with a Dreamcast CHD (didn't try Naomi). Some older revisions didn't crash but just didn't recognise it. I'll revisit this but best bet is to wait for upstream to fix the various issues for now I guess.



  • Had the same issue with lr-Flycast and runncommand log points to line 1247 of the runcommand but it seems unrelated. I did notice this on line 1227:

    if [[ "$(ps -o comm= -p $(ps -o ppid= -p $PPID))" != "emulationstatio" ]]; then
    

    Is that supposed to be "emulationstation" instead of "emulationstatio"?


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.